
Comprehensive 1.1 MS Office and MS Word Basics

UNIT -1:
Lesson 1

MICROSOFT OFFICE AND MS WORD
BASICS

1.0 OBJECTIVE

The main objective of this lesson is to explain what MS Office is and what comprises MS
office. It also explains some basics about how to work with MS WORD. After completing this
lesson you will be able to learn

- Basics of Microsoft Word and
- You can create documents using MS Word.

STRUCTURE

1. Introduction

1.1 Word

1.2 Excel

1.3 PowerPoint

1.4 Outlook/Entourage

1.5 Microsoft Access

1.6 Common features of various versions of MS Office

1.7 File Formats, Meta Data and Extensibility

2. MS Word: Getting Familiar with MS Word 2007 for Windows

2.1 The Microsoft Office Button

2.2 The Quick Access Toolbar

2.3 The Title Bar

2.4 The Ribbon

2.5 The Ruler

2.6 The Text Area

2.7 The Vertical and Horizontal Scroll Bars

2.8 The Status Bar

3. Understanding Document Views

4. Create Sample Data and Select Text
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5. Execute Commands with Keyboard Shortcuts

1. INTRODUCTION

Microsoft Office is a proprietary commercial office suite introduced by Microsoft in the
year 1989. It is available for the Windows and Macintosh platforms. The first version of Office
contained Microsoft Word, Microsoft Excel, and Microsoft PowerPoint. Microsoft Office is
reported to be used by over a billion people worldwide. The current version in the market is
Office 2013 for Windows, released on October 11, 2012. Brief description of the components of
MS Office Suite is given below.

1.1 Word

Microsoft Word is a word processor and was previously considered the main program in
Office. The first version of Word, released in the autumn of 1983, was for the MS-DOS
operating system. It’s proprietary .DOC format is considered a de facto standard, although Word
2007 can also use a new format called .DOCX. Word for Macintosh was released in 1985. Word
for Macintosh was the first graphical version of Microsoft Word. Word is used for Scripts and
other writing pieces. Microsoft Word is a word processing software package, which can be used to
type letters, reports, and other documents.

1.2 Excel

Microsoft Excel is a spreadsheet program. It is available for the Windows and OS X
platforms. Microsoft released the first version of Excel for the Macintosh OS in 1985, and the
first Windows version in November 1987. It is used to organize data into rows and columns. It is
also used to perform mathematical calculations.

1.3 PowerPoint

Microsoft PowerPoint is a presentation program for Windows and OS X. It is used to
create slide shows, composed of text, graphics, and other objects, which can be displayed on-
screen and shown by the presenter or printed out on transparencies or slides.

1.4 Outlook/Entourage

Microsoft Outlook is a personal information manager and an e-mail communication
software. It includes an e-mail client, calendar, and task manager and address book. On the Mac
OS, Microsoft offered several versions of Outlook in the late 1990s, but only for use with
Microsoft Exchange Server. In Office 2001, it introduced an alternative application with a
slightly different feature set called Microsoft Entourage. It reintroduced Outlook in Office 2011,
replacing Entourage.
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1.5 Microsoft Access

It is also known as Microsoft Office Access. It is a database management system from
Microsoft . It is a member of the Microsoft Office suite of applications, included in the
Professional and higher editions or sold separately. The current version, Microsoft Access 2013
was released by Microsoft with Office 2013. Microsoft Access stores data in its own format
based on the Access Jet Database Engine. It can also import or link directly to data stored in
other applications and databases.

1.6 Common features of various versions of MS Office

Most versions of Microsoft Office (including Office 97 and later) use their own tool kit
set and do not exactly match the native operating system. This is most apparent in Microsoft
Office XP and 2003, where the standard menus were replaced with a colored flat looking,
shadowed menu style. The user interface of a particular version of Microsoft Office often heavily
influences a subsequent version of Microsoft Windows. For example, the toolbar, colored
buttons and the gray-colored '3D' look of Office 4.3 were added to Windows 95, and the Ribbon,
introduced in Office 2007, has been incorporated into several applications bundled with
Windows 7.

1.7 File Formats, Meta Data and Extensibility

Microsoft Office prior to Office 2007 used proprietary file formats. This forced users
who share data to adopt the same software platform. Starting with Office 2007, the default file
format has been a version of Office Open XML. In 2008 Microsoft made the entire
documentation for the binary Office formats freely available. The Office 2010 and Service Pack
2 for office 2007 support the Open Document Format (ODF) for opening and saving documents.
Microsoft also provides the ability to remove metadata from Office documents as an integrated
feature of Office 2007 called the Document Inspector. Another major feature of MS Office Suite
is the ability for users to write add-ins (plug-ins) that extend the capabilities of an application by
adding custom commands and specialized features.

2. MS WORD: GETTING FAMILIAR WITH MS WORD 2007 FOR
WINDOWS

Microsoft Word is a word processing software package. You can use it to type letters,
reports, and other documents. This lesson teaches Microsoft Word 2007 basics. It will introduce
you to the Word window. You use this window to interact with Word. To begin this lesson,
switch on computer, click start button, go to programs, select Microsoft office and double click
on Microsoft Word 2007. The Microsoft Word window appears and your screen looks similar to
the one shown here.
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2.1 The Microsoft Office Button:

In the upper-left corner of the Word 2007 window is the Microsoft Office button. When
you click the button, a menu appears. You can use the menu to create a new file, open an
existing file, save a file, and perform many other tasks. The following figure shows you the
Microsoft Office Button.

2.2 The Quick Access Toolbar:

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access
toolbar provides you with access to commands you frequently use. By default Save, Undo, and
Redo appear on the Quick Access toolbar. You can use Save to save your file, Undo to rollback
an action you have taken, and Redo to reapply an action you have rolled back. You can add any
other commands which you need to use frequently. Following figure shows the Quick access
toolbar.
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2.3 The Title Bar:

Next to the Quick Access toolbar is the Title bar. The Title bar displays the title of the
document on which you are currently working. Word names the first new document you open as
Document1. As you open additional new documents, Word names them sequentially. When you
save your document, you assign the document a new name. Following figure shows the Title bar.

2.4 The Ribbon:

You use commands to tell Microsoft Word what to do. In Microsoft Word 2007, you use
the Ribbon to issue commands. The Ribbon is located near the top of the screen, below the
Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab displays several
related command groups. Within each group are related command buttons. You click buttons to
issue commands or to access menus and dialog boxes. You may also find a dialog box launcher
in the bottom-right corner of a group. Clicking the dialog box launcher gives you access to
additional commands via a dialog box.

2.5 The Ruler:

The ruler as shown below is found below the Ribbon.

You can use the ruler to change the format of your document quickly. If your ruler is not
visible, follow the steps listed here:
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1. Click the View tab to choose it.

2. Click the check box next to Ruler in the Show/Hide group. The ruler appears below the
Ribbon.

2.6 The Text Area:

Just below the ruler is a large area called the text area. You type your document in the
text area. The blinking vertical line in the upper-left corner of the text area is the cursor. It marks
the insertion point. As you type, your text displays at the cursor location. The horizontal line next
to the cursor marks the end of the document.

2.7 The Vertical and Horizontal Scroll Bars: The vertical and horizontal scroll bars
enable you to move up, down, and across your window simply by dragging the icon located on
the scroll bar. The vertical scroll bar is located along the right side of the screen. The horizontal
scroll bar is located just above the status bar. To move up and down your document, click and
drag the vertical scroll bar up and down. To move back and forth across your document, click
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and drag the horizontal scroll bar back and forth. You won't see a horizontal scroll bar if the
width of your document fits on your screen.

2.8 The Status Bar:

The Status bar appears at the very bottom of your window and provides such information
as the current page and the number of words in your document. You can change what displays
on the Status bar by right-clicking on the Status bar and selecting the options you want from the
Customize Status Bar menu. You click a menu item to select it. You click it again to deselect it.
A check mark next to an item means it is selected.

3. Understanding Document Views:

In Word 2007, you can display your document in one of five views: Draft, Web Layout,
Print Layout, Full Screen Reading, or Outline Layout.

Draft View: Draft view is the most frequently used view. You use Draft view to
quickly edit your document.

Web Layout: Web Layout view enables you to see your document as it would
appear in a browser such as Internet Explorer.



Acharya Nagarjuna University 1.8 Centre for Distance Education

Print Layout: The Print Layout view shows the document as it will look when it
is printed.

Reading Layout: Reading Layout view formats your screen to make reading
your document more comfortable.

Outline View: Outline view displays the document in outline form. You can
display headings without the text. If you move a heading, the accompanying text
moves with it.

1. Click the View tab.
2. Click Draft in the Document Views group. When the Draft option is selected it appears in

a contrasting color.

Click: During the lessons that follow, you will be asked to "click" items and to choose tabs.

When asked to click:

1. Point to the item.
2. Press your left mouse button once.

If you are asked to double-click an item:

1. Point to the item.
2. Quickly press your left mouse button twice.

If you are asked to right-click:

1. Point to the item.
2. Press your right mouse button.

If you are asked to choose a tab, click the tab.
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1. Choose the Home tab.

2. Click the Show/Hide button in the Paragraph group. The Show/Hide button appears in
a contrasting color, when it is selected.

4. Create Sample Data and Select Text

If you type =rand() in your Word document and then press Enter, Word creates three
paragraphs. You can use these paragraphs to practice what you learn. Throughout these lessons,
you will be asked to select text. The following exercise teaches you how to create data and how
to select data. You can select by using the arrow keys or by clicking and dragging. When using
the arrow keys, use the up arrow to move up, the down arrow to move down, the left arrow to
move left, and the right arrow to move right. When using the mouse, press the left mouse button
and then drag in the direction you want to move.

EXERCISE 1

Create Sample Data

1. Type =rand().
2. Press Enter. Three paragraphs appear in your document.

Select with the Shift and Arrow Keys

1. Place your cursor before the word "On" in the first paragraph.
2. Press and hold down the Shift key, which serves as an "anchor" showing where text you

wish to select begins or ends.
3. Press the right arrow key until the first line of text is highlighted.
4. Press the down arrow key until the first paragraph is highlighted.
5. Click anywhere outside the highlighted area to remove the highlighting.

Select with the Mouse

1. Place your cursor before the word "You" in the second paragraph.
2. Press and hold down the left mouse button.
3. Drag the mouse until you have highlighted the second paragraph.
4. Click anywhere outside the highlighted area to remove the highlighting.
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Place the Cursor

During the lessons, you will often be asked to place the cursor at a specific location (the
insertion point) on the screen. You place the cursor by moving the cursor to the specified
location and pressing the left mouse button or by using the arrow keys to move to the specified
location.

EXERCISE 2

The Arrow Keys

1. Use the down arrow key to move down your document.
2. Use the right arrow key to move to the right.
3. Use the up arrow key to move up.
4. Use the left arrow key to move to the left.

Cursor

1. Move around you document by using you mouse and clicking in a variety of location.
2. Click in a location and type. Note what happens.

5. Execute Commands with Keyboard Shortcuts

There are many methods you can use to accomplish tasks when using Word. Generally,
you choose an option by clicking the option on the Ribbon. However, you can also use shortcut
keys. A key name followed by a plus and a letter means to hold down the key while pressing the
letter. For example, Ctrl+b means you should hold down the Ctrl key while pressing "b." A
shorthand notation of the above would read as follows:

Press Ctrl+b

Start a New Paragraph

When you type in Microsoft Word, you do not need to press a key to move to a new line.
To start a new paragraph, press the Enter key. You can save your work and exit word.
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1. Click the Microsoft Office button. A menu appears.
2. Click Exit Word, which you can find in the bottom-right corner.

3. You are prompted: "Do you want to save changes to Document1?" To save your changes,
click Yes. Otherwise, click No. If you click Yes, the Save As dialog box appears.

4. Move to the correct folder.
5. Name your file by typing Lesson One.doc in the File Name field.
6. Click Save. Word saves your file.
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LESSON 2

MICROSOFT WORD 2007 BASIC FEATURES

2.0 Objective

Previous Lesson familiarized you with the Microsoft Word window. You are now ready
to learn how to create a Word document. This lesson covers the functions of typing, using the
Backspace key, Delete key, inserting text, bolding, underlining, and italicizing.

After studying this lesson you will be able to

- create a document by typing
- edit the text
- format the text

Structure

1. Type, Backspace, and Delete

2. Insert and Overtype

3. Bold, Italicize, and Underline

4. Underline with the Dialog Box Launcher

5. Save a File and Close Word

1. Type, Backspace, and Delete

In Microsoft Word, you create documents by typing them. For example, if you want to
create a report, you open Microsoft Word and then begin typing. You do not have to do anything
when your text reaches the end of a line and you want to move to a new line. Microsoft Word
automatically moves your text to a new line. If you want to start a new paragraph, press Enter.
Microsoft word creates a blank line to indicate the start of a new paragraph. To capitalize, hold
down the Shift key while typing the letter you want to capitalize. If you make a mistake, you
can delete what you typed and then type your correction.

You can use the Backspace key to delete. Each time you press the Backspace key,
Microsoft Word deletes the character that precedes the insertion point. The insertion point is the
point at which your mouse pointer is located. You can also delete text by using the Delete key.
First, you select the text you want to delete; then you press the Delete key.
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EXERCISE 3

Type and Backspace

1. Type the following sentence:
We are the students of M.L.I.Sc. class.

2. Delete the word "class." Using either the arrow keys or the mouse, place the cursor
between the period and the "s" in "class."

3. Press the Backspace key until the word "class" is deleted.
4. Type Course. The sentence should now read:
5. We are the students of M.L.I.Sc. Course.

Delete

Delete the word "the" from the sentence you just typed.

1. Select the word "the." You can place the cursor before the "t" in the word "the," press and
hold down the Shift key, and then press the right arrow key until the word "the" is
highlighted.

2. Press the Delete key. The sentence should now read:
We are students of M.L.I.Sc. Course.

2. Insert and Overtype

While creating your document, you may find you need to place new text between
existing text. Suppose, you type the sentence, "We are students of M.L.I.Sc. Course." After
typing it, you decide you want to change the sentence to "We are girl students of M.L.I.Sc.
Course." With Microsoft Word, inserting a word, phrase, or even several paragraphs is easy.
Alternatively, you may want to replace old text with new text. For example, suppose you type
the sentence, " We are girl students of M.L.I.Sc. Course." After typing it, you decide you want to
change the sentence to "We are male students of M.L.I.Sc. Course." With Microsoft Word,
overtyping the word ‘girl’ with the word ‘male’ is also easy. Before you attempt to insert or
overtype, you should check the mode you are in “Insert or Overtype”. You right click the Status
bar and then use the Customize Status Bar menu to place the Insert/Overtype button on the
Status bar. You can then use the Insert/Overtype button to switch between Insert and Overtype
mode. When you are in Insert mode, you can insert text. When you are in Overtype mode, you
can overtype text. By default, Microsoft Word is in the Insert mode.

EXERCISE 4

Placing the Insert/Overtype button on the Status bar

1. Right-click the Status bar. The Customize Status Bar menu appears.
2. Click Overtype. The Insert/Overtype button appears on the Status bar.
3. If the word Insert appears on the Status bar, you are in Insert mode.
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4. If the word Overtype appears on the Status bar, click the word Overtype and it will
change to Insert, thereby changing Word to Insert mode.

Insert

Make sure you are in Insert mode before proceeding. You are going to insert the word
"girl" between the words "are" and "students."

1. Place the cursor after the space between the words "are" and "students."
2. Type the word girl.
3. Press the spacebar to add a space.
4. The sentence should now read:

"We are girl students of M.L.I.Sc. Course."

Overtype

You can type over the current text (replace the current text with new text) in the Overtype
mode. Do the following to change to the Overtype mode.

 Click "Insert" on the Status bar. The word Insert changes to Overtype.

Change the word "girl" to "male."

1. Place the cursor before the letter "g" in "girl."
2. Type the word male.
3. The sentence should now read:

"We are male students of M.L.I.Sc. Course."

Note: You can overtype text without changing to Overtype mode by selecting the text
you want to overtype and then typing on the highlighted area.

3. Bold, Italicize, and Underline

When creating a document, you may need to emphasize particular words or phrases by
bolding, underlining, or italicizing. You can bold, underline, and italicize when using Word.
When you need to perform a task in Microsoft Word, you can usually choose from several
methods. The exercises that follow show you how to bold, underline, or italicize using four
different methods: using the launcher, the Ribbon, the Mini-toolbar/context menu, and the
keyboard.

EXERCISE 5

Type the following exactly as shown. Remember, pressing the Enter key starts a new
paragraph. Press the Enter key at the end of each of the following lines to start a new paragraph.

Launcher: Bold Italicize Underline these words. All three Regular
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Ribbon: Bold Italicize Underline these words. All three Regular

Mini Toolbar: Bold Italicize Regular

Keys: Bold Italicize Underline these words. All three Regular

Your screen should look similar to the one shown here.

Bold with the Dialog Box Launcher

1. On the line that begins with Launcher, select the word "Bold." You can place the cursor
before the letter "B" in "Bold." Press the Shift key; then press the right arrow key until
the entire word is highlighted.

2. Choose the Home tab.
3. Click the dialog box launcher in the Font group. The Font dialog box appears.



Comprehensive 2.5 MS Word 2007 Basic Features

4. Click Bold in the Font Style box.
Note: You can see the effect of your action in the Preview window. To remove the bold,
click Regular.

5. Click OK to close the dialog box.
6. Click anywhere in the text area to remove the highlighting. You have bolded the word

bold.

Alternate Method—Bold with the Ribbon

1. On the line that begins with "Ribbon," select the word "Bold." You can place the cursor
before the letter "B" in "Bold." Press the Shift key; then press the right arrow key until
the entire word is highlighted.

2. Choose the Home tab.

3. Click the Bold button in the Font group. You have bolded the word bold.

Note: To remove the bold, you can select the text and then click the Bold button
again.
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4. Click anywhere in the text area to remove the highlighting.

Alternate Method - Bold with the Mini Toolbar

1. On the line that begins with "Mini Toolbar," select the word "Bold." You can place the
cursor before the letter "B" in "Bold."Press the Shift key; then press the right arrow key
until the entire word is highlighted.

2. Right-click. The Mini toolbar appears.

3. Click the Bold button . You have bolded the word bold.

Alternate Method—Bold with Keys

1. On the line that begins with "Keys," select the word "Bold." You can place the cursor
before the letter "B" in "Bold." Press the Shift key; then press the right arrow key until
the entire word is highlighted.

2. Press Ctrl+b (hold down the Ctrl key while pressing b).
Note: To remove the Bold, press Ctrl+b again. You can also remove formatting by
pressing Ctrl+spacebar.

3. Click anywhere in the text area to remove the highlighting.

Italicize with the Dialog Box Launcher
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1. On the line that begins with Launcher, select the word "Italicize." You can place the
cursor before the letter "I" in "Italicize." Press the Shift key; then press the right arrow
key until the entire word is highlighted.

2. Choose the Home tab.
3. Click the dialog box launcher in the Font group. The Font dialog box appears.

4. Click Italic in the Font Style box.
Note: You can see the effect of your selection in the Preview window. To remove the
italics, click Regular in the Font Style box.

5. Click OK to close the Font dialog box.
6. Click anywhere in the text area to remove the highlighting. You have italicized the word

Italicize.
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Alternate Method—Italicize with the Ribbon

1. On the line that begins with "Ribbon," select the word "Italicize." You can place the
cursor before the letter "I" in "Italicize." Press the Shift key; then press the right arrow
key until the entire word is highlighted.

2. Choose the Home tab.

3. Click the Italic button on the Ribbon. You have italicized the word Italicize.

Note: To remove the italics, select the text and click the Italicize button again.
4. Click anywhere in the text area to remove the highlighting.

Alternate Method—Italicize with the Mini Toolbar

1. On the line that begins with "Mini Toolbar," select the word "Italicize." You can place
the cursor before the letter "I" in "Italicize." Press the Shift key; then press the right
arrow key until the entire word is highlighted.

2. Right-click. The Mini toolbar appears.
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3. Click the Italic button . You have italicized the word Italicize.

Alternate Method—Italicize with Keys

1. On the line that begins with "Keys," select the word "Italicize." You can place the cursor
before the letter "I" in "Italicize." Press the Shift key; then press the right arrow key until
the entire word is highlighted.

2. Press Ctrl+i (hold down the Ctrl key while pressing i).
Note: To remove italics, press Ctrl+i again. You can also remove formatting by pressing
Ctrl+spacebar.

3. Click anywhere in the text area to remove the highlighting.You have italicized the word
Italicize.

4. Underline with the Dialog Box Launcher

You can underline when using Word. Word provides you with many types of underlines
from which to choose.The following are some of the underlines that are available if you use the
dialog box launcher:

The following illustrates underlining with the dialog box launcher:
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1. On the line that begins with "Launcher," select the words "Underline these words."
2. Choose the Home tab.
3. Click the dialog box launcher in the Font group. The Font dialog box appears.

4. In the Underline Style box, click the down arrow to open the pull-down menu.
5. Click the type of underline you wish to use.

Note: To remove an underline, you select None from the pull-down menu.
6. Click OK to close the dialog box. The underline you selected appears under the words.
7. Click anywhere in the text area to remove the highlighting.
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Alternate Method—Underline with the Ribbon

1. On the line that begins with "Ribbon," select the words "Underline these words."
2. Choose the Home tab.

3. Click the Underline button in the Font group . Alternatively, you can press the down

arrow next to the underline button and click to choose the type of underline you
want.

Note: To remove the underlining, click the Underline button again.
4. Click anywhere in the text area to remove the highlighting.

Alternate Method—Underline with Keys

1. On the line that begins with "Keys," select the words "Underline these words."
2. Press Ctrl+u (hold down the Ctrl key while pressing u).

Note: To remove the underlining, press Ctrl+u again.
3. Click anywhere in the text area to remove the highlighting.

All Three with the Dialog Box Launcher

1. On the line that begins with "Launcher," select the words "All three."
2. Choose the Home tab.
3. Click the dialog box launcher in the Font group. The Font dialog box appears.
4. In the Font Style box, click Bold Italic.

Note: You can see the effect of your selection in the preview window. To turn off the
Bold Italic, click Regular.

5. In the Underline box, click to open the pull-down menu. Click the type of underline you
want to use.
Note: To remove an underline, select None from the pull-down menu.

6. Click OK to close the dialog box.
7. Click anywhere in the text area to remove the highlighting.
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Alternate Method—All Three with the Ribbon

1. On the line that begins with "Ribbon," select the words "All three."
2. Choose the Home tab.

3. Click the Bold button in the Font group.

4. Click the Italic button in the Font group.

5. Click the Underline button in the Font group.
6. Click anywhere in the text area to remove the highlighting.

Alternate Method—All Three with Keys

1. On the line that begins with "Keys," select the words "All three."
2. Press Ctrl+b (bold).
3. Press Ctrl+i (italicize).
4. Press Ctrl+u (underline).
5. Click anywhere in the text area to remove the highlighting.

5. Save File and Close Word

You must save your documents if you wish to recall them later. You can use the Save
option on the Microsoft Office menu, to save a document. You can also save a document by
typing Ctrl+s. The first time you save a document, the Save As dialog box appears. Use the
Save As dialog box to locate the folder in which you want to save your document and to give
your document a name. After you have saved your document at least once, you can save any
changes you make to your document simply by clicking the Save after you click the Microsoft
Office button.

The following exercise shows you how to save the file you just created and close Word.
You will name your file Lesson Two or with whatever name you can identify the document in
future.

EXERCISE 6

Save File—Windows:



Comprehensive 2.13 MS Word 2007 Basic Features

1. Click the Microsoft Office button. A menu appears.
2. Click Save. The Save As dialog box appears, if you are saving your document for the

first time.

3. Use the Address bar to locate the folder in which you want to save your file.
4. Name your file by typing Lesson Two.docx in the File Name box.
5. Click Save.
6. Click the Microsoft Office button. A menu appears.
7. Click Exit Word, which is located in the bottom-right corner of the window. Word

closes.

Every time you save your document, you overwrite the previous version of your
document. For example, you create a document and save it. Later you delete several passages
from the document and then save your changes. The passages from the first draft of the
document no longer exist. If you want to save both the original draft of your document and the
revised document, you must save the second draft of the document using a different name. To
save the document using a different name, click the Microsoft Office button. A menu appears.
Click Save As. The Save As dialog box appears. Use the File Name box to give your document a
new name.
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LESSON 3

MORE BASIC FEATURES OF MS WORD

3.0. Objective

The objective of this lesson is to explain the additional basic features of MS Word to help
you in creating and editing documents.

After studying this lesson you can learn to

- edit the document with cut and paste
- spell check the document
- find and replace the words in the text
- to use different fonts

Structure

1. Open a File

2. Cut and Paste

3. Copy and Paste

4. Use the Clipboard

5. Use Spell Check

6. Find and Replace

7. Change the Font Size

8. Change the Font

1. Open a File

When you do not have time to complete your work or when you finish your work, you
can save and close your file. After saving a file, you can later open it to revise or finish it. The
previous lesson explained you about how to save a file. In the exercises that follow, you can
learn how to open the file you saved.

EXERCISE 7

Open a File

1. Open Word 2007.
2. Click the Microsoft Office button. A menu appears.
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3. Click Open. The Open dialog box appears.
4. Locate the folder in which you saved the file. The file is named Lesson Two.docx.
5. Click Lesson Two.docx.
6. Click Open. The file you created during the previous lesson appears.

Alternate Method—Opening a File with Keys

1. Open Word 2007.
2. Press Ctrl+o.
3. Locate the folder in which you saved your file. The file is named Lesson Two.docx
4. Click Lesson Two.docx.
5. Click Open. The file you created during the previous lesson appears.

2. Cut and Paste

You can use Word's Cut feature to remove information from a document. Then you can
use the Paste feature to place the information you cut anywhere in the same or another
document. In other words, you can move information from one place in a document to another
place in the same or different document by using the Cut and Paste features. The Office
Clipboard is a storage area. When you cut, Word stores the data you cut on the Clipboard. You
can paste the information that is stored on the Clipboard as often as you like.

EXERCISE 8

Cut with the Ribbon

1. Type the following:
I want to move. I am content where I am.

2. Select "I want to move."
3. Choose the Home tab.
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4. Click the Cut button in the Clipboard group. Word cuts the text you selected and
places it on the Clipboard. Your text should now read:
"I am content where I am.”

Paste with the Ribbon

1. Place the cursor after the period in the sentence "I am content where I am."
2. Press the spacebar to leave a space.
3. Choose the Home tab.

4. Click the Paste button in the Clipboard group. Word pastes the text on the Clipboard.
Your text should now read:
"I am content where I am. I want to move."

Alternate Method—Cut with a Context Menu
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1. Type the following:
I want to move. I am content where I am.

2. Select "I want to move."
3. Right-click. The Mini toolbar and a context menu appear.
4. Click Cut on the menu. Your text should now read:

"I am content where I am."

Alternate Method—Paste with a Context Menu

1. Place the cursor after the period in the sentence
"I am content where I am."

2. Press the spacebar to leave a space.
3. Right-click. A Mini toolbar and a context menu appear.
4. Click Paste. Your text should now read:

"I am content where I am. I want to move."

Alternate Method—Cut with Keys

1. Type the following:
I want to move. I am content where I am.

2. Select "I want to move."
3. Press Ctrl+x.
4. Your text should now read:

" I am content where I am."

Alternate Method—Paste with Keys

1. Place the cursor after the period in the sentence: "I am content where I am."
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2. Press the spacebar to leave a space.
3. Press Ctrl+v.
4. Your text should now read:

"I am content where I am. I want to move."

3. Copy and Paste

In Microsoft Word, you can copy information from one area of a document and place the
information you copied anywhere in the same or another document. In other words, after you
type information into a document, if you want to place the same information somewhere else,
you do not have to retype the information. You can copy it and then paste it in the new location.
As with cut data, Word stores copied data on the Clipboard.

EXERCISE 9

Copy with the Ribbon

1. Type the following:
You will want to copy me. One of me is all you need.

2. Select "You will want to copy me."
3. Choose the Home tab.

4. Click the Copy button in the Clipboard group. Word copies the data you selected to
the Clipboard.
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Paste with the Ribbon

1. Place the cursor after the period in the sentence: "One of me is all you need."
2. Press the spacebar to leave a space.
3. Choose the Home tab.

4. Click the Paste button in the Clipboard group. Word places the data you copied at the
insertion point. Your text should now read: "You will want to copy me. One of me is all
you need. You will want to copy me."

Alternate Method—Copy with a Context Menu

1. Type the following:
You will want to copy me. One of me is all you need.

2. Select "You will want to copy me."
3. Right-click. A Mini toolbar and a context menu appear.
4. Click Copy. Word places the data you copied at the insertion point. Your text should now

read: "You will want to copy me. One of me is all you need. You will want to copy me."
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Alternate Method—Paste with a Context Menu

1. Place the cursor after the period in the sentence: "One of me is all you need."
2. Press the spacebar to leave a space.
3. Right-click. A context menu appears.
4. Click Paste. Word pastes the information on the Clipboard into the document.

Alternate Method—Copy with Keys

1. Type the following:
You will want to copy me. One of me is all you need.

2. Select "You will want to copy me. "
3. Press Ctrl+c. Word copies the information you selected to the Clipboard.

Alternate Method—Paste with Keys

1. Place the cursor after the period in the sentence "One of me is all you need."
2. Press the spacebar to leave a space.
3. Press Ctrl+v.
4. Your text should now read:

"You will want to copy me. One of me is all you need. You will want to copy me."

4. Use the Clipboard

As you cut or copy, Word can store the information you have cut or copied on the
Clipboard in a hierarchy. Then each time you cut or copy, the data you just cut or copied moves
to the top of the Clipboard hierarchy and the data previously at the top moves down one level.
When you choose Paste, the item at the top of the hierarchy is the item Word pastes into your
document. The Clipboard can store up to 24 items. You can paste any item on the Clipboard into
your document by placing your cursor at the insertion point, displaying the Clipboard pane, and
then clicking the item. The Clipboard pane includes an Options button. You can click the
Options button to set the Clipboard options described in the following table:
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Option Description

Show Office Clipboard
Automatically

Shows the Clipboard automatically when you
copy items.

Show Office Clipboard When Ctrl+c
Pressed Twice

Shows the Clipboard when you press Ctrl+c
twice.

Collect Without Showing Office
Clipboard

Copies to the Clipboard without displaying the
Clipboard pane.

Show Office Clipboard Icon on
Taskbar

Displays the Clipboard icon on your system
taskbar.

Show Status Near Taskbar When
Copying

Displays the number of items copied on the
taskbar when copying.

EXERCISE 10

Use the Clipboard

1. Place the cursor at the point at which you want to insert your text.
2. Choose the Home tab.
3. Click the Clipboard dialog box launcher to open the Clipboard.
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4. Click the item on the clipboard you want to insert into your document. Word pastes the
Clipboard item into your document at the insertion point.

Create AutoText

Cut and Copy both store information on the Clipboard. Information you store on the
Clipboard is eventually lost. If you want to store information permanently for reuse, use
AutoText. AutoText permanently stores information for future use.

EXERCISE 11

Create AutoText

1. Type the following:
AutoText information is stored permanently.

2. Select "AutoText information is stored permanently."
3. Choose the Insert tab.
4. Click Quick Parts in the Text group. A menu appears.
5. Click Save Selection to Quick Part Gallery. The Create New Building Block dialog box

appears.
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6. Microsoft Word suggests a name. Change the name by typing AT in the Name field.
7. Click OK. The dialog box closes.
8. Click anywhere in the text area to remove the highlighting.
9. Place the cursor between the period in the sentence you just typed and the paragraph

marker (¶).
10. Press the spacebar to leave a blank space.
11. Type AT.
12. Press F3. Your text should now read:

"AutoText information is stored permanently. AutoText information is stored
permanently."

Note: Whenever you need the text, simply type the name (AT) and then press F3.

5. Use Spell Check

Word checks your spelling and grammar as you type. Spelling errors display with a red
wavy line under the word. Grammar errors display with a green wavy line under the error. In
Word 2007, you can use the Review tab's Spelling & Grammar button to initiate a spell and
grammar check of your document.

EXERCISE 12

Use Spell Check

1. Type the following exactly as shown. Include all errors.
Open thr door for Mayrala. She is a teacher from the town of Ridgemont.

2. Select: "Open thr door for Mayrala. She is a teacher from the town of Ridgemont."
3. Choose the Review tab.
4. Click the Spelling & Grammar button. The Spelling and Grammar dialog box appears.
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6. "The" is misspelled, so it is highlighted on the screen and noted in the Not in Dictionary
box. Word suggests correct spellings. These suggestions are found in the Suggestions
box.

7. Click "the" in the Suggestions box.
8. Click Change.

Note: If the word is misspelled in several places, click Change All to correct all
misspellings.

9. The name "Mayrala" is not in the dictionary, but it is correct. Click Ignore Once to leave
"Mayrala" in the document with its current spelling.
Note: If a word appears in several places in the document, click Ignore All so you are not
prompted to correct the spelling for each occurrence.

10. "Ridgemont" is not found in the dictionary. If you frequently use a word not found in the
dictionary, you might want to add that word to the dictionary by clicking the Add to
Dictionary button. Word will then recognize the word the next time it appears. Click Add
to Dictionary.

11. The following should appear on your screen: "Word finished checking the selection. Do
you want to continue checking the remainder of the document?"

12. Click No or Yes depending on your requirement.

Note: You can also press F7 to initiate a spelling and grammar check. If you don't have
anything selected, Word checks the entire document.

6. Find and Replace

If you need to find a particular word or phrase in your document, you can use the Find
command. This command is especially useful when you are working with large files. If you want
to search the entire document, simply execute the Find command. If you want to limit your
search to a selected area, select that area and then execute the Find command.
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After you find the word or phrase you are searching for, you can replace it with new text
by executing the Replace command.

EXERCISE 13

Use Find with the Ribbon

1. Type the following:
Monica is from Easton. She lives on the east side of town. Her daughter attends
Eastern High School.

2. Select: "Monica is from Easton. She lives on the east side of town. Her daughter attends
Eastern High School."

3. Choose the Home tab.
4. Click Find in the Editing group. A menu appears.
5. Click the Find option on the menu. The Find and Replace dialog box appears.

6. Type east in the Find What field.
7. Click Find Next.

Note that the "East" in Easton is highlighted.
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8. Click Find Next again.
Note that "east" is highlighted.

9. Click Find Next again.
Note that the "East" in Eastern is highlighted.

10. Click Find Next. The following message should appear: "Word has finished searching
the selection. Do you want to search the remainder of the document?"

11. Click No.
12. Click Cancel.

Alternate Method—Find with Keys

1. Select: "Monica is from Easton. She lives on the east side of town. Her daughter attends
Eastern High School."

2. Press Ctrl+f.
3. Follow steps 6 through 12 in the preceding section.

Use Replace with the Ribbon

1. Select "Monica is from Easton. She lives on the east side of town. Her daughter attends
Eastern High School."

2. Choose the Home tab.
3. Click Replace in the Editing group. The Find and Replace dialog box appears.
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4. Type east in the Find What box.
5. Type west in the Replace With box.
6. Click Find Next. The East in Easton is highlighted.
7. Click Replace. Word replaces the "East" in "Easton" with "West" and then highlights the

word "east."
8. Click Replace. Word replaces the word "east" with "west" and then highlights the word

"Eastern."
9. Click Close. Do not replace the "East" in "Eastern" with "West."
10. Your text should now read,

"Monica is from Weston. She lives on the west side of town. Her daughter attends
Eastern High School."

Alternate Method—Replace with Keys

1. Select "Monica is from Easton. She lives on the west side of town. Her daughter attends
Western High School."

2. Press Ctrl+h.
3. Follow steps 4 through 11 in the preceding section.

7. Change the Font Size

A font is a set of characters (text) represented in a single typeface. Each character within
a font is created by using the same basic style. In Microsoft Word, you can change the size of
your font. The following exercise illustrates changing the font size.

EXERCISE 14

Change the Font Size
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1. Type the following:
I can be any size you want me to be.

2. Select "I can be any size you want me to be."
3. Choose the Home tab.
4. In the Font group, click the down arrow next to the Font Size box. A menu of font sizes

appears.
5. Move your cursor over the menu of font sizes. As you do, Word 2007 provides a live

preview of the effect of applying each font size.
6. Click 36 to select it as your font size.

Note: If you know the font size you want, you can type it in the Font Size field.

Alternate Method—Change the Font Size with Grow Font and Shrink Font

You can also change the size of your font by clicking the Grow Font and Shrink Font
buttons. Selecting text and then clicking the Grow Font button makes your font larger. Selecting
text and then clicking the Shrink Font button makes your font smaller.

1. Type the following:
Grow Shrink

2. Select "Grow"
3. Choose the Home tab.

4. Click the Grow Font button several times. You font becomes larger

5. Click the Grow Font button several times. You font becomes larger.
6. Select Shrink.

7. Click the Shrink Font button several times. Your font becomes smaller.

8. Change the Font

In Microsoft Word, you can change the font (the "family" of type you use for your text).
This feature is illustrated in the following exercise:
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EXERCISE 15

Change the Font with the Ribbon

1. Type the following:
Changing fonts

2. Select "Changing fonts."
3. Choose the Home tab.
4. Click the down arrow next to the Font field. A menu of fonts appears.
5. Move the cursor over the list of fonts. Word 2007 provides a live preview of what the

font will look like if you select it.
6. Click the font name to select the font you want.
7. Alternate Method—Change the Font with the Mini Toolbar
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1. Select "Changing fonts."
2. Right-click. The Mini toolbar and a menu appears.
3. Move to the Mini toolbar.
4. Click the down arrow next to the Font field. A menu of fonts appears.
5. Click the name of the font you want.

Save Your File

You can save your file with name and close Word.
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LESSON 4

FORMATTING PARAGRAPHS AND WORKING WITH
STYLES

4.0. Objective
The objective of this lesson is to explain different commands and features available to

create and format paragraphs with different styles.

After studying this lesson you will be able to
- format paragraphs in the text
- apply different styles to the document

Structure

1. Introduction

2. Creating Paragraph

3. Change Line Spacing

4. Indentation

5. Align Paragraphs

6. Choose a Style Set

1. Introduction
When you type information into Microsoft Word, each time you press the Enter key

Word creates a new paragraph. You can format paragraphs. For example, you can indent the first
line of a paragraph, you can set the amount of space that separates paragraphs, and you can align
a paragraph left, right, center, or flush with both margins. Styles are a set of formats you can
quickly apply to a paragraph. For example, by applying a style, you can set the font, set the font
size, and align a paragraph all at once. In this lesson, you will learn about the various formats
you can apply to a paragraph and about styles.

When you are formatting a paragraph, you do not need to select the entire paragraph.
Placing the cursor anywhere in the paragraph enables you to format it. After you format a
paragraph, pressing the Enter key creates a new paragraph in the same format.

2. Creating Paragraph
Open a Blank Document

To begin this lesson, open a blank document in Microsoft Word.



Acharya Nagarjuna University 4.2 Centre for Distance Education

EXERCISE 1
Open a Blank Document

1. Open Word 2007.
2. Click the Microsoft Office button. A menu appears.
3. Click New. The New Document dialog box appears.
4. Click Blank Document.
5. Click Create. A new blank document opens.

Add Sample Text

This lesson uses sample text provided by Microsoft for training and demonstration
purposes. You can type the text; however, there is a quicker way. You can use the rand function.
Functions are used to obtain information. You tell the function what you want and the function
returns that information to you. By default, in Word, when you type the rand function, Word
returns three paragraphs. When working with functions, you use arguments to be specific about
what you want the function to return. There are two arguments you can use with the rand
function. The first one tells Word how many paragraphs you want, and the second one tells
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Word how many sentences you want in a paragraph. You place arguments between the
parentheses and you separate them with a comma. For example, if you type =rand() and then
press Enter, word returns three paragraphs. To tell Word you want two paragraphs with three
sentences in each paragraph, you type =rand(2,3).

EXERCISE 2

Add Sample Text

1. Type =rand().
2. Press the Enter key. The following text appears:

On the Insert tab, the galleries include items that are designed to coordinate with
the overall look of your document. You can use these galleries to insert tables,
headers, footers, lists, cover pages, and other document building blocks. When
you create pictures, charts, or diagrams, they also coordinate with your current
document look. ¶

You can easily change the formatting of selected text in the document text by
choosing a look for the selected text from the Quick Styles gallery on the Home
tab. You can also format text directly by using the other controls on the Home
tab. Most controls offer a choice of using the look from the current theme or
using a format that you specify directly. ¶

To change the overall look of your document, choose new Theme elements on the
Page Layout tab. To change the looks available in the Quick Style gallery, use the
Change Current Quick Style Set command. Both the Themes gallery and the Quick
Styles gallery provide reset commands so that you can always restore the look of your
document to the original contained in your current template. ¶

Add Space Before or After Paragraphs

When creating a document, space is often used to clearly identify where each paragraph
begins and ends. By default, Word may place slightly more space between paragraphs than it
does between lines in a paragraph. You can increase or decrease the amount of space that
appears before and after paragraphs by entering amounts in the Before and After fields in the
Paragraph section of the Page Layout tab. Use the up arrows next to the Before and After fields
to increase the amount of space before or after each paragraph; use the down arrows to decrease
the amount of space before or after each paragraph. The following illustrates:

EXERCISE 3

Add Space Before or After Paragraphs
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1. Place your cursor anywhere in the second para of the sample text you created in Exercise 2.
2. Choose the Page Layout tab. The default spacing appears in the Spacing Before field.
3. Click the up arrow next to the Spacing Before field to increase the space before the paragraph.
4. Click the up arrow next to the Spacing after field to increase the amount of space after the

paragraph.

Note: You can click the down arrows next to the Spacing Before and the Spacing After
fields to decrease the amount of space before or after a paragraph. You can also type the amount
of space you want to use directly into the fields. Space is measured in points. There are 72 points
to an inch.

3. Change Line Spacing

Line spacing sets the amount of space between lines within a paragraph. The spacing for
each line is set to accommodate the largest font on that line. If the lines include smaller fonts,
there will appear to be extra space between lines where the smaller fonts are located. At 1.5, the
line spacing is set to one-and-a-half times the single-space amount. At 2.0, the line spacing is set
to two times the single-space amount (double space).

EXERCISE 4

Change Line Spacing
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1. Place your cursor anywhere in the first paragraph of the sample text you created in
Exercise 2.

2. Choose the Home tab.

3. Click the Line Spacing button in the Paragraph group. A menu of options appears.
4. Click 2.0 to double-space the first paragraph.

4. Indentation

Create a First-Line Indent

Some people and organizations delineate the start of a new paragraph by indenting the
first line. If you want to indent the first line of your paragraphs, you can use the Paragraph dialog
box to set the amount by which you want to indent. In the Special Field of the Paragraph dialog
box, you tell Word you want to indent the first line by choosing First Line from the menu
options. In the by field, you tell Word the amount, in inches by which you want to indent.

EXAMPLE: First-line Indent

On the Insert tab, the galleries include items that are designed
to coordinate with the overall look of your document. You can use
these galleries to insert tables, headers, footers, lists, cover pages, and
other document building blocks. When you create pictures, charts, or
diagrams, they also coordinate with your current document look.

EXERCISE 5

Create a First-line Indent
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1. Place your cursor anywhere within the first paragraph of sample text you created in Exercise 2.
2. Choose the Home tab.
3. In the Paragraphs group, click the launcher. The Paragraph dialog box appears.

4. Choose the Indents and Spacing tab.
5. Click to open the drop-down menu on the Special field.
6. Click First Line.
7. Enter 0.5" in the By field.
8. Click OK. The first line of your paragraph is now indented half an inch.

Special Note: To remove the first line indent:
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1. Place the cursor anywhere in the paragraph.
2. Choose the Home tab.
3. In the Paragraphs group, click the launcher. The Paragraph dialog box opens.
4. Choose the Indents and Spacing tab.
5. Click the down arrow next to the Special field and then click None.
6. Click OK.

Indent Paragraphs

Indentation allows you to indent your paragraph from the left and/or right margin. You
may find this necessary when you are quoting a large block of text. The following exercise
shows you how to indent a paragraph 1 inch from each side.

EXAMPLE: Indentation

On the Insert tab, the galleries include items that are designed to coordinate with
the overall look of your document. You can use these galleries to insert tables,
headers, footers, lists, cover pages, and other document building blocks. When
you create pictures, charts, or diagrams, they also coordinate with your current
document look.

You can easily change the formatting of selected text in the
document text by choosing a look for the selected text
from the Quick Styles gallery on the Home tab. You can
also format text directly by using the other controls on the
Home tab. Most controls offer a choice of using the look
from the current theme or using a format that you specify
directly.

EXERCISE 6

Indent Paragraphs
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1. Place your cursor anywhere in the second paragraph of sample text you created in Exercise 2.
2. Choose the Page Layout tab.
3. Type 1" in the Indent Left field or use the up or down arrows to set the field value to 1".
4. Type 1" in the Indent Right field or use the up or down arrows to set the field value to 1". Your

paragraph is now indented one inch from both the left and right margins, as in the example.

Create a Hanging Indent

The hanging indent feature indents each line except the first line by the amount specified
in the By field, as shown in the example.

EXAMPLE:Hanging Indent

Hanging Indent: The hanging indent feature indents the first line of
the paragraph from the margin by the amount
specified in the Left field. The amount in the Left
field plus the amount specified in the By field
indent all subsequent lines.

EXERCISE 8

Create a Hanging Indent
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1. Type the following:
Hanging Indent: The hanging indent feature indents the first line by the amount specified
in the Left field. Subsequent lines are indented by the amount specified in the Left field
plus the amount specified in the By field.

2. Select the paragraph you just typed.
3. Choose the Home tab.
4. Click the launcher in the Paragraph group. The Paragraph dialog box appears.

5. Choose the Indents and Spacing tab.
6. In the Special field, click to open the pull-down menu.
7. Click Hanging.
8. In the By box, type 2".
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9. Click OK.
10. Place the cursor after the colon following "Hanging Indent."
11. Press the Tab key. Notice that the indentation changes.

5. Align Paragraphs

Microsoft Word gives you a choice of several types of alignments. Left-aligned text is
flush with the left margin of your document and is the default setting. Right-aligned text is flush
with the right margin of your document, centered text is centered between the left and right
margins, and justified text is flush with both the left and right margins.

EXAMPLE: Left-Aligned

Sample Paragraph

On the Insert tab, the galleries include items that are designed to coordinate with the overall
look of your document. You can use these galleries to insert tables, headers, footers, lists,
cover pages, and other document building blocks. When you create pictures, charts, or
diagrams, they also coordinate with your current document look.

EXAMPLE: Right-aligned

Sample Paragraph

On the Insert tab, the galleries include items that are designed to coordinate with the overall
look of your document. You can use these galleries to insert tables, headers, footers, lists,

cover pages, and other document building blocks. When you create pictures, charts, or
diagrams, they also coordinate with your current document look.

EXAMPLE: Centered

Sample Paragraph

On the Insert tab, the galleries include items that are designed to coordinate with the overall
look of your document. You can use these galleries to insert tables, headers, footers, lists,

cover pages, and other document building blocks. When you create pictures, charts, or
diagrams, they also coordinate with your current document look.

EXAMPLE: Justified

Sample Paragraph

On the Insert tab, the galleries include items that are designed to coordinate with the overall
look of your document. You can use these galleries to insert tables, headers, footers, lists,
cover pages, and other document building blocks. When you create pictures, charts, or
diagrams, they also coordinate with your current document look.
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The following exercises demonstrate how to justify text.

EXERCISE 7

Create the Paragraphs

1. Type Sample Paragraph.
2. Press Enter.
3. Type =rand(1) to create a paragraph.
4. Press Enter.

Right-align

1. Select the paragraphs you created.
2. Choose the Home tab.

3. Click the Align-right button in the Paragraph group. Word right-aligns your
paragraphs.

Left-align

1. Select the paragraphs you created.
2. Choose the Home tab.

3. Click the Align-left button in the Paragraph group. Word left-aligns your paragraph.

Center

1. Selected the paragraphs you created.
2. Choose the Home tab.

3. Click the Center button in the Paragraph group. Word centers your paragraph.
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Justify

1. Select the paragraphs you created.
2. Choose the Home tab.

3. Click the Justify button in the Paragraph group. Word justifies your paragraph.

Alternate Method—Right-Justify with Keys

1. Select the paragraphs you created.
2. Press Ctrl+r. The paragraph is now right-aligned.

Alternate Method—Left-Justify with Keys

1. Select the paragraphs you created.
2. Press Ctrl+l. The paragraph is now left-aligned.

Alternate Method—Center with Keys

1. Select the paragraphs you created.
2. Press Ctrl+e. The paragraph is now centered.

Alternate Method—Justify with Keys

1. Select the paragraphs you created.
2. Press Ctrl+j. The paragraph is now justified.

6. Choose a Style Set

When working with Word, you can use styles to quickly format your documents. A style
is a set of formats consisting of such things as fonts, font colors, font sizes, and paragraph
formats. Word 2007 supplies you with predesigned style sets that contain styles for titles,
subtitles, quotes, headings, lists and more. The sections that follow all show you how to work
with styles. The exercises are based on a file you must download. Right click here to download
the file. Click Save Target As from the menu that appears, and save the linked file to a directory
on your computer.

The file will download as a zip file. A zip file is a file that is compressed. Compressed files
are smaller and easier to download. To open the file:

1. Open the folder you downloaded the file to.
2. Right-click on the file name.
3. Click Extract All on the menu that appears. The Extract Compressed (Zipped) Folders dialog box

appears.
4. Enter the folder you want to put the file in or except to suggested location.
5. Click Extract. Windows Explorer extracts the file.
6. You can use Microsoft Word to open the file.
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EXERCISE 9

Choose a Style Set

1. Choose the Home tab.
2. Click Change Styles in the Styles group. A menu appears.
3. Click Style Set. A menu appears. You can choose from any of the styles listed on the

menu.
4. Click Simple. Word 2007 reformats all of the paragraphs into the Simple style by

applying the Normal format to each paragraph.

Apply a Style

You can see of all the styles available to you in the style set by clicking the launcher in
the Styles group and opening the Styles pane. You can leave the Styles pane open and available
for use by docking it. To dock the Styles pane, click the top of the pane and drag it to the left or
right edge of the Word window.

You do not need to select an entire paragraph to apply a style. If the cursor is anywhere
in the paragraph, when you click on the style, Word formats the entire paragraph.

EXERCISE 10

Apply the Title Style
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1. Choose the Home tab.
2. Click the launcher in the Styles Group. The Styles pane appears. You can drag it to the

side of the Word window to dock it. To close the Styles pane, click the Close button in
the upper right corner of the pane .

3. Click anywhere in the paragraph "Single-Parent Family—Career Help."
4. Click Title in the Styles pane. Word 2007 applies the Title style to the paragraph.

Headings and subheadings mark major topics within your document. With Word 2007, you
can easily format the headings and subheadings in your document.

Apply Headings

1. Click anywhere in the paragraph "The Nature of Single Parenthood."
2. In the Style box, click Heading 1. Word reformats the paragraph.
3. Repeat steps 1 and 2 in the following paragraphs:

 Types of Single Parents
 Career Development Needs of Single Parents
 Career Development Programs

Apply Subheadings

1. Click anywhere in the paragraph "Displaced Homemakers"
2. In the Style box, click Heading 2. Word reformats the paragraph.
3. Repeat steps 1 and 2 for the following paragraphs:
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 Displaced Homemakers
 Adolescent Mothers
 Single Fathers
 High School Dropout Prevention
 Established Education Sites

Alternate Method -- Apply Styles with the Ribbon
You can also choose styles by selecting the option you want from the Styles group on the

Ribbon. First you must place your cursor in the paragraph to which you want to apply the style.
Then you click the More button in the Styles group to see all of the styles in the currently
selected set. As you roll your cursor over each of the styles listed, Word 2007 provides you with
a live preview of how the style will appear when applied.

1. Select the paragraphs "Emotional Support" through "Parenthood Education" (they are
probably on page two).

2. Click the More button in the Styles group.
3. Locate and click the List Paragraph style. Word applies the List Paragraph style to the

paragraphs you selected.

Change Style Sets

Once you have applied styles, changing to another style set is easy. You simply open the
Style Set gallery. As you move your cursor down the menu, Word 2007 provides you with a live
preview of the effect of applying the style set. To choose a style set, you click it.

EXERCISE 11

Change Style Sets

1. Click Change Styles in the Styles group. A menu appears.
2. Click Style Set. A menu appears. As you move your cursor down the menu Word 2007

provides you with a live preview of the effect of applying the Style set to your document.
3. Click Formal. Word 2007 reformats all of the paragraphs into the Formal style applying

the appropriate format to each paragraph.
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Lesson 5

ADDING BULLETS AND NUMBERS, UNDOING
AND REDOING, SETTING PAGE LAYOUTS AND

PRINTING DOCUMENTS
5.0. Objective

The objective of this lesson is to make you learn setting page layouts, adding bullets and
or numbers when you work with lists. This lesson also explains about how to take print outs of
the document.

After studying this lesson you can

- prepare lists in word
- add bullets to the list
- set page layout
- print setup

Structure

1. Introduction

2. Adding Bullets and Numbers

2.1. Numbering

2.2. Bulleting

3. Undo and Redo

4. Page Layouts

4.1 Set the Orientation

4.2 Set the Page Size

4.3 Set the Margins

4.4 Add Page Numbers

4.5 Insert Page Breaks

5. Preview and Print Documents

1. Introduction

If you have lists of data, you may want to bullet or number them. When using Microsoft
Word, bulleting and numbering are easy. The first part of this lesson teaches you to add bullet
and number to the lists in the document.
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After you have completed your document, you may want to share it with others. One way
to share your document is to print and distribute it. However, before you print you may want to
add page numbers and tell Word such things as the page orientation, the paper size, and the
margin setting you want to use. In this lesson you will learn how to layout and how to print your
documents.

2. Adding Bullets and Numbers

In Microsoft Word, you can easily create bulleted or numbered lists of items. Several
bulleting and numbering styles are available, as shown in the examples. You can select the one
you wish to use.

2.1. Numbering

EXAMPLES: Numbering

Numbers
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1. Type the following list as shown:
Apple
Orange
Grape
Mango
Cherry

2. Select the words you just typed.
3. Choose the Home tab.

4. In the Paragraph group, click the down arrow next to the Numbering button . The
Numbering Library appears.

5. Click to select the type of numbering you want to use. Word numbers your list.
Note: As you move your cursor over the various number styles, Word displays the
number style onscreen.

To remove the numbering:

1. Select the list again.
2. Choose the Home tab.
3. In the Paragraph group, click the down arrow next yo the Numbering icon. The Number

dialog box appears.
4. Click None. Word removes the numbering from your list.

2.2. Bulleting

EXAMPLES: Bulleting
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EXERCISE 1

Bullets

1. Type the following list as shown:
Apple
Orange
Grape
Mango
Cherry

2. Select the words you just typed.
3. Choose the Home tab.

4. In the Paragraph group, click the down arrow next to the Bullets button . The Bullet
Library appears.

5. Click to select the type of bullet you want to use. Word adds bullets to your list.
Note: As you move your cursor over the various bullet styles, Word displays the bullet
style onscreen.

To remove the bulleting:

1. Select the list again.
2. Choose the Home tab.
3. In the Paragraph group, click the down arrow next to the Bullets icon. The Bullet dialog

box appears.
4. Click None. Word removes the bullets from your list.
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3. Undo and Redo

You can quickly reverse most commands you execute by using Undo. If you then change
your mind again, and want to reapply a command, you can use Redo.

EXERCISE 2

Undo and Redo

1. Type Undo example.
2. Click the Undo button on the Quick Access menu. The typing disappears.
3. Click the Redo button on the Quick Access menu. The typing reappears.
4. Select "Undo example."
5. Press Ctrl+b to bold. Word bolds the text.
6. Press Ctrl+i. Word italicizes the text.
7. Press Ctrl+u Word underlines the text.
8. Click the down arrow next to the Undo icon. You will see the actions you performed

listed. To undo the underline, click Underline; to undo the underline and italic, click
Underline Italic; to undo the underline, italic, and bold click Bold etc.

9. To redo, click the Redo icon several times.

Alternate Method -- Undo & Redo by Using Keys

1. Type Undo example.
2. Press Ctrl+z. The typing disappears.
3. Press Ctrl+y. The typing reappears.
4. Select "Undo example."
5. Press Ctrl+u to underline.
6. Press Ctrl+z. The underline is removed.
7. Press Ctrl+y. The underline reappears.
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4. Page Layouts
MS Word provides features to design the page layouts by selecting orientation,

paper size, margins etc. It also allows to insert page numbers, page breaks etc.

4.1 Set the Orientation

Before you print your document, you may want to change the orientation of your pages.
There are two orientations you can use: portrait and landscape. Paper, such as paper sized 8 1/2
by 11, is longer on one edge than it is on the other. If you print in Portrait, the shortest edge of
the paper becomes the top of the page. Portrait is the default option. If you print Landscape, the
longest edge of the paper becomes the top of the page.

Portrait

Landscape

EXERCISE 3

Set the Orientation

1. Choose the Page Layout tab.
2. Click Orientation in the Page Setup group. A menu appears.
3. Click Portrait. Word sets your page orientation to Portrait.
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4.2 Set the Page Size
Paper comes in a variety of sizes. Most business correspondence uses 8 1/2 by 11 paper

which is the default page size in Word. If you are not using 8 1/2 by 11paper, you can use the
Size option in the Page Setup group of the Page Layout tab to change the Size setting.
EXERCISE 4
Set the Page Size

1. Choose the Page Layout tab.
2. Click Size in the Page Setup group. A menu appears.
3. Click Letter 8.5 x 11in. Word sets your page size.

4.3 Set the Margins

Margins define the amount of white space that appears at the top, bottom, left, and right
edges of your document. The Margin option in the Page Setup group of the Page Layout tab
provides several standard margin sizes from which you can choose.

EXERCISE 5

Set the Margins
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1. Choose the Page Layout tab.
2. Click Margins in the Page Setup group. A menu appears.
3. Click Moderate. Word sets your margins to the Moderate settings.

4.4 Add Page Numbers

Page numbers help you keep your document organized and enable readers to find
information quickly. You can add page numbers to the top, bottom, or margins of your pages,
and you can choose where the numbers appear. For example, numbers can appear at the top of
the page, on the left, right, or center of the page. Word also offers several number styles from
which you can choose.

EXERCISE 6

Add Page Numbers
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1. Choose the Insert tab.
2. Click the Page Number button in the Header & Footer group. A menu appears.
3. Click Bottom of Page.
4. Click the right-side option.

4.5 Insert Page Breaks

As you learned in Lesson 1, you can display your document in any of five views: Draft,
Web Layout, Print Layout, Full Screen Reading, or Online Layout. In Print Layout view you see
your document as it will appear when you print it. You can clearly see where each page ends and
a new page begins.

As you review your document, you may find that you want to change the point at which a
new page begins. You do this by inserting a page break. For example, if a page heading appears
on one page and the first paragraph under the heading appears on the next page, you may want to
insert a page break before the heading to keep the heading and the first paragraph together.

EXERCISE 7

Change to Print View
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1. Choose the View tab.
2. Click Print Layout in the Document Views group. Your document changes to the Print

Layout view.

Insert Page Breaks

1. Place your cursor before the D in "Displaced Homemakers"
2. Choose the Insert tab.
3. Click Page Break. Word places a page break in your document.

To delete a page break, you select the page break and then press the Delete key.

5. Preview and Print Documents
When you have your margins, tabs, and so on the way you want them, you are ready to

print. In Word, You can preview your document before you print. In the Preview mode, you can
review each page, view multiple pages at the same time, zoom in on a page, and access the Size,
Orientation, and Margin options.

If you press the Zoom button while you are in Preview mode, the Zoom dialog box
appears. In the Zoom dialog box you can set the sizes of the pages that display as well as the
number of pages that display.

When you are ready to print, you use the Print dialog box. In the Print Range area,
choose All to print every page of your document, choose Current Page to print the page you are
currently on, or choose Pages to enter the specific pages you want to print. Type the pages you
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want to print in the Pages field. Separate individual pages with commas (1,3, 13); specify a range
by using a dash (4-9).

EXERCISE 8
Print Preview

1. Click the Microsoft Office button. A menu appears.
2. Highlight the Print option. The Preview and Print the Document menu appears.
3. Click Print Preview. The Preview window appears, with your document in the window.
4. Click One Page to view one page at a time. Click Two Pages to view two pages at a time.
5. To view your document in normal size, click 100%.
6. Click the Zoom Button. The Zoom dialog box appears.
7. Select an option and then click OK. Perform this task for each option and note the results.

Note: If you want to make changes to your document, click the Close Print Preview button,
to return to your document. Once you are satisfied with your document, you are ready to
print.

Print
1. Click the Print button. The Print dialog box appears.
2. Click the down arrow next to the Name field and select the printer to which you want to

print.
3. Choose All as the page range.
4. Click OK. Word prints your document.
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UNIT – 2 : Lesson 6

MICROSOFT EXCEL 2007

6.0. Objective

The objective of this lesson is to explain the spreadsheet program provided by Microsoft
Office in the form of Excel. This lesson explains the basics of using Excel program in
organizing data and to do mathematical calculations.

After studying this lesson you will be able to learn

- basics of excel window
- enter text and numbers into columns
- edit the data entered

Structure

1. Introduction
2. Entering Text and Numbers

2.1 The Microsoft Excel Window
2.2 Moving Around Worksheet
2.3 Enter Data

3. Editing
4. Saving and Closing the file

1. Introduction

Microsoft Excel is an electronic spreadsheet program. You can use it to organize your
data into rows and columns. You can also use it to perform mathematical calculations quickly.
This lesson explains Microsoft Excel features and about how to use Excel window. You use the
window to interact with Excel.

2. Entering Text and Numbers

The excel window provides worksheets to enter text or numbers into columns and rows.
Before explaining the entering of data and performing mathematical functions, the following
section explains the MS Excel Window.

2.1 The Microsoft Excel Window

Start Microsoft Excel 2007. The Microsoft Excel window appears and your screen looks
similar to the one shown here.
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Note: Your screen will probably not look exactly like the screen shown. In Excel
2007, how a window displays depends on the settings

The Microsoft Office Button

In the upper-left corner of the Excel 2007 window is the Microsoft Office button. When
you click the button, a menu appears. You can use the menu to create a new file, open an
existing file, save a file, and perform many other tasks.

The Quick Access Toolbar

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access
toolbar gives you with access to commands you frequently use. By default, Save, Undo, and
Redo appear on the Quick Access toolbar. You can use Save to save your file, Undo to roll back
an action you have taken, and Redo to reapply an action you have rolled back.
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The Title Bar

Next to the Quick Access toolbar is the Title bar. On the Title bar, Microsoft Excel
displays the name of the workbook you are currently using. At the top of the Excel window, you
should see "Microsoft Excel - Book1" or a similar name.

The Ribbon

In Microsoft Excel 2007, you use the Ribbon to issue commands. The Ribbon is located
near the top of the Excel window, below the Quick Access toolbar. At the top of the Ribbon are
several tabs; clicking a tab displays several related command groups. Within each group are
related command buttons. You click buttons to issue commands or to access menus and dialog
boxes. You may also find a dialog box launcher in the bottom-right corner of a group. When you
click the dialog box launcher, a dialog box makes additional commands available.

Worksheets
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Microsoft Excel consists of worksheets. Each worksheet contains columns and rows. The
columns are lettered A to Z and then continuing with AA, AB, AC and so on; the rows are
numbered 1 to 1,048,576. The number of columns and rows you can have in a worksheet is
limited by your computer memory and your system resources.

The combination of a column coordinate and a row coordinate make up a cell address.
For example, the cell located in the upper-left corner of the worksheet is cell A1, meaning
column A, row 1. Cell E10 is located under column E on row 10. You enter your data into the
cells on the worksheet.

The Formula Bar

Formula Bar

If the Formula bar is turned on, the cell address of the cell you are in displays in the Name
box which is located on the left side of the Formula bar. Cell entries display on the right side of
the Formula bar. If you do not see the Formula bar in your window, perform the following steps:

1. Choose the View tab.
2. Click Formula Bar in the Show/Hide group. The Formula bar appears.

The Status Bar
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The Status bar appears at the very bottom of the Excel window and provides such
information as the sum, average, minimum, and maximum value of selected numbers. You can
change what displays on the Status bar by right-clicking on the Status bar and selecting the
options you want from the Customize Status Bar menu. You click a menu item to select it. You
click it again to deselect it. A check mark next to an item means the item is selected.

2.2 Moving Around Worksheet

By using the arrow keys, you can move around your worksheet. You can use the down
arrow key to move downward one cell at a time. You can use the up arrow key to move upward
one cell at a time. You can use the Tab key to move across the page to the right, one cell at a
time. You can hold down the Shift key and then press the Tab key to move to the left, one cell at
a time. You can use the right and left arrow keys to move right or left one cell at a time. The
Page Up and Page Down keys move up and down one page at a time. If you hold down the Ctrl
key and then press the Home key, you move to the beginning of the worksheet.

EXERCISE 1

Move Around the Worksheet

The Down Arrow Key

 Press the down arrow key several times. Note that the cursor moves downward one cell
at a time.

The Up Arrow Key

 Press the up arrow key several times. Note that the cursor moves upward one cell at a
time.

The Tab Key

1. Move to cell A1.
2. Press the Tab key several times. Note that the cursor moves to the right one cell at a time.

The Shift+Tab Keys

 Hold down the Shift key and then press Tab. Note that the cursor moves to the left one
cell at a time.

The Right and Left Arrow Keys

1. Press the right arrow key several times. Note that the cursor moves to the right.
2. Press the left arrow key several times. Note that the cursor moves to the left.
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Page Up and Page Down

1. Press the Page Down key. Note that the cursor moves down one page.
2. Press the Page Up key. Note that the cursor moves up one page.

The Ctrl-Home Key

1. Move the cursor to column J.
2. Stay in column J and move the cursor to row 20.
3. Hold down the Ctrl key while you press the Home key. Excel moves to cell A1.

Go To Cells Quickly

The following are shortcuts for moving quickly from one cell in a worksheet to a cell in a
different part of the worksheet.

EXERCISE 2

Go to -- F5

The F5 function key is the "Go To" key. If you press the F5 key, you are prompted for the
cell to which you wish to go. Enter the cell address, and the cursor jumps to that cell.

1. Press F5. The Go To dialog box opens.
2. Type J3 in the Reference field.
3. Press Enter. Excel moves to cell J3.

Go to -- Ctrl+G

You can also use Ctrl+G to go to a specific cell.

1. Hold down the Ctrl key while you press "g" (Ctrl+g). The Go To dialog box opens.
2. Type C4 in the Reference field.
3. Press Enter. Excel moves to cell C4.

The Name Box

You can also use the Name box to go to a specific cell. Just type the cell you want to go
to in the Name box and then press Enter.
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1. Type B10 in the Name box.
2. Press Enter. Excel moves to cell B10.

Select Cells

If you wish to perform a function on a group of cells, you must first select those cells by
highlighting them. The exercises that follow teach you how to select.

EXERCISE 3

Select Cells
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To select cells A1 to E1:

1. Go to cell A1.
2. Press the F8 key. This anchors the cursor.
3. Note that "Extend Selection" appears on the Status bar in the lower-left corner of the

window. You are in the Extend mode.
4. Click in cell E7. Excel highlights cells A1 to E7.
5. Press Esc and click anywhere on the worksheet to clear the highlighting.

Alternative Method: Select Cells by Dragging

You can also select an area by holding down the left mouse button and dragging the mouse
over the area. In addition, you can select noncontiguous areas of the worksheet by doing the
following:

1. Go to cell A1.
2. Hold down the Ctrl key. You won't release it until step 9. Holding down the Ctrl key

enables you to select noncontiguous areas of the worksheet.
3. Press the left mouse button.
4. While holding down the left mouse button, use the mouse to move from cell A1 to C5.
5. Continue to hold down the Ctrl key, but release the left mouse button.
6. Using the mouse, place the cursor in cell D7.
7. Press the left mouse button.
8. While holding down the left mouse button, move to cell F10. Release the left mouse

button.
9. Release the Ctrl key. Cells A1 to C5 and cells D7 to F10 are selected.
10. Press Esc and click anywhere on the worksheet to remove the highlighting.
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2.3 Enter Data

This section explains you how to enter data into your worksheet. First, place the cursor in
the cell in which you want to start entering data. Type some data, and then press Enter. If you
need to delete, press the Backspace key to delete one character at a time.

EXERCISE 4
Enter Data

1. Place the cursor in cell A1.
2. Type John Jordan. Do not press Enter at this time.

Delete Data
The Backspace key erases one character at a time.
1. Press the Backspace key until Jordan is erased.
2. Press Enter. The name "John" appears in cell A1.

3. Editing
Edit a Cell
After you enter data into a cell, you can edit the data by pressing F2 while you are in the

cell you wish to edit.
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EXERCISE 5
Edit a Cell

Change "John" to "Jones."
1. Move to cell A1.
2. Press F2.
3. Use the Backspace key to delete the "n" and the "h."
4. Type nes.
5. Press Enter.

Alternate Method: Editing a Cell by Using the Formula Bar

You can also edit the cell by using the Formula bar. You change "Jones" to "Joker" in the
following exercise.

1. Move the cursor to cell A1.
2. Click in the formula area of the Formula bar.
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3. Use the backspace key to erase the "s," "e," and "n."
4. Type ker.
5. Press Enter.

Alternate Method: Edit a Cell by Double-Clicking in the Cell

You can change "Joker" to "Johnson" as follows:

1. Move to cell A1.
2. Double-click in cell A1.
3. Press the End key. Your cursor is now at the end of your text.
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3. Use the Backspace key to erase "r," "e," and "k."
4. Type hnson.
5. Press Enter.

Change a Cell Entry

Typing in a cell replaces the old cell entry with the new information you type.

1. Move the cursor to cell A1.
2. Type Cathy.
3. Press Enter. The name "Cathy" replaces "Johnson."

Wrap Text

When you type text that is too long to fit in the cell, the text overlaps the next cell. If you
do not want it to overlap the next cell, you can wrap the text.
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EXERCISE 6

Wrap Text

1. Move to cell A2.
2. Type Text too long to fit.
3. Press Enter.

4. Return to cell A2.
5. Choose the Home tab.

6. Click the Wrap Text button . Excel wraps the text in the cell.
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Delete a Cell Entry

To delete an entry in a cell or a group of cells, you place the cursor in the cell or select
the group of cells and press Delete.

EXERCISE 7

Delete a Cell Entry

1. Select cells A1 to A2.
2. Press the Delete key.

4. Saving and Closing the file

Save a File

To save your file:

1. Click the Office button. A menu appears.
2. Click Save. The Save As dialog box appears.
3. Go to the directory in which you want to save your file.
4. Type Lesson1 in the File Name field.
5. Click Save. Excel saves your file.

Close Excel

Close Microsoft Excel.

1. Click the Office button. A menu appears.
2. Click Close. Excel closes.
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Lesson 7

EXCEL FORMULAS AND MATHEMATICAL
CALCULATIONS

7.0. Objective

The objective of this lesson is to explain how to perform mathematical calculations. This
lesson makes you learn how to format text in the cells.

After studying this lesson you will be able to
- do mathematical calculations with data entered into the cells
- format text in the desired way

Structure
1. Introduction

2. Set the Enter Key Direction

3. Perform Mathematical Calculations

3.1 Addition

3.2 Subtraction

3.3 Multiplication

3.4 Division

3.5 Auto Sum

4. Perform Automatic Calculations

5. Perform Advanced Mathematical Calculations

6. Align Cell Entries

7. Copy, Cut, Paste, and Cell Addressing

7.1 Copy with the Ribbon

7.2 Copy with the Mini Toolbar

7.3 Absolute Cell Addressing

7.4 Copy and Paste with Keyboard Shortcuts

7.5 Mixed Cell Addressing

7.6 Cut and Paste
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1. Introduction

The previous lesson taught you how to move around the Excel window, and how to enter
data. Excel window provides formula bar to perform basic mathematical calculations on the data
entered into cells. Excel also gave provision to format text and numerical data. To start this
lesson, open Excel.

2. Set the Enter Key Direction

In Microsoft Excel, you can specify the direction the cursor moves when you press the
Enter key. In the exercises that follow, the cursor must move down one cell when you press
Enter. You can use the Direction box in the Excel Options pane to set the cursor to move up,
down, left, right, or not at all. Perform the steps that follow to set the cursor to move down when
you press the Enter key.

1. Click the Microsoft Office button. A menu appears.
2. Click Excel Options in the lower-right corner. The Excel Options pane appears.
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3. Click Advanced.
4. If the check box next to After Pressing Enter Move Selection is not checked, click the

box to check it.
5. If Down does not appear in the Direction box, click the down arrow next to the Direction

box and then click Down.
6. Click OK. Excel sets the Enter direction to down.

3. Perform Mathematical Calculations

In Microsoft Excel, you can enter numbers and mathematical formulas into cells.
Whether you enter a number or a formula, you can reference the cell when you perform
mathematical calculations such as addition, subtraction, multiplication, or division. When
entering a mathematical formula, precede the formula with an equal sign. Use the following to
indicate the type of calculation you wish to perform:

+ Addition
- Subtraction
* Multiplication
/ Division
^ Exponential

In the following exercises, you can learn how to perform mathematical calculations.

EXERCISE 1

3.1 Addition
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1. Type Add in cell A1.
2. Press Enter. Excel moves down one cell.
3. Type 1 in cell A2.
4. Press Enter. Excel moves down one cell.
5. Type 1 in cell A3.
6. Press Enter. Excel moves down one cell.
7. Type =A2+A3 in cell A4.
8. Click the check mark on the Formula bar. Excel adds cell A1 to cell A2 and displays the

result in cell A4. The formula displays on the Formula bar.

Note: Clicking the check mark on the Formula bar is similar to pressing Enter. Excel
records your entry but does not move to the next cell.

3.2 Subtraction
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1. Press F5. The Go To dialog box appears.
2. Type B1 in the Reference field.
3. Press Enter. Excel moves to cell B1.

4. Type Subtract.
5. Press Enter. Excel moves down one cell.
6. Type 6 in cell B2.
7. Press Enter. Excel moves down one cell.
8. Type 3 in cell B3.
9. Press Enter. Excel moves down one cell.
10. Type =B2-B3 in cell B4.
11. Click the check mark on the Formula bar. Excel subtracts cell B3 from cell B2 and the

result displays in cell B4. The formula displays on the Formula bar.

3.3 Multiplication

1. Hold down the Ctrl key while you press "g" (Ctrl+g). The Go To dialog box appears.
2. Type C1 in the Reference field.
3. Press Enter. Excel moves to cell C1
4. Type Multiply.
5. Press Enter. Excel moves down one cell.
6. Type 2 in cell C2.
7. Press Enter. Excel moves down one cell.
8. Type 3 in cell C3.
9. Press Enter. Excel moves down one cell.
10. Type =C2*C3 in cell C4.
11. Click the check mark on the Formula bar. Excel multiplies C1 by cell C2 and displays the

result in cell C3. The formula displays on the Formula bar.
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3.4 Division

1. Press F5.
2. Type D1 in the Reference field.
3. Press Enter. Excel moves to cell D1.
4. Type Divide.
5. Press Enter. Excel moves down one cell.
6. Type 6 in cell D2.
7. Press Enter. Excel moves down one cell.
8. Type 3 in cell D3.
9. Press Enter. Excel moves down one cell.
10. Type =D2/D3 in cell D4.
11. Click the check mark on the Formula bar. Excel divides cell D2 by cell D3 and displays

the result in cell D4. The formula displays on the Formula bar.

When creating formulas, you can reference cells and include numbers. All of the following
formulas are valid:

=A2/B2
=A1+12-B3
=A2*B2+12
=24+53

3.5 AutoSum

You can use the AutoSum button on the Home tab to automatically add a column or

row of numbers. When you press the AutoSum button , Excel selects the numbers it thinks
you want to add. If you then click the check mark on the Formula bar or press the Enter key,
Excel adds the numbers. If Excel's guess as to which numbers you want to add is wrong, you can
select the cells you want.

EXERCISE 2

AutoSum

The following illustrates AutoSum:
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1. Go to cell F1.
2. Type 3.
3. Press Enter. Excel moves down one cell.
4. Type 3.
5. Press Enter. Excel moves down one cell.
6. Type 3.
7. Press Enter. Excel moves down one cell to cell F4.
8. Choose the Home tab.

9. Click the AutoSum button in the Editing group. Excel selects cells F1 through F3 and
enters a formula in cell F4.

10. Press Enter. Excel adds cells F1 through F3 and displays the result in cell F4.

4. Perform Automatic Calculations

By default, Microsoft Excel recalculates the worksheet as you change cell entries. This
makes it easy for you to correct mistakes and analyze a variety of scenarios.
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EXERCISE 3

Automatic Calculation

Make the changes described below and note how Microsoft Excel automatically re -
calculates.

1. Move to cell A2.
2. Type 2.
3. Press the right arrow key. Excel changes the result in cell A4. Excel adds cell A2 to cell

A3 and the new result appears in cell A4.
4. Move to cell B2.
5. Type 8.
6. Press the right arrow key. Excel subtracts cell B3 from cell B3 and the new result

appears in cell B4.
7. Move to cell C2.
8. Type 4.
9. Press the right arrow key. Excel multiplies cell C2 by cell C3 and the new result appears

in cell C4.
10. Move to cell D2.
11. Type 12.
12. Press the Enter key. Excel divides cell D2 by cell D3 and the new result appears in cell

D4.

5. Perform Advanced Mathematical Calculations

When you perform mathematical calculations in Excel, be careful of precedence.
Calculations are performed from left to right, with multiplication and division performed before
addition and subtraction.
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EXERCISE 5

Advanced Calculations

1. Move to cell A7.
2. Type =3+3+12/2*4.
3. Press Enter.

Note: Microsoft Excel divides 12 by 2, multiplies the answer by 4, adds 3, and then adds
another 3. The answer, 30, displays in cell A7.

To change the order of calculation, use parentheses. Microsoft Excel calculates the
information in parentheses first.

1. Double-click in cell A7.
2. Edit the cell to read =(3+3+12)/2*4.
3. Press Enter.

Note: Microsoft Excel adds 3 plus 3 plus 12, divides the answer by 2, and then multiplies
the result by 4. The answer, 36, displays in cell A7.

6. Align Cell Entries

When you type text into a cell, by default your entry aligns with the left side of the cell.
When you type numbers into a cell, by default your entry aligns with the right side of the cell.
You can change the cell alignment. You can center, left-align, or right-align any cell entry. Look
at cells A1 to D1. Note that they are aligned with the left side of the cell.
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EXERCISE 4

Center

To center cells A1 to D1:

1. Select cells A1 to D1.
2. Choose the Home tab.

3. Click the Center button in the Alignment group. Excel centers each cell's content.

Left-Align

To left-align cells A1 to D1:

1. Select cells A1 to D1.
2. Choose the Home tab.

3. Click the Align Text Left button in the Alignment group. Excel left-aligns each cell's
content.
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Right-Align

To right-align cells A1 to D1:

1. Select cells A1 to D1. Click in cell A1.
2. Choose the Home tab.

3. Click the Align Text Right button. Excel right-aligns the cell's content.
4. Click anywhere on your worksheet to clear the highlighting.

7. Copy, Cut, Paste, and Cell Addressing

In Excel, you can copy data from one area of a worksheet and place the data you copied
anywhere in the same or another worksheet. In other words, after you type information into a
worksheet, if you want to place the same information somewhere else, you do not have to retype
the information. You simple copy it and then paste it in the new location.

You can use Excel's Cut feature to remove information from a worksheet. Then you can
use the Paste feature to place the information you cut anywhere in the same or another
worksheet. In other words, you can move information from one place in a worksheet to another
place in the same or different worksheet by using the Cut and Paste features.

Microsoft Excel records cell addresses in formulas in three different ways, called
absolute, relative, and mixed. The way a formula is recorded is important when you copy it.
With relative cell addressing, when you copy a formula from one area of the worksheet to
another, Excel records the position of the cell relative to the cell that originally contained the
formula. With absolute cell addressing, when you copy a formula from one area of the
worksheet to another, Excel references the same cells, no matter where you copy the formula.
You can use mixed cell addressing to keep the row constant while the column changes, or vice
versa. The following exercises demonstrate.
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EXERCISE 6

Copy, Cut, Paste, and Cell Addressing

1. Move to cell A9.
2. Type 1. Press Enter. Excel moves down one cell.
3. Type 1. Press Enter. Excel moves down one cell.
4. Type 1. Press Enter. Excel moves down one cell.
5. Move to cell B9.
6. Type 2. Press Enter. Excel moves down one cell.
7. Type 2. Press Enter. Excel moves down one cell.
8. Type 2. Press Enter. Excel moves down one cell.

In addition to typing a formula, you can also enter formulas by using Point mode. When you
are in Point mode, you can enter a formula either by clicking on a cell or by using the arrow
keys.

1. Move to cell A12.
2. Type =.
3. Use the up arrow key to move to cell A9.
4. Type +.
5. Use the up arrow key to move to cell A10.
6. Type +.
7. Use the up arrow key to move to cell A11.
8. Click the check mark on the Formula bar. Look at the Formula bar. Note that the formula

you entered is displayed there.

7.1 Copy with the Ribbon

To copy the formula you just entered, follow these steps:
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1. You should be in cell A12.
2. Choose the Home tab.

3. Click the Copy button in the Clipboard group. Excel copies the formula in cell A12.

4. Press the right arrow key once to move to cell B12.

5. Click the Paste button in the Clipboard group. Excel pastes the formula in cell A12
into cell B12.

6. Press the Esc key to exit the Copy mode.

Compare the formula in cell A12 with the formula in cell B12 (while in the respective cell,
look at the Formula bar). The formulas are the same except that the formula in cell A12 sums the
entries in column A and the formula in cell B12 sums the entries in column B. The formula was
copied in a relative fashion.Before proceeding with the next part of the exercise, you must copy
the information in cells A7 to B9 to cells C7 to D9. This time you will copy by using the Mini
toolbar.
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7.2 Copy with the Mini Toolbar

1. Select cells A9 to B11. Move to cell A9. Press the Shift key. While holding down the
Shift key, press the down arrow key twice. Press the right arrow key once. Excel
highlights A9 to B11.

2. Right-click. A context menu and a Mini toolbar appear.
3. Click Copy, which is located on the context menu. Excel copies the information in cells

A9 to B11.

4. Move to cell C9.
5. Right-click. A context menu appears.
6. Click Paste. Excel copies the contents of cells A9 to B11 to cells C9 to C11.
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7. Press Esc to exit Copy mode.

7.3 Absolute Cell Addressing

You make a cell address an absolute cell address by placing a dollar sign in front of the row
and column identifiers. You can do this automatically by using the F4 key. To illustrate:

1. Move to cell C12.
2. Type =.
3. Click cell C9.
4. Press F4. Dollar signs appear before the C and the 9.
5. Type +.
6. Click cell C10.
7. Press F4. Dollar signs appear before the C and the 10.
8. Type +.
9. Click cell C11.
10. Press F4. Dollar signs appear before the C and the 11.
11. Click the check mark on the formula bar. Excel records the formula in cell C12.

7.4 Copy and Paste with Keyboard Shortcuts

Keyboard shortcuts are key combinations that enable you to perform tasks by using the
keyboard. Generally, you press and hold down a key while pressing a letter. For example, Ctrl+c
means you should press and hold down the Ctrl key while pressing "c." This tutorial notates key
combinations as follows:

Press Ctrl+c.

Now copy the formula from C12 to D12. This time, you can copy by using keyboard
short cuts.

1. Move to cell C12.
2. Hold down the Ctrl key while you press "c" (Ctrl+c). Excel copies the contents of cell

C12.
3. Press the right arrow once. Excel moves to D12.
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4. Hold down the Ctrl key while you press "v" (Ctrl+v). Excel pastes the contents of cell
C12 into cell D12.

5. Press Esc to exit the Copy mode.

Compare the formula in cell C12 with the formula in cell D12 (while in the respective
cell, look at the Formula bar). The formulas are exactly the same. Excel copied the formula from
cell C12 to cell D12. Excel copied the formula in an absolute fashion. Both formulas sum
column C.

7.5 Mixed Cell Addressing

You use mixed cell addressing to reference a cell when you want to copy part of it absolute
and part relative. For example, the row can be absolute and the column relative. You can use the
F4 key to create a mixed cell reference.

1. Move to cell E1.
2. Type =.
3. Press the up arrow key once.
4. Press F4.
5. Press F4 again. Note that the column is relative and the row is absolute.
6. Press F4 again. Note that the column is absolute and the row is relative.
7. Press Esc.

7.6 Cut and Paste

You can move data from one area of a worksheet to another.
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1. Select cells D9 to D12
2. Choose the Home tab.

3. Click the Cut button.
4. Move to cell G1.

5. Click the Paste button . Excel moves the contents of cells D9 to D12 to cells G1 to
G4.

The keyboard shortcut for Cut is Ctrl+x. The steps for cutting and pasting with a
keyboard shortcut are:

1. Select the cells you want to cut and paste.
2. Press Ctrl+x.
3. Move to the upper-left corner of the block of cells into which you want to paste.
4. Press Ctrl+v. Excel cuts and pastes the cells you selected.
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Lesson 8

FORMATTING DATA AND EDITING COLUMNS
AND ROWS

8.0. Objective

The objective of this lesson is to explain some formatting features such as how to insert
and delete rows and columns, changing the column width and selecting font size and font colour
etc. This lesson also makes you learn how to format numbers and change decimals to a percent.

After studying this lesson you will be able to

- insert and delete rows and columns
- bold, italicize and underline text in the cells
- change the fonts in size and colour
- change the decimal to percent

Structure
1. Introduction

2. Insert and Delete Columns and Rows

3. Create Borders

4. Merge and Centre

5. Add Background colour

6. Change the Font, Font Size, and Font Color

6.1 Change the font size

6.2 Change the Font colour

7. Move to a New Worksheet

8. Bold, Italicize, and Underline

8.1 Bold with the Ribbon

8.2 Italicize with the Ribbon

8.3 Underline with the Ribbon

8.4 Double Underline

8.5 Bold, Underline, and Italicize

8.6 Bold, Underline, and Italicize with short keys

9. Work with Long Text
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10. Change Column’s width

11. Change a Column Width by Dragging

12. Format numbers

13. Change a decimal to a percent

1. Introduction

The previous lesson taught you how to perform basic mathematical calculations on the
data entered into cells. You have also learned to edit text with copy and paste commands. Excel
also gave provision to format text and numerical data. To start this lesson, open Excel.

2. Insert and Delete Columns and Rows

You can insert and delete columns and rows. When you delete a column, you delete
everything in the column from the top of the worksheet to the bottom of the worksheet. When
you delete a row, you delete the entire row from left to right. Inserting a column or row inserts a
completely new column or row.

EXERCISE 7

Insert and Delete Columns and Rows

To delete columns F and G:

1. Click the column F indicator and drag to column G.
2. Click the down arrow next to Delete in the Cells group. A menu appears.
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3. Click Delete Sheet Columns. Excel deletes the columns you selected.
4. Click anywhere on the worksheet to remove your selection.

To delete rows 7 through 12:

1. Click the row 7 indicator and drag to row 12.
2. Click the down arrow next to Delete in the Cells group. A menu appears.
3. Click Delete Sheet Rows. Excel deletes the rows you selected.
4. Click anywhere on the worksheet to remove your selection.

To insert a column:

1. Click on A to select column A.
2. Click the down arrow next to Insert in the Cells group. A menu appears.
3. Click Insert Sheet Columns. Excel inserts a new column.
4. Click anywhere on the worksheet to remove your selection.

To insert rows:

1. Click on 1 and then drag down to 2 to select rows 1 and 2.
2. Click the down arrow next to Insert in the Cells group. A menu appears.
3. Click Insert Sheet Rows. Excel inserts two new rows.
4. Click anywhere on the worksheet to remove your selection.
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Your worksheet should look like the one shown here.

3. Create Borders

You can use borders to make entries in your Excel worksheet stand out. You can choose

from several types of borders. When you press the down arrow next to the Border button ,
a menu appears. By making the proper selection from the menu, you can place a border on the
top, bottom, left, or right side of the selected cells; on all sides; or around the outside border.
You can have a thick outside border or a border with a single-line top and a double-line bottom.
Accountants usually place a single underline above a final number and a double underline below.
The following illustrates:

EXERCISE 8

Create Borders

1. Select cells B6 to E6.
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2. Choose the Home tab.

3. Click the down arrow next to the Borders button . A menu appears.
4. Click Top and Double Bottom Border. Excel adds the border you chose to the selected

cells.

4.Merge and Center

Sometimes, particularly when you give a title to a section of your worksheet, you will
want to center a piece of text over several columns or rows. The following example shows you
how.
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EXERCISE 9

Merge and Center

1. Go to cell B2.
2. Type Sample Worksheet.
3. Click the check mark on the Formula bar.
4. Select cells B2 to E2.
5. Choose the Home tab.

6. Click the Merge and Center button in the Alignment group. Excel merges cells B2,
C2, D2, and E2 and then centers the content.

Note: To unmerge cells:

1. Select the cell you want to unmerge.
2. Choose the Home tab.
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3. Click the down arrow next to the Merge and Center button. A menu appears.
4. Click Unmerge Cells. Excel unmerges the cells.

5. Add Background Color
To make a section of your worksheet stand out, you can add background color to a cell or

group of cells.

EXERCISE 10

Add Background Color

1. Select cells B2 to E3.

2. Choose the Home tab.

3. Click the down arrow next to the Fill Color button .
4. Click the color dark blue. Excel places a dark blue background in the cells you selected.
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6. Change the Font, Font Size, and Font Color

A font is a set of characters represented in a single typeface. Each character within a font
is created by using the same basic style. Excel provides many different fonts from which you can
choose. The size of a font is measured in points. There are 72 points to an inch. The number of
points assigned to a font is based on the distance from the top to the bottom of its longest
character. You can change the Font, Font Size, and Font Color of the data you enter into Excel.

EXERCISE 11

Change the Font

1. Select cells B2 to E3.
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2. Choose the Home tab.
3. Click the down arrow next to the Font box. A list of fonts appears. As you scroll down

the list of fonts, Excel provides a preview of the font in the cell you selected.
4. Find and click Times New Roman in the Font box. Note: If Times New Roman is your

default font, click another font. Excel changes the font in the selected cells.

6.1 Change the Font Size

1. Select cell B2.
2. Choose the Home tab.
3. Click the down arrow next to the Font Size box. A list of font sizes appears. As you

scroll up or down the list of font sizes, Excel provides a preview of the font size in the
cell you selected.

4. Click 26. Excel changes the font size in cell B2 to 26.



Acharya Nagarjuna University 8.10 Centre for Distance Education

6.2 Change the Font Color

1. Select cells B2 to E3.
2. Choose the Home tab.

3. Click the down arrow next to the Font Color button .
4. Click on the color white. Your font color changes to white.

Your worksheet should look like the one shown here.

7.Move to a New Worksheet

In Microsoft Excel, each workbook is made up of several worksheets. Each worksheet
has a tab. By default, a workbook has three sheets and they are named sequentially, starting with
Sheet1. The name of the worksheet appears on the tab. Before moving to the next topic, move to
a new worksheet. The exercise that follows shows you how to move to new worksheet.
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EXERCISE 12

Move to a New Worksheet

 Click Sheet2 in the lower-left corner of the screen. Excel moves to Sheet2.

8. Bold, Italicize, and Underline

When creating an Excel worksheet, you may want to emphasize the contents of cells by
bolding, italicizing, and/or underlining. You can easily bold, italicize, or underline text with
Microsoft Excel. You can also combine these features—in other words, you can bold, italicize,
and underline a single piece of text.

In the exercises that follow, you will be explained different methods you can use to bold,
italicize, and underline.

EXERCISE 13

8.1 Bold with the Ribbon

1. Type Bold in cell A1.
2. Click the check mark located on the Formula bar.
3. Choose the Home tab.

4. Click the Bold button . Excel bolds the contents of the cell.
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5. Click the Bold button again if you wish to remove the bold.

8.2 Italicize with the Ribbon

1. Type Italic in cell B1.
2. Click the check mark located on the Formula bar.
3. Choose the Home tab.

4. Click the Italic button . Excel italicizes the contents of the cell.

5. Click the Italic button again if you wish to remove the italic.

8.3 Underline with the Ribbon

Microsoft Excel provides two types of underlines. The exercises that follow illustrate
them.

Single Underline:

1. Type Underline in cell C1.
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2. Click the check mark located on the Formula bar.
3. Choose the Home tab.

4. Click the Underline button . Excel underlines the contents of the cell.

5. Click the Underline button again if you wish to remove the underline.

8.4 Double Underline

1. Type Underline in cell D1.
2. Click the check mark located on the Formula bar.
3. Choose the Home tab.

4. Click the down arrow next to the Underline button and then click Double Underline.
Excel double-underlines the contents of the cell. Note that the Underline button changes

to the button shown here , a D with a double underline under it. Then next time you
click the Underline button, you will get a double underline. If you want a single

underline, click the down arrow next to the Double Underline button and then
choose Underline.

5. Click the double underline button again if you wish to remove the double underline.

8.5 Bold, Underline, and Italicize

1. Type All three in cell E1.
2. Click the check mark located on the Formula bar.
3. Choose the Home tab.

4. Click the Bold button . Excel bolds the cell contents.

5. Click the Italic button . Excel italicizes the cell contents.

6. Click the Underline button . Excel underlines the cell contents.
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Alternate Method: Bold with Shortcut Keys

1. Type Bold in cell A2.
2. Click the check mark located on the Formula bar.
3. Hold down the Ctrl key while pressing "b" (Ctrl+b). Excel bolds the contents of the cell.
4. Press Ctrl+b again if you wish to remove the bolding.

Alternate Method: Italicize with Shortcut Keys

1. Type Italic in cell B2. Note: Because you previously entered the word Italic in column
B, Excel may enter the word in the cell automatically after you type the letter I. Excel
does this to speed up your data entry.

2. Click the check mark located on the Formula bar.
3. Hold down the Ctrl key while pressing "i" (Ctrl+i). Excel italicizes the contents of the

cell.
4. Press Ctrl+i again if you wish to remove the italic formatting.

Alternate Method: Underline with Shortcut Keys

1. Type Underline in cell C2.
2. Click the check mark located on the Formula bar.
3. Hold down the Ctrl key while pressing "u" (Ctrl+u). Excel applies a single underline to

the cell contents.
4. Press Ctrl+u again if you wish to remove the underline.

8.6 Bold, Italicize, and Underline with Shortcut Keys

1. Type All three in cell D2.
2. Click the check mark located on the Formula bar.
3. Hold down the Ctrl key while pressing "b" (Ctrl+b). Excel bolds the cell contents.
4. Hold down the Ctrl key while pressing "i" (Ctrl+i). Excel italicizes the cell contents.
5. Hold down the Ctrl key while pressing "u" (Ctrl+u). Excel applies a single underline to

the cell contents.

9. Work with Long Text

Whenever you type text that is too long to fit into a cell, Microsoft Excel attempts to
display all the text. It left-aligns the text regardless of the alignment you have assigned to it, and
it borrows space from the blank cells to the right. However, a long text entry will never write
over cells that already contain entries—instead, the cells that contain entries cut off the long text.
The following exercise illustrates this.
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EXERCISE 14

Work with Long Text

1. Move to cell A6.
2. Type Now is the time for all good men to go to the aid of their army.
3. Press Enter. Everything that does not fit into cell A6 spills over into the adjacent cell.

4. Move to cell B6.
5. Type Test.
6. Press Enter. Excel cuts off the entry in cell A6.

7. Move to cell A6.
8. Look at the Formula bar. The text is still in the cell.

10. Change Column's Width

You can increase column widths. Increasing the column width enables you to see the
long text.

EXERCISE 15

Change Column Width
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1. Make sure you are in any cell under column A.
2. Choose the Home tab.
3. Click the down arrow next to Format in the Cells group.
4. Click Column Width. The Column Width dialog box appears.
5. Type 55 in the Column Width field.
6. Click OK. Column A is set to a width of 55. You should now be able to see all of the

text.

11. Change a Column Width by Dragging

You can also change the column width with the cursor.

1. Place the mouse pointer on the line between the B and C column headings. The mouse

pointer should look like the one displayed here , with two arrows.
2. Move your mouse to the right while holding down the left mouse button. The width

indicator appears on the screen.
3. Release the left mouse button when the width indicator shows approximately 20. Excel

increases the column width to 20.

12. Format Numbers
You can format the numbers you enter into Microsoft Excel. For example, you can add

commas to separate thousands, specify the number of decimal places, place a dollar sign in front
of a number, or display a number as a percent.
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EXERCISE 16
Format Numbers

1. Move to cell B8.
2. Type 1234567.
3. Click the check mark on the Formula bar.

4. Choose the Home tab.
5. Click the down arrow next to the Number Format box. A menu appears.
6. Click Number. Excel adds two decimal places to the number you typed.
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7. Click the Comma Style button . Excel separates thousands with a comma.

8. Click the Accounting Number Format button . Excel adds a dollar sign to your
number.

9. Click twice on the Increase Decimal button to change the number format to four
decimal places.

10. Click the Decrease Decimal button if you wish to decrease the number of decimal
places.

13. Change a decimal to a percent.

1. Move to cell B9.
2. Type .35 (note the decimal point).
3. Click the check mark on the formula bar.
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4. Choose the Home tab.

5. Click the Percent Style button . Excel turns the decimal to a percent.

You can save and close your file.
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Lesson 9

CREATING EXCEL FUNCTIONS, FILLING
CELLS, AND PRINTING

9.0 Objective

The objective of this lesson is to explain different functions by employing reference
operators provided by Excel package.

After studying this lesson you will be able to

- learn using reference operators
- learn performing some mathematical functions
- learn to fill cells automatically

- learn to create header and footer

Structure

1. Introduction

2. Using Reference Operators

3. Understanding Functions

3.1 SUM Function

3.2 Average Calculation

3.3 MIN Function

3.4 MAX Function

3.5 Count the Numbers in a Series of Numbers

3.6

4. Fill Cells Automatically

4.1 Fill Times

4.2 Fill Numbers

5. Creating Headers and Footers
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1. Introduction

Microsoft Excel provides some prewritten formulas to perform certain mathematical
calculations. Sometimes you may want to enter a series of data such as days of a week or months
of a year etc. Excel provides automating filling feature to make use to enter a series of data.
Adjusting column and row widths and height is also possible to make the document look elegant.
Setting page and print layouts is also easy in Excel.

2. Using Reference Operators

To use functions, you need to understand reference operators. Reference operators refer
to a cell or a group of cells. There are two types of reference operators: range and union.

A range reference refers to all the cells between and including the reference. A range
reference consists of two cell addresses separated by a colon. The reference A1:A3 includes cells
A1, A2, and A3. The reference A1:C3 includes cells A1, A2, A3, B1, B2, B3, C1, C2, and C3.

A union reference includes two or more references. A union reference consists of two or
more numbers, range references, or cell addresses separated by a comma. The reference
A7,B8:B10,C9,10 refers to cells A7, B8 to B10, C9 and the number 10.

3. Understanding Functions

Functions are prewritten formulas. Functions differ from regular formulas in that you
supply the value but not the operators, such as +, -, *, or /. For example, you can use the SUM
function to add. When using a function, remember the following:

Use an equal sign to begin a formula.
Specify the function name.

Enclose arguments within parentheses. Arguments are values on which you want to
perform the calculation. For example, arguments specify the numbers or cells you want
to add.

Use a comma to separate arguments.

3.1 SUM Function
Here is an example of a function:

=SUM(2,13,A1,B2:C7)

In this function:
The equal sign begins the function.
SUM is the name of the function.
2, 13, A1, and B2:C7 are the arguments.
Parentheses enclose the arguments.
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Commas separate the arguments.

After you type the first letter of a function name, the AutoComplete list appears. You can
double-click on an item in the AutoComplete list to complete your entry quickly. Excel will
complete the function name and enter the first parenthesis.

EXERCISE 1
Functions
The SUM function adds argument values.

1. Open Microsoft Excel.
2. Type 12 in cell B1.
3. Press Enter.
4. Type 27 in cell B2.
5. Press Enter.
6. Type 24 in cell B3.
7. Press Enter.
8. Type =SUM(B1:B3) in cell A4.
9. Press Enter. The sum of cells B1 to B3, which is 63, appears.

Alternate Method: Enter a Function with the Ribbon
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1. Type 150 in cell C1.
2. Press Enter.
3. Type 85 in cell C2.
4. Press Enter.
5. Type 65 in cell C3.
6. Choose the Formulas tab.
7. Click the Insert Function button. The Insert Function dialog box appears.
8. Choose Math & Trig in the Or Select A Category box.
9. Click Sum in the Select A Function box.
10. Click OK. The Function Arguments dialog box appears.

12. Type C1:C3 in the Number1 field, if it does not automatically appear.
13. Click OK. The sum of cells C1 to C3, which is 300, appears.

Format worksheet

1. Move to cell A4.
2. Type the word Sum.
3. Select cells B4 to C4.
4. Choose the Home tab.

5. Click the down arrow next to the Borders button .
6. Click Top and Double Bottom Border.

You can also calculate a sum by using the AutoSum button .
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3.2 Average Calculation

You can use the AVERAGE function to calculate the average of a series of numbers.

1. Move to cell A6.
2. Type Average. Press the right arrow key to move to cell B6.
3. Type =AVERAGE(B1:B3).
4. Press Enter. The average of cells B1 to B3, which is 21, appears.

Calculate an Average with the AutoSum Button

In Microsoft Excel, you can use the AutoSum button to calculate an average.

1. Move to cell C6.
2. Choose the Home tab.

3. Click the down arrow next to the AutoSum button .
4. Click Average.
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5. Select cells C1 to C3.
6. Press Enter. The average of cells C1 to C3, which is 100, appears.

3.3 MIN Function

Find the Lowest Number

You can use the MIN function to find the lowest number in a series of numbers.

1. Move to cell A7.
2. Type Min.
3. Press the right arrow key to move to cell B7.
4. Type = MIN(B1:B3).
5. Press Enter. The lowest number in the series, which is 12, appears.

Note: You can also use the drop-down button next to the AutoSum button to
calculate minimums, maximums, and counts.

3.4 MAX Function

Find the Highest Number



Comprehensive & Viva… 9.7 Creating Excel Functions, Filling Cells, …

You can use the MAX function to find the highest number in a series of numbers.

.

1. Move to cell A8.
2. Type Max.
3. Press the right arrow key to move to cell B8.
4. Type = MAX(B1:B3).
5. Press Enter. The highest number in the series, which is 27, appears.

3.5 Count the Numbers in a Series of Numbers

You can use the count function to count the number of numbers in a series.

1. Move to cell A9.
2. Type Count.
3. Press the right arrow key to move to cell B9.
4. Choose the Home tab.

5. Click the down arrow next to the AutoSum button .
6. Click Count Numbers. Excel places the count function in cell C9 and takes a guess at

which cells you want to count. The guess is incorrect, so you must select the proper cells.
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7. Select B1 to B3.
8. Press Enter. The number of items in the series, which is 3, appears.

4. Fill Cells Automatically

You can use Microsoft Excel to fill cells automatically with a series. For example, you
can have Excel automatically fill your worksheet with days of the week, months of the year,
years, or other types of series.

EXERCISE 2:

Fill Cells Automatically

The following demonstrates filling the days of the week:
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1. Click the Sheet2 tab. Excel moves to Sheet2.
2. Move to cell A1.
3. Type Sun.
4. Move to cell B1.
5. Type Sunday.
6. Select cells A1 to B1.
7. Choose the Home tab.

8. Click the Bold button . Excel bolds cells A1 to B1.
9. Find the small black square in the lower-right corner of the selected area. The small black

square is called the fill handle.
10. Grab the fill handle and drag with your mouse to fill cells A1 to B14. Note how the days

of the week fill the cells in a series. Also, note that the Auto Fill Options button appears.
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Copy Cells

1. Click the Auto Fill Options button. The Auto Fill Options menu appears.
2. Choose the Copy Cells radio button. The entry in cells A1 and B1 are copied to all the

highlighted cells.
3. Click the Auto Fill Options button again.
4. Choose the Fill Series radio button. The cells fill as a series from Sunday to Saturday

again.
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5. Click the Auto Fill Options button again.
6. Choose the Fill Without Formatting radio button. The cells fill as a series from Sunday to

Saturday, but the entries are not bolded.
7. Click the Auto Fill Options button again.
8. Choose the Fill Weekdays radio button. The cells fill as a series from Monday to Friday.

Adjust Column Width

Some of the entries in column B are too long to fit in the column. You can quickly adjust the
column width to fit the longest entry.

1. Move your mouse pointer over the line that separates column B and C. The Width
Indicator appears.

2. Double-click. The Column adjusts to fit the longest entry.

After you complete the remainder of the exercise, your worksheet will look like the one
shown here.

4.1 Fill Times

The following demonstrates filling time:
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1. Type 1:00 into cell C1.
2. Grab the fill handle and drag with your mouse to highlight cells C1 to C14. Note

that each cell fills, using military time.
3. Press Esc and then click anywhere on the worksheet to remove the highlighting.

To change the format of the time:

1. Select cells C1 to C14.
2. Choose the Home tab.

3. Click the down arrow next to the number format box . A menu appears.
4. Click Time. Excel changes the format of the time.

4.2 Fill Numbers
You can also fill numbers.
Type a 1 in cell D1.

1. Grab the fill handle and drag with your mouse to highlight cells D1 to D14. The
number 1 fills each cell.

2. Click the Auto Fill Options button.
3. Choose the Fill Series radio button. The cells fill as a series, starting with 1, 2, 3.

Here is another interesting fill feature.

1. Go to cell E1.
2. Type Lesson 1.
3. Grab the fill handle and drag with your mouse to highlight cells E1 to E14. The

cells fill in as a series: Lesson 1, Lesson 2, Lesson 3, and so on.

5. Create Headers and Footers

You can use the Header & Footer button on the Insert tab to create headers and footers. A
header is text that appears at the top of every page of your printed worksheet. A footer is text
that appears at the bottom of every page of your printed worksheet. When you click the Header
& Footer button, the Design context tab appears and Excel changes to Page Layout view. A
context tab is a tab that only appears when you need it. Page Layout view structures your
worksheet so that you can easily change the format of your document. You usually work in
Normal view.

You can type in your header or footer or you can use predefined headers and footers. To find
predefined headers and footers, click the Header or Footer button or use the Header & Footer
Elements group's buttons. When you choose a header or footer by clicking the Header or Footer
button, Excel centers your choice. The table shown here describes each of the Header & Footer
Elements group button options.
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Header & Footer Elements

Button Purpose

Page Number Inserts the page number.

Number of Pages Inserts the number of pages in the document.

Current Time Inserts the current time.

File Path Inserts the path to the document.

File Name Inserts the file name.

Sheet Name Inserts the name of the worksheet.

Picture Enables you to insert a picture.

Both the header and footer areas are divided into three sections: left, right, and center.
When you choose a Header or Footer from the Header & Footer Elements group, where you
place your information determines whether it appears on the left, right, or center of the printed
page. You use the Go To Header and Go To Footer buttons on the Design tab to move between
the header and footer areas of your worksheet.

EXERCISE 3

Insert Headers and Footers

1. Choose the Insert tab.
2. Click the Header & Footer button in the Text group. Your worksheet changes to Page

Layout view and the Design context tab appears. Note that your cursor is located in the
center section of the header area.
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3. Click the right side of the header area.
4. Click Page Number in the Header & Footer Elements group. When you print your

document, Excel will place the page number in the upper-right corner.
5. Click the left side of the Header area.
6. Type your name. When you print your document, Excel will place your name in the

upper-left corner.
7. Click the Go To Footer button. Excel moves to the footer area.

8. Click the Footer button. A menu appears.
9. Click the path to your document. Excel will place the path to your document at the

bottom of every printed page.

To return to Normal view:

1. Choose the View tab.
2. Click the Normal button in the Workbook Views group.
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Lesson 10

Printing and Creating Charts in Excel
10.0. Objective

The objective of this lesson is to explain how to design page layout, page set up and printing
features given in Excel package. This lesson also describes creating charts in different styles and labeling
etc.

After studying this lesson you will be able to

- set the page layout
- set the page orientation
- print the document
- creating and inserting charts
- adding labels to charts

Structure

1. Introduction

2. Set Print Functions

2.1 Set the page layout

2.2 Set the page orientation

2.3 Set the paper size

3. Print

4. Creating Charts

4.1 Create Column Chart

4.2 Apply a Chart Layout

4.3 Add labels

4.4 Switch Data

4.5 Choose the Style of the Chart

4.6 Change the Size and Position of the Chart

4.7 Move a Chart to a Chart Sheet

4.8 Change the Chart Type

1. Introduction

After creating document in Excel you may want to take a hard copy. The package
enables you to layout the page, set up the page format etc. The Excel also enables the user in
creating charts in different colours and styles and labeling the charts etc.
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2. Set Print Options
There are many print options. You set print options on the Page Layout tab. Among other

things, you can set your margins, set your page orientation, and select your paper size. Margins
define the amount of white space that appears on the top, bottom, left, and right edges of your
document. The Margin option on the Page Layout tab provides several standard margin sizes
from which you can choose. There are two page orientations: portrait and landscape. Paper, such
as paper sized 8 1/2 by 11, is longer on one edge than it is on the other. If you print in Portrait,
the shortest edge of the paper becomes the top of the page. Portrait is the default option. If you
print in Landscape, the longest edge of the paper becomes the top of the page.

Portrait

Landscape

Paper comes in a variety of sizes. Most business correspondence uses 8 1/2 by 11 paper,
which is the default page size in Excel. If you are not using 8 1/2 by 11 paper, you can use the
Size option on the Page Layout tab to change the Size setting.

2.1 Set the Page Layout

Exercise 4

1. Choose the Page Layout tab.
2. Click Margins in the Page Setup group. A menu appears.
3. Click Wide. Word sets your margins to the Wide settings.
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2.2 Set the Page Orientation

1. Choose the Page Layout tab.
2. Click Orientation in the Page Setup group. A menu appears.
3. Click Landscape. Excel sets your page orientation to landscape.

2.4Set the Paper Size

1. Choose the Page Layout tab.
2. Click Size in the Page Setup group. A menu appears.
3. Click the paper size you are using. Excel sets your page size.

3. Print
The simplest way to print is to click the Office button, highlight Print on the menu that

appears, and then click Quick Print in the Preview and Print the Document pane. Dotted lines
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appear on your screen, and your document prints. The dotted lines indicate the right, left, top,
and bottom edges of your printed pages.

You can also use the Print Preview option to print. When using Print Preview, you can
see onscreen how your printed document will look when you print it. If you click the Page Setup
button while in Print Preview mode, you can set page settings such as centering your data on the
page.

If your document is several pages long, you can use the Next Page and Previous Page
buttons to move forward and backward through your document. If you check the Show Margins
check box, you will see margin lines on your document. You can click and drag the margin
markers to increase or decrease the size of your margins. To return to Excel, click the Close Print
Preview button.

You click the Print button when you are ready to print. The Print dialog box appears.
You can choose to print the entire worksheet or specific pages. If you want to print specific
pages, enter the page numbers in the From and To fields. You can enter the number of copies
you want to print in the Number of Copies field.

EXERCISE 5

Open Print Preview

1. Click the Office button. A menu appears.
2. Highlight Print. The Preview and Print The Document pane appears.
3. Click Print Preview. The Print Preview window appears, with your document in the

center.
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Center Your Document

1. Click the Page Setup button in the Print group. The Page Setup dialog box appears.
2. Choose the Margins tab.
3. Click the Horizontally check box. Excel centers your data horizontally.
4. Click the Vertically check box. Excel centers your data vertically.
5. Click OK. The Page Setup dialog box closes.

Print

1. Click the Print button. The Print dialog box appears.
2. Click the down arrow next to the name field and select the printer to which you want to

print.
3. Click OK. Excel sends your worksheet to the printer.
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You can save and close your file.

4. Creating Charts

In Microsoft Excel, you can represent numbers in a chart. On the Insert tab, you can
choose from a variety of chart types, including column, line, pie, bar, area, and scatter. The basic
procedure for creating a chart is the same no matter what type of chart you choose. As you
change your data, your chart will automatically update.

You select a chart type by choosing an option from the Insert tab's Chart group. After you
choose a chart type, such as column, line, or bar, you choose a chart sub-type. For example, after
you choose Column Chart, you can choose to have your chart represented as a two-dimensional
chart, a three-dimensional chart, a cylinder chart, a cone chart, or a pyramid chart. There are
further sub-types within each of these categories. As you roll your mouse pointer over each
option, Excel supplies a brief description of each chart sub-type.

Create a Chart

To create the column chart shown above, start by creating the worksheet below exactly as
shown.
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After you have created the worksheet, you are ready to create your chart.

4.1 Create Column Chart

EXERCISE 1

.

1. Select cells A3 to D6. You must select all the cells containing the data you want in your
chart. You should also include the data labels.

2. Choose the Insert tab.
3. Click the Column button in the Charts group. A list of column chart sub-types types

appears.
4. Click the Clustered Column chart sub-type. Excel creates a Clustered Column chart and

the Chart Tools context tabs appear.

4.2 Apply a Chart Layout

Context tabs are tabs that only appear when you need them. Called Chart Tools, there are
three chart context tabs: Design, Layout, and Format. The tabs become available when you
create a new chart or when you click on a chart. You can use these tabs to customize your chart.

You can determine what your chart displays by choosing a layout. For example, the
layout you choose determines whether your chart displays a title, where the title displays,
whether your chart has a legend, where the legend displays, whether the chart has axis labels and
so on. Excel provides several layouts from which you can choose.

EXERCISE 2

Apply a Chart Layout
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1. Click your chart. The Chart Tools become available.
2. Choose the Design tab.
3. Click the Quick Layout button in the Chart Layout group. A list of chart layouts appears.
4. Click Layout 5. Excel applies the layout to your chart.

4.3 Add Labels

When you apply a layout, Excel may create areas where you can insert labels. You use
labels to give your chart a title or to label your axes. When you applied layout 5, Excel created
label areas for a title and for the vertical axis.

EXERCISE 3

Add labels

Before After

1. Select Chart Title. Click on Chart Title and then place your cursor before the C in Chart
and hold down the Shift key while you use the right arrow key to highlight the words
Chart Title.

2. Type Toy Sales. Excel adds your title.
3. Select Axis Title. Click on Axis Title. Place your cursor before the A in Axis. Hold down

the Shift key while you use the right arrow key to highlight the words Axis Title.
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4. Type Sales. Excel labels the axis.
5. Click anywhere on the chart to end your entry.

4.4 Switch Data

If you want to change what displays in your chart, you can switch from row data to
column data and vice versa.

EXERCISE 4

Switch Data

Before After

1. Click your chart. The Chart Tools become available.
2. Choose the Design tab.
3. Click the Switch Row/Column button in the Data group. Excel changes the data in your

chart.

4.5 Change the Style of a Chart

A style is a set of formatting options. You can use a style to change the color and format
of your chart. Excel 2007 has several predefined styles that you can use. They are numbered
from left to right, starting with 1, which is located in the upper-left corner.

EXERCISE 5

Change the Style of a Chart
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1. Click your chart. The Chart Tools become available.
2. Choose the Design tab.

3. Click the More button in the Chart Styles group. The chart styles appear.

4. Click Style 42. Excel applies the style to your chart.

4.6 Change the Size and Position of a Chart

When you click a chart, handles appear on the right and left sides, the top and bottom,
and the corners of the chart. You can drag the handles on the top and bottom of the chart to
increase or decrease the height of the chart. You can drag the handles on the left and right sides
to increase or decrease the width of the chart. You can drag the handles on the corners to
increase or decrease the size of the chart proportionally. You can change the position of a chart
by clicking on an unused area of the chart and dragging.

EXERCISE 6

Change the Size and Position of a Chart
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1. Use the handles to adjust the size of your chart.
2. Click an unused portion of the chart and drag to position the chart beside the data.

4.7 Move a Chart to a Chart Sheet

By default, when you create a chart, Excel embeds the chart in the active worksheet.
However, you can move a chart to another worksheet or to a chart sheet. A chart sheet is a sheet
dedicated to a particular chart. By default Excel names each chart sheet sequentially, starting
with Chart1. You can change the name.

EXERCISE 7

Move a Chart to a Chart Sheet

1. Click your chart. The Chart Tools become available.
2. Choose the Design tab.
3. Click the Move Chart button in the Location group. The Move Chart dialog box appears.
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4. Click the New Sheet radio button.
5. Type Toy Sales to name the chart sheet. Excel creates a chart sheet named Toy Sales and

places your chart on it.

4.8 Change the Chart Type

Any change you can make to a chart that is embedded in a worksheet, you can also make
to a chart sheet. For example, you can change the chart type from a column chart to a bar chart.

EXERCISE 8

Change the Chart Type

1. Click your chart. The Chart Tools become available.
2. Choose the Design tab.
3. Click Change Chart Type in the Type group. The Chart Type dialog box appears.
4. Click Bar.
5. Click Clustered Horizontal Cylinder.
6. Click OK. Excel changes your chart type.
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You can save and close your file.
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UNIT – 3 : Lesson 11

POWER POINT

11.0 Objective

The objective of this lesson is to explain the basic features of powerPoint package supplied with
MS Office suite. It explains the preparation of slides for presentation with various animation effects and
to create slide shows.

After studying this lesson you will be able to
- create PowerPoint presentation
- create slides
- editing slides
- apply a theme to slides
- run slide show

Structure
1. The PowerPoint Window
2. Creating PowerPoint Presentation

2.1 Create a Title Slide
2.2 Create New Slides
2.3 Create an Outline
2.4 Create Two-Column Text

3. Editing Slides
4. Apply a Theme
5. Run PowerPoint Slide Show

1. The PowerPoint Window

PowerPoint is a presentation software package supplied with MS Office suite to create
slide shows. This lesson introduces you to the PowerPoint window. You use the window to
interact with the software. To begin, click start button on the desktop, click programs, click MS
Office and open PowerPoint 2007 by double clicking on it. The window appears and your screen
looks similar to the one shown below.
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The Microsoft Office Button

In the upper-left corner is the Microsoft Office button. When you click the button, a
menu appears. You can use the menu to create a new file, open an existing file, save a file, and
perform many other tasks.

The Quick Access Toolbar

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access
toolbar provides you with access to commands you frequently use. By default, Save, Undo, and
Redo appear on the Quick Access toolbar. You use Save to save your file, Undo to rollback an
action you have taken, and Redo to reapply an action you have rolled back.

The Title Bar

The Title bar is located at the top in the center of the PowerPoint window. The Title bar
displays the name of the presentation on which you are currently working. By default,
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PowerPoint names presentations sequentially, starting with Presentation1. When you save your
file, you can change the name of your presentation.

The Ribbon

1 Tabs

2 Command Group

3 Command Buttons

4 Launcher

You use commands to tell PowerPoint what to do. In PowerPoint 2007, you use the
Ribbon to issue commands. The Ribbon is located near the top of the PowerPoint window,
below the Quick Access toolbar. At the top of the Ribbon are several tabs; clicking a tab displays
several related command groups. Within each group are related command buttons. You click
buttons to issue commands or to access menus and dialog boxes. You may also find a dialog box
launcher in the bottom-right corner of a group. When you click the dialog box launcher, a dialog
box makes additional commands available.

Rulers

Rulers are vertical and horizontal guides. You use them to determine where you want to
place an object. If the rulers do not display in your PowerPoint window:

1. Click the View tab.
2. Click Ruler in the Show/Hide group. The rulers appear.

Slides, Placeholders, and Notes
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1 Slide

2 Placeholders

3 Notes

Slides appear in the center of the window. You create your presentation on slides.
Placeholders hold the objects in your slide. You can use placeholders to hold text, clip art,
charts, and more. You can use the notes area to create notes to yourself. You can refer to these
notes while you give your presentation.

Status Bar, Tabs, View Buttons, and More

The Status bar generally appears at the bottom of the window. The Status bar displays the
number of the slide that is currently displayed, the total number of slides, and the name of the
design template in use or the name of the background.

The Outline tab displays the text contained in your presentation. The Slides tab displays a
thumbnail of all your slides. You click the thumbnail to view the slide in the Slide pane.

The View buttons appear near the bottom of the screen. You use the View buttons to
change between Normal view, Slider Sorter view, and the Slide Show view.
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1
Status Bar 6 Vertical & Horizontal

Splitter Bars

2 Outline Tab 7 Minimize Button

3 Slides Tab 8 Maximize/Restore
Button

4 View Buttons 9 Close Button

5 Zoom

Normal View: Normal view splits your screen into three major sections: the Outline and Slides
tabs, the Slide pane, and the Notes area. The Outline and Slides tabs are on the left side of your
window. They enable you to shift between two different ways of viewing your slides. The Slides
tab shows thumbnails of your slides. The Outline tab shows the text on your slides. The Slide
pane is located in the center of your window. The Slide pane shows a large view of the slide on
which you are currently working. The Notes area appears below the Slide pane. You can type
notes to yourself on the Notes area.

Slide Sorter View: Slide Sorter view shows thumbnails of all your slides. In Slide Sorter view,
you can easily add, delete, or change their order of your slides.

Slide Show: Use the Slide Show view when you want to view your slides, as they will
look in your final presentation. When in Slide Show view:

Esc Returns you to the view you were using previously.

Left-
clicking

Moves you to the next slide or animation effect.
When you reach the last slide, you automatically
return to your previous view.
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Right-
clicking

Opens a pop-up menu. You can use this menu to
navigate the slides, add speaker notes, select a
pointer, and mark your presentation.

Zoom allows you to zoom in and zoom out on the window. You can click and drag the
vertical and horizontal splitter bars to change the size of your panes.

You use the Minimize button to remove a window from view. While a window is
minimized, its title appears on the taskbar. You click the Maximize button to cause a
window to fill the screen. After you maximize a window, clicking the Restore button returns
the window to its former smaller size. You click the Close button to exit the window and
close the program.

2. Creating PowerPoint Presentation

You create your PowerPoint presentation on slides. You use layouts to organize the
content on each slide. PowerPoint has several slide layouts from which to choose. Themes are
sets of colors, fonts, and special effects. Backgrounds add a colored background to your slides.
You can add themes and backgrounds to your slides. After you complete your slides, you can
run your presentation.

2.1 Create a Title Slide

When you start PowerPoint, it displays the title slide in the Slide pane. You can type the
title of your presentation and a subtitle on this slide. To enter text:

 Click and type the title of your presentation in the "Click to add title" area.
 Click and type a subtitle in the "Click to add subtitle" area.

If you do not wish to use the title slide, click the Delete Slide button in the Slides group
on the Home tab.

EXERCISE 1

Create a Title Slide

1. Open PowerPoint. You are presented with a title slide.
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2. Enter the information shown here. Type College Scholarships and Financial Aid in the
Click to Add Title text box. Type Paying for College in the Click to Add Subtitle text
box.

2.2 Create New Slides

After completing your title slide, you can create additional slides. To create a new slide:

1. Choose the Home tab.

2. Click the New Slide button in the Slides group. The Office Theme dialog box
appears and displays several layout templates.

3. Click the layout you want. The layout appears in the Slide pane of the PowerPoint
window.
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3. To add text, click inside the placeholder and type.
4. To add an additional slide to your presentation, do one of the following:

Right-click the slide layout. A menu appears. Click Layout and then click the layout you
want.

EXERCISE 2

Create New Slides

1. Choose the Home tab.

2. Click the New Slide button in the Slides group. The Office Theme dialog box
appears.

3. Click the Title and Content Layout. The slide appears on the Slides tab.
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4. Enter the information shown here. Type Here is what to do: (including the colon) in the
Click to Add Title text box. Type the bulleted text in the Content text box.

2.3 Create an Outline

If you need to present the information in your slide in outline form, you can easily create an

outline by using the Increase List Level button to create a hierarchy.

1. Choose the Home tab.

2. Click the New Slide button in the Slides group. The Office Theme dialog box
appears.

3. Click the Title and Content layout.

4. Enter the information shown here. Click the Increase List Level button in the
Paragraph group to indent the bullets for Stafford Loans and PLUS Loans. If you ever

need to decrease an indent, use the Decrease List Level button in the Paragraph
group.

2.4 Create Two-Column Text

You can also place text in two separate columns.

1. Choose the Home tab.

2. Click the New Slide button in the Slides group. The Office Theme dialog box
appears.
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3. Click the Two Content layout.
4. Enter the information shown here.

3. Editing Slides
After creating a slide, if you want to add text:
1. Place the mouse pointer at the point at which you would like to add text.
2. Type the information you want to add.

If you would like to change text:
1. Select the text you want to change.
2. Type the new text.

You can use the Backspace key to delete text. You can also delete text by highlighting
the text and pressing the Delete key.

4. Apply a Theme

A theme is a set of colors, fonts, and special effects. Themes provide attractive
backgrounds for your PowerPoint slides. To apply a theme to all of the slides in your
presentation:

1. Choose the Design tab.

2. Click the More button in the Themes group.
3. Click the design you want.

To apply a theme to selected slides:

1. Click the Slides tab, located on the left side of the window.
2. Hold down the Ctrl key and then click to select the slides to which you want to apply a

theme.
3. Choose the Design tab.



Comprehensive & Viva… 11.11 Power Point

4. Click the More button in the Themes group.
5. Right-click the theme you want to apply. A menu appears.
6. Click Apply to Selected Slides. Excel applies the theme to the slides you selected.

You can add a dramatic effect to your theme by applying a background.

1. Choose the Design tab.

2. Click the Background Styles button .
3. Click the background you want.

EXERCISE 3

Apply a Theme

1. Choose the Design tab.

2. Click the More button in the Themes group.

3. Click the theme you want. PowerPoint applies the theme to all of the slides in your
presentation.

Add a Background
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1. Choose the Design tab.

2. Click the Background Styles button .
3. Click the background you want. PowerPoint applies the background to your slides.

5. Run PowerPoint Slide Show

After you create your slides, you can run your slide show:

1. Do any one of the following:
o Press F5.

o Choose the Slide Show tab. Click the From Beginning button in the Start
Slide Show group.

o Click the Slide Show icon in the bottom-right corner of your screen.

Your slide show appears on your screen.

Navigating the Slide Show

Task Procedure

Go to the next slide. Do one of the following:
 Press the Right Arrow key.
 Press the Enter key.
 Press the Page Down key.
 Left-click the slide.

Go to the previous slide. Do one of the following:
 Press the Left Arrow key.
 Press the Backspace key.
 Press the Page Up key.

End the slide show and return to
PowerPoint.

Press the Esc key.
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EXERCISE 4

Run Your Slide Show

1. Press F5 to run the slide show.
2. Use the arrow keys on your keyboard to move forward and backward through your

slides.
3. Use the Esc key to return to Normal view.
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Lesson 12

POWERPOINT - ANIMATIONS, TRANSITIONS,
SPELL CHECK, OUTLINE TAB, SLIDES TAB,

SORTER VIEW, AND PRINTING

12.0. Objective
The objective of this lesson is to explain about how to introduce animations and

transitions into slides to make the presentation effective. This lesson also teaches how to spell-
check your document, how to use the Outline and Slides tabs, how to use Sorter view, and how
to print.

After studying this lesson you can
- add animation to the slides
- add sound to the slide show
- spell check the slides
- take a print out of outline presentation
- take print out of slides

Structure
1. Introduction

2. Add Animations

3. Modify the Animation

4. Add Transitions

5. Add Sound and Set the Speed

6. Spell Check

7. Use the Outline and Slides Tabs

8. Use Slide Sorter View

9. Print

9.1 Print an Outline

9.2 Print Slides

9.3 Print Slides as Handout

1. Introduction

Animations control how objects move onto the slides and around your slides. It also
controls how objects move off from the slides. Transitions control how your presentation moves
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from one slide to the next. Different animation techniques are built in along with the package.
Applying animations and transitions make the slide show effective.

2. Add Animations

You can animate the objects on your PowerPoint slides. PowerPoint provides four types
of animations: Entrance, Emphasis, Exit, and Motion Paths.

An Entrance animation determines the manner in which an object appears on a slide; for
example, an object can move onto a slide.

An Emphasis animation does something to draw attention to an object; for example, the
object can become larger.

An Exit animation determines the manner in which an object leaves a slide; for example,
an object can move off a slide.

A Motion Paths animation determines how an object moves around a slide; for example,
an object can move from left to right.

After you add an animation, you can use the Custom Animation pane to modify it by
choosing an effect. Choosing an effect enables you to define what starts the animation, its
properties, and control the speed of the animation. In addition, you can have an animation start
when you click the mouse, start along with the previous animation, or start at a specified time
after the previous animation.

If the Auto Preview box is checked on the Custom Animation pane, PowerPoint provides
you with preview of your animation after you create it and each time you modify it. You can also

use the Play button on the Custom Animation pane to preview an animation.

To choose an effect:

1. Select the object you want to animate.
2. Choose the Animations tab.

3. Click the Custom Animation button . The Custom Animation pane
appears.

4. Click the Add Effect button . A menu appears.
5. Choose the type of effect you want. A submenu appears.
6. Click the effect you want. PowerPoint applies the effect.

To modify an effect:

1. Click the down arrow next to the Start field on the Custom Animations pane and then
select the start method you want.

2. Click the down arrow next to the Property field on the Custom Animations pane and the
select the property you want. The Property field might be labeled Direction, Size, or
some other property.

3. Click the down arrow next to the Speed field on the Custom Animations pane and then
select the speed you want to apply to your animation.

To preview the animation, click the Play button on the Custom Animations pane.
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EXERCISE 1

Add an Animation to a Slide

1. Click Slide 2 on the Slides tab.
2. Select "Start saving early."
3. Choose the Animations tab.

4. Click the Custom Animation button . The Custom Animation pane
appears.

5. Click the Add Effect button . A menu appears.
6. Choose Entrance. A submenu appears.
7. Click Fly In. PowerPoint applies the effect. If the Auto preview box is checked,

PowerPoint automatically provides you with a preview of the animation.

Modify the Effect

1. Click the down arrow next to the Start field and then select After Previous.
2. Click the down arrow next to the Direction field and then select From Bottom.
3. Click the down arrow next to the Speed field and then select Medium.



Acharya Nagarjuna University 12.4 Centre for Distance Education

Add Another Animation

1. Select "Apply for financial aid."

2. Click the Add Effect button . A menu appears.
3. Choose Entrance. A submenu appears.
4. Click Fly In. PowerPoint applies the effect. If the Auto preview box is checked,

PowerPoint automatically provides you with a preview of the animation.

3. Modify the Animation

1. Click the down arrow next to the Start field and then select After Previous. The Apply for
Financial Aid field appears in the center of the Custom Animation pane.

2. Click the down arrow next to the Apply for Financial Aid field and then click Timing.
The Fly In dialog box appears.
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3. Type 0.05 in the Delay text box.
4. Click OK.

5. Click the down arrow next to the Direction field and then select From Bottom.
6. Click the down arrow next to the Speed field and then select Medium. If the Auto

preview box is checked, PowerPoint automatically provides you with a preview of the

animation. You can click the Play button on the Custom Animation pane at
anytime to preview an animation.

4. Add Transitions

Transitions determine how your presentations move from one slide to the next. For
example, a slide can move up onto the screen and replace the previous slide. PowerPoint
provides several transition methods. You can add sound to a transition and you can control its
speed. You can apply a transition to selected slides or to all of the slides in your presentation.

A transition can occur when the presenter clicks the mouse or after the amount of time
you specify.

To apply a transition to selected slides:
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1. On the Slides tab, hold down the Ctrl key and then click the slides to which you want to
apply the transition.

2. Choose the Animations tab.

3. Click the More button in the Transition to this Slide group. A menu of transitions
appears.

4. Click the transition you want to apply. PowerPoint applies the transition. As you roll
your pointer over each transition, PowerPoint provides you with a live preview of the
transition.

To apply a transition to all slides:

1. Choose the Animations tab.

2. Click the More button in the Transition to this Slide group. A menu of transitions
appears.

3. Click the transition you want to apply. As you roll your pointer over each transition,
PowerPoint provides you with a live preview of the transition.

4. Click the Apply to All button in the Transition to This Slide group.

To add a sound to a transition:

1. Choose the Animations tab.
2. Click the down arrow next to the Transition Sound field and then click the sound you

want. As you roll your pointer over each sound, PowerPoint plays the sound.

To set the speed of a transition:

1. Choose the Animations tab.
2. Click the down arrow next to the Transition Speed field and then click the speed you

want.

If you want the transition to occur after the presenter clicks the mouse, check the ‘On
Mouse Click’ check box. If you want a transition to occur after a specified period of time, check
the ‘Automatically After’ check box and then specify the amount of time you want to elapse
before the transition occurs. The ‘On Mouse Click’ check box and the ‘Automatically After'
check box are both located on the Animations tab in the Transition to This Slide group.

EXERCISE 2

Add Transitions
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1. Choose the Animations tab.

2. Click the More button in the Transition to this Slide group. A menu of transitions
appears.

s

3. Click the Push Up transition. As you roll your pointer over each transition, PowerPoint
provides you with a live preview of the transition.

5. Add Sound and Set the Speed

You can add sound to your slide show by clicking some icons or using the menu
provided. The speed of the show also can be controlled. This will be done with following
window.

1. Click the down arrow next to the Transition Sound field and then click Click.
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2. Click the down arrow next to the Transition Speed field and then click Slow.

Advance Slide

1. Check the On Mouse Click check box.
2. Click the Automatically After check box.
3. Type 00:07 in the Automatically After text box.

4. Click the Apply to All button . PowerPoint applies all of your changes to
all of the slides.

5. Click Slide 1 on the Slides tab.
6. Type 00:03 in the Automatically After text box. PowerPoint changes the timing for Slide

1.

6. Spell Check

PowerPoint checks the spelling as you type and displays errors with a red wavy line under
the misspelled word. You can right-click and then select the correct spelling from the list of
offerings on the menu that appears or select Spelling to open the Spelling dialog box. If you need
to, you can initiate a spell check anytime you like. To start a spell check, do one of the
following:

 Press F7.

 Choose the Review tab and then click the Spelling button .

If the spell check finds a possible spelling error, the Spelling dialog box opens with the
spelling error highlighted. You can respond in several ways.
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Response Procedure

Do not change spelling. Click Ignore.

Correct spelling. 1. Click the correct spelling in the
Suggestions box.

2. Click Change.

Add to dictionary. Click Add.

Word is correct. Do not change
presentation.

Click Ignore All.

Word is incorrect. Change
entire presentation.

Click Change All.

EXERCISE 3

Spell Check

1. Press F7
2. Correct any spelling errors PowerPoint finds. If PowerPoint does not find any errors,
the Spelling Check is Complete message box appears. Click OK.

7. Use the Outline and Slides Tabs

By default, the Outline and Slides tabs are located on the left side of your PowerPoint
window. The Outline tab displays the text contained in your presentation. The Slides tab displays
a thumbnail of all your slides. You click the thumbnail to view the slide in the Slide pane.

EXERCISE 4

Use the Outline and Slides Tabs
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1. Choose the Slides tab to view thumbnails of your slides.

2. Choose the Outline tab to view the text of your presentation as an outline.

8. Use Slide Sorter View

After you have created your PowerPoint slides, you can move, cut, copy, paste, duplicate,
navigate, and view them in Sorter view. To view the slides in Sorter view, do one of the
following:

 Choose the View tab and then click the Slide Sorter button in the Presentation
Views group.

 Click the Slide Sorter button in the bottom-right corner of the PowerPoint window.
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Slide Sorter View

Task Procedure

Move to first slide. Use Ctrl+Home.

Move to last slide. Use Ctrl+End.

Move to next slide. Use the right arrow.

Move to previous slide. Use the left arrow.

Select a slide. Single-click the slide.

Open a slide in Normal view. Double-click the slide.

Select slides. Select a single slide:
1. Click the slide you want to

select.

Select multiple slides:
1. Hold down the Ctrl key.
2. Click the slides you want to

select.

Delete a slide. 1. Select the slide or slides
you want to delete.

2. Press the Delete key.

1. Select the slide or slides
you want to delete.

2. Choose the Home tab and
then click the Delete button

.

Copy a slide. 1. Select the slide.
2. Choose the Home tab.

3. Click the Copy button
in the Clipboard group.

1. Select the slide.
2. Press Ctrl+C.

Paste a slide. 1. Select the slide after which
you want the new slide or
slides to appear.

2. Choose the Home tab.

3. Click the Paste button
in the Clipboard group.
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Slide Sorter View

Task Procedure

1. Select the slide after which
you want the new slide or
slides to appear.

2. Press Ctrl+V.

Cut a slide. 1. Select the slide or slides
you want to cut.

2. Choose the Home tab.

3. Click the Cut button in
the Clipboard group.

1. Select the slide or slides
you want to cut.

2. Press Ctrl+X.

Move a slide. 1. Select the slide (or slides)
you want to move.

2. Drag it to the new location.

Duplicate a slide. 1. Select the slide (or slides)
you want to duplicate.

2. Press Ctrl+D.

EXERCISE 5

Use Slide Sorter View
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1. Choose the View tab.
2. Click Slide Sorter in the Presentation Views group.
3. Double-click a slide to view it in Normal view.

9. Print
PowerPoint provides you with many printing options. You can print a large view of your

slides or you can print your slides as handouts with 1, 2, 3, 4, 6, or 9 slides per page. You can
also print your Notes pages or the Outline view of your slides.

To print:

1. Click the Microsoft Office button. A menu appears.
2. Choose Print.
3. Click Print Preview.
4. Click the down arrow next to the Print What field in the Page Setup group and then select

what you would like to print. A preview appears onscreen.
5. Click the Print. The Print dialog box appears.
6. Click the down arrow next to the Color/Grayscale field to select whether you want your

slides to print in color, grayscale, or black and white. If you are using a black and white
printer, choose black and white. You will use less ink or toner.

7. Click OK.

9.1 Print an Outline
EXERCISE 6
Print an Outline

1. Click the Microsoft Office button. A menu appears.
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2. Choose Print.
3. Click Print Preview. The Print Preview tab appears.

4. Click the down arrow next to the Print What field in the Page Setup group and then select
Outline View.

5. Click the Print button . The Print dialog box appears.
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6. Click the down arrow next to the Color/Grayscale field to select whether you want your
slides to print in color, grayscale, or black and white. If you are using a black and white
printer, choose black and white. You will use less ink or toner.

7. Set the other print settings.
8. Click OK. Your outline prints.

9.2 Print Slides

1. Click the Microsoft Office button. A menu appears.
2. Choose Print.
3. Click Print Preview. The Print Preview tab appears.
4. Click the down arrow next to the Print What field in the Page Setup group and then select

Slides.

5. Click the Print button . The Print dialog box appears.
6. Click the down arrow next to the Color/Grayscale field to select whether you want your

slides to print in color, grayscale, or black and white. If you are using a black and white
printer, choose black and white. You will use less ink or toner.

7. Set the other print settings.
8. Click OK. Your slides print.

9.3 Print Slides as a Handout

1. Click the Microsoft Office button. A menu appears.
2. Choose Print.
3. Click Print Preview. The Print Preview tab appears.
4. Click the down arrow next to the Print What field in the Page Setup group and then select

Handouts (4 slides per page).

5. Click the Print button . The Print dialog box appears.
6. Click the down arrow next to the Color/Grayscale field to select whether you want your

slides to print in color, grayscale, or black and white. If you are using a black and white
printer, choose black and white. You will use less ink or toner.

7. Set the other print settings.
8. Click OK. Your handouts print.



Comprehensive & Viva… 13.1 Internet

Lesson 13

INTERNET

13.0. Objective

The main objective of this lesson is to explain briefly what is Internet and how to take
Internet connectivity and hardware requirements. This lesson also explains the browsers needed to
search the Internet. Various search techniques adopted by search engines are also discussed to
enable you to retrieve web information available in the Internet.

After studying this lesson you will be able to know
- what is Internet
- types of Internet connectivity
- Internet services
- search engines
- search strategies
- searching methods

Structure

1. Introduction
2. Internet Access
3. Internet Services

3.1 World Wide Web (WWW)
3.2 Communication

3.3 Data Transfer
4. Net Searching

4.1. Search Strategies
5. Search Engines
6. Subject Directories
7. Gateways and Subject-Specific Databases
8. Reading Web Addresses

8.1 Determining the Authenticity of Web Page
9. Starting Search

9.1 Creating a Search Statement
9.2 Boolean Searches
9.3 Proximity Operators
9.4 Field Searching, Title Searching and Domain Searching

1. Introduction

The Internet is a global system of interconnected computer networks. It is anetwork of
networks that consists of millions of private, public, academic, business, and government
networks. It uses the standard Internet protocol suite (TCP/IP) to serve several billion users
worldwide. The Internet carries an extensive range of information resources and services, such as
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the inter-linked hypertext documents of the World Wide Web (WWW) and the infrastructure to
support email. Internet is a super high way of information. In the present day IT environment
almost everyone is depending on Internet to get information for one thing or the other.
Information is now available in the form of World Wide Web through Internet. World Wide Web
is a store of interlinked information which is stored in the computers in the form of Hyper Text.

2. Internet Access:

Internet access connects individual computer to the Internet. Internet Service Providers
(ISP) offer Internet access to the public in different types of access. Most Internet access was
from personal computers and workstations directly connected to local area networks or from dial-
up connections using modems and analog telephone lines. Now Broadband access such as ISDN,
DSL, Leased Line, Cable and Wireless are being provided by many ISPs.

3. Internet Services:

The main services of the internet are World Wide Web (WWW), Communication (email,
IRC, Newsgroups etc) and Data transfer (FTP).

3.1 World Wide Web (WWW):

The World Wide Web is a global set of documents, images and other resources, logically
interrelated by hyperlinks and referenced with Uniform Resource Locators (URLs). URLs
symbolically identify services, servers, and other databases, and the documents and resources that
they can provide. Hypertext Transfer Protocol (HTTP) is the main access protocol of the World
Wide Web.

World Wide Web browser software, such as Microsoft's Internet Explorer, Mozilla
Firefox, Opera, Apple's Safari, and Google Chrome, lets users navigate from one web page to
another via hyperlinks embedded in the documents. These documents may also contain any
combination of computer data, including graphics, sounds, text, video, multimedia and interactive
content that runs while the user is interacting with the page. . Through search
engines like Yahoo! and Google, users worldwide have easy, instant access to a vast and diverse
amount of online information. Compared to printed media, books, encyclopedias and traditional
libraries, the World Wide Web has enabled the decentralization of information on a large scale.

3.2 Communication

Email is an important communications service available on the Internet. Internet
telephony is another common communications service made possible by the creation of the
Internet. VoIP stands for Voice-over-Internet Protocol, referring to the protocol that underlies all
Internet communication. Internet Relay Chat is also an interactive communication available on
the Internet. The search engines like Google, Yahoo, Rediff etc. provide free email accounts to
the users.

3.3 Data transfer

File sharing is an example of transferring large amounts of data across the Internet.
A computer file can be emailed to customers, colleagues and friends as an attachment. It can be
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uploaded to a website or FTP server for easy download by others. Streaming media is the real-
time delivery of digital media for the immediate consumption or enjoyment by end users.

4 Net Searching:

Having Internet connection from Internet Service Provider is the pre-requisite to conduct
search for information on the Internet. Assuming that you have an internet connection, you are
explained with procedure to search Internet.

Switch on the computer. Double click on any browser, such as Internet Explorer, Mozaic
or Google Chrome, available on your desktop. You can conduct search for information by
selecting suitable search engine required for your search.

4.1 Search Strategies
Internet is a super high way of information. In the present day IT environment almost

everyone is depending on Internet to get information for one thing or the other. Information is
now available in the form of World Wide Web through Internet. World Wide Web is a store of
interlinked information which is stored in the computers in the form of Hyper Text. From
common man to scholar, everyone who uses the Internet has had the experience of getting
hundreds of results when conducted a web search. By choosing the appropriate search engine,
controlling the terms that you search for, and using a few tricks, you can make
Internet searching faster and more efficient.

5. SEARCH ENGINES

Search engines are huge databases of web page files that have been assembled
automatically by machine. Search engines compile their databases by employing "spiders" or
"robots" ("bots") to crawl through web space from link to link, identifying and perusing pages.
Search engines are best at finding unique keywords, phrases, quotes, and information buried in
the full-text of web pages available on computers connected to Internet.

Examples of Search Engines:

 Google
 Ask
 Gigablast
 Yahoo! Search
 Rediff

6. SUBJECT DIRECTORIES

Subject directories, unlike search engines, are created and maintained by human editors,
not electronic spiders or robots. The editor review and select sites for inclusion in their directories
on the basis of previously determined selection criteria. The resources they list are usually
annotated.
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Subject directories are best for browsing and for searches of a more general nature. They
are good sources for information on popular topics, organizations, commercial sites and products.

EXAMPLES OF SUBJECT DIRECTORIES AND PORTALS :

Subject Directories

 Beaucoup
 LookSmart
 Open Directory Project
 Yahoo

Portals (subject directories serving as home pages)

 Excite
 MSN directory
 Netscape
 Yahoo! directory

7. GATEWAYS AND SUBJECT-SPECIFIC DATABASES

Gateways

There are two kinds of gateways: library gateways and portals. Library gateways are
collections of databases and informational sites, arranged by subject, that have been assembled,
reviewed and recommended by specialists, usually librarians. These gateway collections support
research and reference needs by identifying and pointing to recommended, academically-oriented
pages on the Web. See list of examples below.

Subject-Specific Databases (sometimes called "Vortals")

Subject-specific databases, or vortals (i.e., "vertical portals") are databases devoted to a
single subject, created by professors, researchers, experts, governmental agencies, business
interests, and other subject specialists and/or individuals who have a deep interest in, and
professional knowledge of, a particular field and have accumulated information and data about it.
See list of examples below.

Use library gateways when you are looking for high quality information sites on the Web.
You can be fairly certain that these sites have been reviewed and evaluated by subject specialists
for their accuracy and content.

Use subject-specific databases when looking for information on a specific topic, e.g., news
links, multimedia files, archives, mailing lists, people, job finders, and thousands of databases
devoted to specific topics of interest. Today, more and more of the so-called "main-stream" search
engines, subject directories and portals are pointing to these subject-specific databases, using
direct links on their home pages.
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EXAMPLES OF LIBRARY GATEWAYS

 Academic Information
 Digital Librarian
 Infomine
 Internet Public Library
 Librarians' Index to the Internet
 PINAKES
 WWW.VirtualLibrary.com

EXAMPLES OF SUBJECT-SPECIFIC DATABASES

 Educator's Reference Desk (educational information)
 Expedia (travel)
 Internet Movie Database (movies)
 Jumbo Software (computer software)
 Kelley Blue Book (car values)
 Monster Board (jobs)
 Motley Fool (personal investment)
 MySimon (comparison shopping)
 Roller Coaster Database (roller coasters)
 Voice of the Shuttle (humanities research)
 WebMD (health information)

8. READING WEB ADDRESSES

First, you need to know how to read a web address, or URL (Universal Resource Locator).
Let's look at the URL for this tutorial:

http://www.nagarjunauniversity.ac.in/deptdet.asp?id=1005 Here's what it all means:

 "http" means hypertext transfer protocol and refers to the format used to transfer and deal
with information

 "www" stands for World Wide Web and is the general name for the host server that
supports text, graphics, sound files, etc. (It is not an essential part of the address, and some
sites choose not to use it)

 "nagarjunauniversity" is the domain name and usually designates the server's location, in
this case, the Acharya Nagarjuna University.

 "ac" is second level domain name
 “deptdet” is the file name
 ".asp " is the file type extension and, in this case, stands for "active server page”

Here is a list of the domains that have been in operation for the past several years and
are generally accepted by all:
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 .edu -- educational site (usually a university or college)
 .com -- commercial business site
 .gov -- U.S. governmental/non-military site
 .mil -- U.S. military sites and agencies
 .net -- networks, internet service providers, organizations
 .org -- U.S. non-profit organizations and others

8.1 Determining the Authenticity of Web Page

You can tell a lot about the authenticity of a page by finding out all you can about its
author/publisher. A reputable Web page will usually provide you with the following information:

 Last date page updated
 Mail-to link for questions, comments
 Name, address, telephone number, and email address of page owner

9. Starting Search

It's always a good idea to THINK about your search before you begin. Create a search
strategy in your head by asking yourself this question:

What do I want to do?

1. Browse?
2. Locate a specific piece of information?
3. Retrieve everything I can on the subject?

Your answer will determine how you conduct your search and what tools you will use.

1. If you're browsing and trying to determine what's available in your subject area, start out
by selecting a subject directory like Yahoo!. Then, enter your search keyword(s) into one
of the meta search engines, such as Vivisimo, just to see what's out there.

2. If you're looking for a specific piece of information, go to a major search engine such as
Google, or to a specialized database such as Bureau of the Census (for statistics).

3. If you want to retrieve everything you can on a subject, try the same search on several
search engines.

In your search statement, if you enter more than one keyword without using any
accompanying sign, mark or symbol, the search engine will automatically add either the AND or
the OR conjunction to link your search terms together.

9.1 Creating a Search Statement
When structuring your query, keep the following tips in mind:

 Be specific
EXAMPLE: Hurricane Hugo

 Whenever possible, use nouns and objects as keywords
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EXAMPLE: fiesta dinnerware plates cups saucers
 Put most important terms first in your keyword list; to ensure that they will be searched,

put a +sign in front of each one
EXAMPLE: +hybrid +electric +gas +vehicles

 Use at least three keywords in your query
EXAMPLE: interaction vitamins drugs

 Combine keywords, whenever possible, into phrases
EXAMPLE: "search engine tutorial"

 Avoid common words, e.g., water, unless they're part of a phrase
EXAMPLE: "bottled water"

 Think about words you'd expect to find in the body of the page, and use them as keywords
EXAMPLE: anorexia bulimia eating disorder

 Write down your search statement and revise it before you type it into a search engine
query box

EXAMPLE: +"south carolina" +"financial aid" +applications +grants
 Use the plus (+) and minus (-) signs in front of words to force their inclusion and/or

exclusion in searches.

EXAMPLE: +meat -potatoes
(NO space between the sign and the keyword)

 Use double quotation marks (" ") around phrases to ensure they are searched exactly as is,
with the words side by side in the same order.
EXAMPLE: "bye bye miss american pie"
(Do NOT put quotation marks around a single word.)

 Put your most important keywords first in the string.
EXAMPLE: dog breed family pet choose

 Type keywords and phrases in lower case to find both lower and upper case versions.
Typing capital letters will usually return only an exact match.

EXAMPLE: president retrieves both president and President
 Use truncation (or stemming) and wildcards (e.g., *) to look for variations in spelling and

word form.
EXAMPLE: librar* returns library, libraries, librarian, etc.
EXAMPLE: colo*r returns color (American spelling) and colour (British spelling)

 Combine phrases with keywords, using the double quotes and the plus (+) and/or minus (-)
signs.
EXAMPLE: +cowboys +"wild west" -football –dallas
(In this case, if you use a keyword with a +sign, you must put the +sign in front of the
phrase as well. When searching for a phrase alone, the +sign is not necessary.)

 When searching within a document for the location of your keyword(s), use the "find"
command on that page.

 Know the default (basic) settings your search engine uses (OR or AND). This will have an
effect on how you configure your search statement because, if you don't use any signs (+, -
, " "), the engine will default to its own settings.
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9.2 Boolean Searches

Boolean logic operators are AND, OR, and NOT, which we use to link words and phrases
for more precise queries.

 In Boolean searches, always enclose OR statements in parentheses.
EXAMPLE: Yosemite (campgrounds OR reservations)

 Always use CAPS when typing Boolean operators in your search statements. Most
engines require that the operators (AND, OR, AND NOT/NOT) be capitalized. Other
engines will accept either CAPS or lower case, so you're on safe ground if you stick to
CAPS.
EXAMPLE: "immune system" AND homeopathic (medicine OR remedy)

BOOLEAN "AND"

The Boolean AND actually narrows your search by retrieving only documents that contain
every one of the keywords you enter. The more terms you enter, the narrower your search
becomes.

EXAMPLE: truth AND justice

EXAMPLE: truth AND justice AND ethics AND congress

BOOLEAN "OR"

The Boolean OR expands your search by returning documents in which either or both
keywords appear. Since the OR operator is usually used for keywords that are similar or
synonymous, the more keywords you enter, the more documents you will retrieve.

EXAMPLE: college OR university

EXAMPLE: college OR university OR institution OR campus

BOOLEAN "NOT" / "AND NOT"

The Boolean NOT or AND NOT (sometimes typed as ANDNOT) limits your search by
returning only your first keyword but not the second, even if the first word appears in that
document, too.

EXAMPLE: saturn AND NOT car

EXAMPLE: pepsi AND NOT coke

NESTING -- WITH BOOLEAN OPERATORS
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Nesting, i.e., using parentheses, is an effective way to combine several search
statements into one search statement. Use parentheses to separate keywords when you
are using more than one operator and three or more keywords.

EXAMPLE: (hybrid OR electric) AND (Toyota OR Honda)

(For best results, always enclose OR statements in parentheses.)

IMPLIED BOOLEAN OPERATORS

Implied Boolean operators use the plus (+) and minus (-) symbols in place of
the full Boolean operators, AND and NOT. Typing a (+) or (-) sign in front of a word

will force the inclusion or exclusion of that word in the search statement.

EXAMPLE: +dementia -alzheimers

Similarly, putting double quotation marks (" ") around two or more words will
force them to be searched as a phrase in that exact order.

EXAMPLE: "green tea"

While full Boolean operators are usually accepted only in the advanced search
option of search engines, implied Boolean operators are accepted in the basic search
options of most search engines.

9.3 Proximity Operators

Proximity, or positional, operators (NEAR, ADJ, SAME, FBY) are not really part of
Boolean logic, but they serve a similar function in formulating search statements.

The NEAR operator allows you to search for terms situated within a specified distance of
each other in any order. The closer they are, the higher the document appears in the results list.
Using NEAR, when possible, in place of the Boolean AND usually returns more relevant results.

EXAMPLE: phylogeny NEAR ontogeny

EXAMPLE: de Vere NEAR Shakespeare

Even fewer search engines accept ADJ (adjacent to). ADJ works as a phrase except that
the two terms, which must appear adjacent to each other in the webpage, can appear in any order.

EXAMPLE: Ernest ADJ Hemingway

EXAMPLE: endangered ADJ species
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The above example retrieve both Ernest Hemingway and Hemingway Ernest; endangered
species and species endangered.

9.4 Field Searching, Title Searching and Domain Searching

Electronic records, like print records, are organized into separate fields. A typical web
page is composed of the following major fields: title, domain, host (or site), URL, and link. When
information is entered into a record's field, some search engines allow you to retrieve it by using
the correct field label in combination with your search term(s). Where available, field searching
on the Web is a very powerful tool. It allows you to specify exactly where you want the search
engine to look in the Web document.

EXAMPLE: title: "web search tutorial"

EXAMPLE:

domain:edu AND "Origin of Species" AND Darwin limits your search to educational
sites dealing with Charles Darwin and his theory of evolution.

HOST (OR SITE) SEARCHING

If you are seeking information that resides on a specific computer or server, you can
narrow your search with a "host" or "site" query.

EXAMPLE: host:www.anucde.info

returns pages hosted at the Acharya Nagarjuna University Centre for Distance education.

Exercise:

1. Try to find the URL of Centre for Distance Education, Acharya Nagarjuna
University

2. Open web site of Centre for Distance Education, Acharya Nagarjuna University
and find whether it is offering M.L.I.Sc.?

3. Find and collect information (about 2-5 pages) on Colon Classification
4. Search using the following words as phrase and using Boolean operators

Automation of University Libraries in India
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UNIT – 4 : Lesson 14:

CDS/ISIS PACKAGE

14.0. OBJECTIVE

The main objective of this lesson is to explain the main window of CDS/ISIS package.
It also illustrates how to create database using CDS/ISIS by explaining creation of FDT,
Worksheet, FST and Display format.

After studying this lesson you will be able to learn

- history of CDS/ISIS Package
- loading/installing the package
- creating database

Structure

1. Introduction
2. Overview of CDS/ISIS for WINDOWS
3. The WINDOWS Version: The Main Menu
4. Installation

4.1 Loading the Package
4.2 System Parameter File, Syspar.par

5. Creating Database
5.1 Choice of tagging scheme
5.2 Field Definition Table (FDT)
5.3 Data Entry Worksheet
5.4 Default Display Format
5.5 Field Selection table (FST)
5.6 Stop word List

6. Exercises
7. References

1. INTRODUCTION

Library automation is the order of the day. Library of Congress, USA is the first library
that introduced application of computer in library operations. Since then many software
packages have came into existence to use in libraries. CDS/ISIS is one of the library software
packages. CDS/ISIS for microcomputers developed by UNESCO (the United Nations
Educational, Scientific and Cultural Organization) is one of the widely used information
storage and retrieval package. CDS/ISIS which runs under DOS operating system was
released in the year 1985. The first version of CDS/ISIS for windows was released in the year
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1991. It runs under Microsoft Windows. The Windows version is called WINISIS. The DOS
version is written in PASCAL language. ISIS for Windows is written in a combination of
languages, primarily C and C++. However the PASCAL interface is given to write
programs and integrate into WINISIS.

2. OVERVIEW OF CDS/ISIS FOR WINDOWS

CDS/ISIS for Windows is, as its name implies, a Windows-based system. It allows you
to have more than one CDS/ISIS database open. CDS/ISIS was developed for bibliographic
information, i.e. information about documents such as books, journal articles or conference
proceedings. Usually each record in the database contains information about one document.
Many of the features of CDS/ISIS are different from those in database management systems
which have been designed for general purposes. The major differentiating feature of
CDS/ISIS when compared with other database management systems is in its use of variable
length text fields, repeatable fields and unpredicted fields. It also handles subfields and
Inverted file for faster searching of the database. Another feature of the package is the
flexibility of the screen and printed displays achieved by a sophisticated formatting language.
This formatting language gives users of CDS/ISIS a higher level of control over their data
than is found probably in any commercial library automation package.

Each database includes a master file and cross-reference file. The master file contains
the data and the cross-reference file includes for each record, by sequential master file
number, a pointer to where the data belonging to that record occur in the Master file.
Database records are numbered from 1.

3. THE WINDOWS VERSION: THE MAIN MENU

At this point we are assuming that CDS/ISIS for Windows has been loaded on your
computer and that the machine has been switched on and Windows is running. Open the
CDS/ISIS for Windows program by clicking on the WINISIS icon. This will run the program
and display the main menu.

Let us look at the drop-down menus from left to right.

Database leads to the functions associated with a database. In other Windows
programs, this would usually be F for File. If you have just opened the program by clicking
on the WINISIS icon, you will have only four options, Open, New, Printer Setup and Exit.
Other options are greyed out as shown in Figure 1 You will see them in a light shade of grey
in contrast with the black of other menus. This is a convention used by most programs which
run under Windows which indicates that that option is not at that time available. There may
also be a list of the last five databases open on which you may also click to retrieve one.
These will always be in black.
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Figure 1 Opening screen with database drop-down menu

You open a database by choosing Open, or the icon on the very left of the tool bar, a
picture of an open card file. This brings up a Window entitled File Selection (Figure 1.2).
This is in the usual Windows format giving the possibility of browsing through drives and
folders to find the appropriate 'file name' which will be an mst file or a par file. When you
have clicked on a database to open it, all options under Database will become accessible.
You will see at the same time as a database is opened that more icons appear on the tool
bar.

Figure 2 File selection window
Close and Close All are self explanatory and result in the closing of one or all

databases. The other functions which become available are Import, Export, I/F Update (i.e.
Inverted File Update) and Print. Print is conventionally found on the left hand drop down
menu in Windows applications and the other options here are for file maintenance, adding to
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a file, extracting a file and indexing the database. Exit will close the CDS/ISIS for Windows
program and take you back to the Windows desktop.

Browse ({Alt b} from the menu bar) has nine functions which cannot be operated
unless a database has been opened. Click onDatabase to view the records in a database in
database order. Click on Search results... to go to a list of previous searches from where
you may view the records retrieved by any earlier search in that session. You may mark any
records that you view. Then you can click on Marked records to view only those that have
been marked. Or you can revert to all records retrieved by selecting All records. You may
open the dictionary by clicking on Open dictionary to see which terms have been indexed
in which fields (Figure 3).

Choose Search {Alt s}and you will have access to two kinds of search, Expert Search
or Guided Search. It also allows you to go back to a previously saved search (the search may
have been saved at any previous occasion) Recall saved search or to save the results of the
present search for future use: Save search. Close Search Window is no mystery: it allows you
to close the expert or guided search window when you wish to look through the records you
have retrieved.

Edit {Alt e}is the gateway to Data entry and modifying the database structure. (If you
are running in read only mode, you will not have access to this menu.) Data entry functions
are accessed by Data entry to call up the Data Entry window which lets you edit the record
you were looking at in the browse or search window or lets you create a new record. Delete
will delete the record you are looking at in the data entry window. You can also copy the
record you have on screen into the Windows clipboard with Copy to clipboard or clear the
clipboard by choosing Clear clipboard.

Figure 3 Dictionary open
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From this drop down menu, you can modify the database you are in via the Field
Definition Table or Field Selection Tables. You can also edit or add new Print Formats.

Configure {Alt c}allows you to change the language of the menus and other features
of the database and many other system settings.

Utilities {Alt u}includes global additions and deletions. Also included is the facility
to compile ISIS/Pascal programs.

Windows {Alt w}allows the windows open to be arranged on the screen.

Finally there is a Help drop down menu in the usual Windows style with a contents list
and a keyword search.

4. INSTALLATION

4.1 LOADING THE PACKAGE

The package may be distributed on CD-ROM or on two 3.5 inch Floppy disks called
'Disk 1' and 'Disk 2’.

The minimum computer system requirements are an Intel Pentium processor,
16Mb of RAM, 10Mb hard disk space, 3.5 inch high-density floppy disk drive, CD or
DVD drive and the operating system Windows.

If you are installing from CD-ROM, place the CD in your drive and it should load
automatically. If not, run the program install.exe in its root directory. If you are installing
from floppy disks, insert Disk 1 in the floppy disk drive and run the program setup.exe.
When all the files have been copied from both disks, click OK to accept the license
conditions. The system respond with dialogue “The setup process was successful!” and
you can click OK to finish. If the shortcut (icon) for CDS/ISIS has not appeared, you can
create one using the values:

Target: c:\winisis\wisis.exe
Start in: c:\winisis

Now you can try starting CDS/ISIS for Windows by clicking its icon.

When you install, The Windows version of CDS/ISIS is normally installed on a hard disk
in a folder (directory) called winisis in C drive: so this folder will be c:\winisis. The package
comes with over 200 files and these are usually installed into a number of subfolders of winisis
as shown below:
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WINISIS
|

------------------------------------------------------------------------------------------------
| | | | | | | | |

bg ctl3d data doc menu msg plugin prog work

The winisis folder itself contains the main ISIS program, wisis.exe and an
important parameter file, syspar.par. It also contains the help file, isishlp.hlp, a
readme file with the latest release notes, and some configuration files.

The bg subfolder contains about 30 bitmap (image) files used by the sample
database provided. The subfolder called ctl3d contains two Dynamic Link Library files
(with the filename extension .dll). The data subfolder is intended to hold CDS/ISIS
databases. Each database consists of at least 13 files with different file extensions, e.g.:

cds.mst The master file for CDS
cds.fdt The Field Definition Table for CDS
cds.pft The default print format for CDS
cds.ifp The inverted file postings for CDS

There are also a few files whose names do not consist of the database name plus a file
extension. acds.fmt is the first page of the data entry worksheet for CDS. To start with, you
can keep all your database files in the data subfolder, but if you have several databases they
might be better in sub-subfolders, e.g. c:\winisis\data\cds.

The doc subfolder is intended to hold documentation files. The menu subfolder
contains the menu items in various languages used by CDS/ISIS. The msg subfolder
contains one database for each language. The plugin subfolder is provided to hold plugin
programs which will enhance the abilities of CDS/ISIS. The prog subfolder is intended for
holding additional Pascal programs to be used in conjunction with CDS/ISIS. The final
subfolder is work and is used to hold workfiles created by CDS/ISIS

4.2 SYSTEM PARAMETER FILE, SYSPAR.PAR

Fundamental to the working of CDS/ISIS is the system parameter file called
syspar.par. The installation program will set up a standard version for you. However, the
file gives a lot of flexibility in the way that CDS/ISIS is set up. The file itself has a number
of lines, each of which sets a numbered parameter to a particular value, e.g.

3=c:\winisis\msg\

The most important parameters of the syspar.par file are:
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1=c:\winisis\prog\
2=c:\winisis\menu\
3=c:\winisis\msg\
4=c:\winisis\work\
5=c:\winisis\data\
6=books

5. CREATING A DATABASE

A database is usually constructed to store information about some things or persons. For
example, a bibliographic database contains information about documents, such as books, journal
articles or conference proceedings. A personnel database contains information about employees.
The database consists of records and there is generally a one-to-one correspondence between the
records and the things described. In a bibliographic database one record may correspond to one
book or journal article: in a personnel database one record may correspond to one employee.

In CDS/ISIS terms, a record is made up of a number of fields. Each field contains data
about some particular aspect or attribute of the thing or person, for example the author, title
and year of publication etc., in a bibliographic database, or the name, address and grade in a
personnel database. A sample record from a bibliographic database is shown below.

ISBN 9780878150064
Author F.W. Lancaster
Title Vocabulary control for Information Retrieval
Imprint Washington: Information Resources Press, 1972
DDC No. 025.3

It is possible that you might need to store more than one value in a field − for example
two authors in the record above. As explained earl ier the bibliographic database has
the following three special features:

1. A field may have more than one value. For example a book may be written by
two or three authors. CDS/ISIS has special provision for this by allowing
fields to be defined as repeatable: the author field is repeated to contain the
second author.

2. A field may need to be divided into subfields for different purposes. For
example the author field may be divided into entry element and other
elements for cataloguing purpose. CDS/ISIS also allows you to divide up
fields into subfields. Subfields are designated by a single lower case letter
and when entering data this letter is prefixed by a circumflex, ^. Thus the
name F.W. Lancaster might be entered as

^aLancaster^bF.W.

If data are divided up like this, the user can specify different treatment of different
parts of the field. For example, the entry element could be made searchable but not the
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other elements.

5.1 CHOICE OF TAGGING SCHEME

Before you create a database with CDS/ISIS you need to decide on a format, i.e. what
fields will be used and how you will record the data in them. The choice of fields is not
final: you can modify them later.

There are quite a lot of 'standard' bibliographic and other formats existing, such as the
national MARC formats, UNIMARC and the Common Communication Format. If you are
contemplating exchanging data with other organizations, it would be a good idea to find out
what they are using and to agree on a common format. However, if you expect to be quite
self-contained you are at liberty to make up your own format to suit your own purposes.

Each field in CDS/ISIS must have a numeric 'tag' to identify it. This is a number
between 1 and 999. If you are making up your own format you could number your fields 10,
20, 30, etc., so there is room to slot others in between them later. If you are using a standard
data structure you have to follow the tags allocated for the fields in that format.

When you have decided on your format you can start up CDS/ISIS and choose
Database and select New. You are then asked to give the database a name of up to six
characters. Then choose OK.

In CDS/ISIS, once you have decided on your format and started creating database you will
be required to complete following four forms in setting up the database, otherwise the system
does not allow you to exit from the system.

1. Field Definition Table (FDT)

2. Data Entry Worksheet

3. Display Format

4. Field Selection Table (FST).

5.2 FIELD DEFINITION TABLE (FDT)

The FDT defines the fields that may be present in the database and certain parameters
for each field. The window of the FDT contains different boxes which are described
below. You enter the values in the boxes at the top of the dialog box. It is better to be
careful while defining FDT, although CDS/ISIS allows you to change it later. The
boxes are as follows:

(a) Tag -- You can use the up and down arrows if you like to select the number, or type
it in.

(b) Name -- this is to help you identify the field. It can be up to 31 characters long and
can contain spaces. When you come to set up the data entry worksheet, this name will
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be used as the prompt for the field, but you can override it there. It is also used to
specify the field in the “Guided Search” form.

(c) Type – The values for the type of field are Alphabetic, Numeric and alphanumeric. It
is better to use Alphanumeric which can accommodate letters, numbers and special
characters.

(d) Rep[eatable]. If the fields you are defining contain multiple occurrences, e.g.
several authors or several descriptors, click this checkbox.

(e) Pattern/subfields. If you are dividing the field into subfields, you should list the
subfields here (without punctuation or spaces) e.g. abc

When you have entered the data for each field, either click the Add button or press
{Enter} to add the field to the table (displayed in the large box). If you need to correct the
details for any field, just click on that entry in the large box and the details will be copied into
the boxes used for editing. If you need to remove an entry, highlight it and click the Delete
Entry button. You can sort the fields in ascending or descending order of the tag
number. You can also alter the order of fields by selecting a field and clicking the up-arrow or
down-arrow key. The fields defined need not have to be in numeric order, though that is better
and clear. You can save your work in the middle while defining FDT by clicking Save button.
After entering all the fields, click the OK button with the green arrow to go on. An example of
an FDT is shown in the following figure.
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Figure 4 Example of a Field Definition Table (FDT)

5.3 DATA ENTRY WORKSHEET

You will enter data into the database using a worksheet, rather like an input form.
CDS/ISIS allows you to have more than one worksheet. The main choice is which fields you
want to be on the worksheet. If you only have one worksheet then normally you will want
them all, and you need only to click the button with the double arrow to effect this. If you
want to have selected fields, or to change the order of fields on the worksheet, you can
select fields one at a time and either double-click the field or click the button with the single
arrow. The order need not have to be by ascending tag number.

You can make the worksheet do more by highlighting one of the Data Entry Fields
(when you have moved some onto the worksheet) and clicking the button showing a pencil
and paper. This brings up a dialog box with some further options:

Description: This allows you to use a different name on the worksheet from the
name you have used in the FDT.

Default value: Certain fields of the database will always contain the same value, e.g. 'eng'
for language 'English', you can put this in as a default value. It will then already be filled
when you use the worksheet, but you can alter the value when it does not apply.

Help: You may enter a 'Help' message for the field that will be displayed at the bottom
of the data entry window when the user is entering data in that field. It is often useful
to give an example, e.g.

Enter entry element with subfield ^a, and other elements of the author name with subfield
^b. e.g. ^aWalton^bC.J. for C.J. Walton.

Validation format: In order to avoid data entry mistakes CDS/ISIS provided
provision to formulate certain rules to check the format of the data entered, e.g.
the length must be a certain number of characters, or the field may only be present if
another field is absent. The rule is written using the formatting language provided
by CDS/ISIS for display and printing of records. An example that might be
used in the specification for field 110 is shown below:

if p(v100) and p(v110) then 'You cannot have two main entries' fi

The if expression p(v100) tests for field 100 being present and field 110 being
present. It will cause a message box to appear after the user tries to enter data in field
110 if there is already field 100 present. Data entry cannot proceed until the data are
removed from field 110. Another easy kind of validation is to test that the contents of a
field are the right length,

e.g. if size(v8) > 40 then 'Field 8 is too long' fi
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However, if you make a mistake in writing a validation rule it may be
impossible ever to satisfy it and you will never be able to get beyond this field in
data entry. It is therefore not recommended for beginners.

Pick-list definition. A pick-list enables the user to display a list giving a choice of
values for a particular field during data entry. In the pick-list definition box you enter
choice followed by two colons and a format that will produce the list. The first line
produced by the format will appear as the title of the list box during data entry. For
example:

choice::'Languages'/'English'/'French'/'German'/'Spanish'

The values here are all unconditional literals. ‘Languages’ will be taken as the
title of the list box and ‘English’, ‘French’, ‘German’, and ‘Spanish’ will be the
choices displayed as shown in the following Figure.

Figure 5 Example of a pick-list

The first box below the title is to allow the person doing data entry to search for a
desired value: he/she can enter the term or the beginning of the term and click the button
with the magnifying glass.

OK. Click the OK button to go back to the Worksheet definition screen.

If you have entered any Data Entry Fields by mistake, you can remove them using the
button with the left-pointing arrow. You can alter the order of fields on the worksheet by
selecting the field to be moved and clicking the ↑or ↓ button. A validation rule applying to 
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the record, rather than an individual field, can be entered by clicking the Record Validation
button. For example in Format you could have:

if a(v200) then 'Record must contain a title.' fi

This will generate an error message if the user has entered a record without any data in
field 200 and then tries to save it. Again caution is advised: a badly written rule may mean that
you can never save the record. When you have set up the worksheet, click the button with the
green arrow pointing right.

5.4 DEFAULT DISPLAY FORMAT

The display format means the way that the records will appear when you use
browse the database or display search results. Display formats can also be used in
producing printed output. There must be at least one display format for the database and
that must have the same filename as the database. You can always create more formats,
or modify existing ones, later.

A message box appears asking “Do you want Winisis to launch the Print Format
Assistant?” and you can choose Yes or No. If you are new to CDS/ISIS, or if you just want
temporary format to save time, click Yes. You are then given the choice of five pre-defined
formats. The order of fields will be the same as in the Field Definition Table.

Normal style. This uses font 2 (normally Times Roman) and colour 4 (normally
blue) and gives a display with the field names in one column and the data in the
next.

CDS/ISIS DOS compatible format. This is similar to the Normal style but it uses only
black text and Courier font.
Decorated format. Three fonts and various colours feature in the format. The record
number(MFN) and the name of the database appear in a box and the field names appear
in italics.

HTML normal. This is a format using very basic HTML (HyperText Markup
Language), the language used to create pages for the World Wide Web. No HTML
tags are included to separate the contents of one record from the next.

HTML table with headers. This again incorporates HTML tags and displays field
names and their contents in the form of a table.

Once the format has been created, it will be displayed in case you wish to edit it.
The next lesson gives you the detailed description of the formatting language.
However, following is minimum basic things to create display format:

(a) Fields are specified by using v (for variable) in front of the tag: thus v100
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means display the contents of field 100.

(b) Text between single or double inverted commas forms a literal and will appear
in the display just as it is written.

(c) The slash (/) means start a new line here.

A simple format for a database containing fields 100, 200 and 300 could be:

v100/v200/v300

This would display field 100, field 200, by field 300 in consecutive lines. e.g.

9785643214789
Good Governance
Ramana, O.V.

To display the fields on the same line, they should be separated by comas. e.g.

v100,v200,v300

This would display the above example as:

9785643214789GoodGovernanceRamana, O.V.
When you have finished writing the display format, click the green arrow to proceed

further.

5.5 FIELD SELECTION TABLE (FST)

CDS/ISIS has two ways of finding information in the database. One method is free
text searching which is a 'serial' or 'sequential' search, and the second method is to make use
of the index or inverted file. The first method is likely to be a slow process when the
database contains more than a few hundred records. The second method, using an index, is
the normal way of searching. CDS/ISIS allows you to set up the index automatically and
refers to it as the index or inverted file. (The list of terms in the index without the details of
their occurrences is also referred to as the terms dictionary.)

The selection of terms from the database records to go on to the index file is controlled
by the Field Selection Table (FST). The selection of fields depends upon three rules:

i. Which fields from the record are to be indexed (e.g. you want authors indexed
but not the publisher or the number of pages).

ii. How the index terms are to be constructed from the data in the selected fields
(called the indexing technique). For example, do you want the title 'Harvesting of
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Rice in India' as a whole field under 'H', or do you want it split up into separate words
so that 'Rice' can be searched under 'R' and India can be searched under ‘I’?

iii. You can also specify a list of stop words which are not to be used on their own as
index terms, e.g. 'in', 'of' and 'the'.

CDS/ISIS allows much flexibility in specifying each of these three rules. It is important
to consider them carefully, since they determine what searches will be possible on the
database. If you index authors as separate words, then records of 'Shakespeare, William'
will appear under 'William' and under 'Shakespeare'. You cannot search him as 'Shakespeare,
William'. If you index titles as whole fields, then 'The Concise Oxford Dictionary of
Quotations' cannot be searched under 'Dictionary' or under 'Quotations'. It is, in fact, possible
in CDS/ISIS to index the same field in more than one way.

If you have divided the field into subfields, you can index different subfields by
different techniques (or some subfields but not others).

Each line of the Field Selection Table comprises three elements: the Tag or Name, the
Technique and the Format. You need to make an entry in the table for each field you want
to index (i.e. to make searchable) and if the same field is indexed in two ways you need two
entries for it.

Again if you are unsure about writing FSTs it would be a good idea to engage the
services of the Dictionary Assistant. This will give you a dialog box like the one in the
following Figure.

Figure 6 Dictionary Assistant dialog box
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All you need do is to choose which technique to apply and which fields to index. The
list box on the right shows the techniques available. The two most commonly used are 0 – by
line and 4 – by word.

0 means that the whole field contents will be indexed as a single term.

1 means index each subfield separately and so is relevant only if the field is
divided into subfields.

2 means index only words or phrases which have been entered between angle brackets,
e.g. <inflation rate>.This technique can be used to select particular terms from a lengthy
piece of text such as an abstract. Some CDS/ISIS users like to enter descriptors this way
and use technique 2 to index them.

3 is similar to 2 but indexes terms entered between slashes, e.g. /Business Women/

4 signify that each word in the field will be indexed separately (except stop words). If
the field is divided into subfields, you must specify mode mhlor mdlin the extraction
format.

Now click the check boxes against the fields you want to be indexed (i.e. searchable)
and finally click OK. The FST is then displayed and you can edit it if necessary. Using the
Dictionary Assistant, all the fields selected are indexed by the same technique: if you want
to apply different techniques to different fields, you will need to make changes here.

Each entry in the FST has three parts. In the top part of the dialog box the entry being
edited is shown in three separate boxes. In the Entries box each entry is shown on one line
with spaces between the three parts.

The first value will be same as the tag of the field from which the terms come. The
second value, the indexing technique, specifies how the index terms are to be extracted as
explained above. The third column, the format, shows the terms are to come from which
field in the record. As in the display format, fields are specified with v in front of their tags.

So, if the title field has a tag 200 and we want to index each individual word, the
entries would be:

Tag/Name: 200 Title Technique: 4 Format: v200

and if the author field is 300 and we want to index the author name as a whole:
Tag/Name: 300 Author Technique: 0 Format: v300

If we want to index only subfield a of field 100 we could specify
Tag/Name: 3 0 0 Author Technique: 0 Format: v300^a
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This dialog box works in a similar way to the one for the FDT. When you have
entered the data for each field, the focus will be on the Add button. Either click on the
button or press {Enter} to add the field to the table (displayed in the Entries box). If you
need to correct the details for any entry, just click on that entry in the Entries box and the
details will be copied into the boxes used for editing. If you need to remove an entry,
highlight it and click the Delete button. An example of an FST is shown below.

You need not be too concerned to get the Field Selection Table right first time. It is
best to try it out on a few sample records and look at the index terms produced. If they are
not what you want, edit the FST and then regenerate the inverted file.

Figure 7 Example of Field Selection Table (FST )

When you have completed your entries in the Field Selection Table, click the
Terminate button. You are then asked to confirm that you want the database to be
created. Click Yes. You are then invited to select a database to work on.

5.6 STOPWORD LIST

If you are indexing a field by separate words (indexing technique 4) you may want to
prevent common, non-informative words such as 'an' or 'the' from being indexed. This can be
achieved by setting up a stop word list for the database. Words on the stop word list will not
be indexed using indexing techniques 4 (though they may still appear as part of phrases
produced with other indexing techniques). Note that there can only be one stop word list for
a given database, not different lists for different fields. The stop word file needs to be set up
outside CDS/ISIS using a text editor or word processor. An example of stop word file is
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shown below.

----------------------------------------------------------------------------------------
A
AN AND
BY FOR
FRM IS
IT NOT
THE
WITH

It must have the same name as the database and the file extension stw (e.g. books.stw
for the database BOOKS). It must reside in the same folder as the FDT file for the database.
The file must contain one stop word on each line with no preceding s[aces, and the words
must be in capital letters.

Although you may be able to think of hundreds of words that are not useful as search
terms, it is usually not necessary to list more than the most common twenty or so.

6. EXERCISES:

1. Create database with field names Author, Title, Publisher, Year of publication.
2. Create database with fields Author, Title, Imprint, Collation, Subject descriptors, Call

number and Accession number. Give your name as database name. Make the author
field repeatable with subfields entry element and other elements. Make the Imprint and
Collation fields contain sub fields to accommodate AACR prescriptions of these fields.

7. REFERENCES:

1. Mini-Micro CDS/ISIS 2.3 Reference Manual & CDS/ISIS Pascal Manual / Division of
software development and applications. UNESCO. – New Delhi : NISSAT, DSIR,
1989
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Lesson 15

DATA ENTRY AND SEARCHING

15.0 Objective
The objective of this lesson is to explain creation of records, editing of records and about

data entry. This lesson also explains searching methods that can be employed in retrieving
information from CDS/ISIS database. By now you have learned from the previous lesson
about how to set up your database using CDS/ISIS package. It is best to put in say six records
and check that they can be searched and displayed as you would like before starting on full scale
data entry.

After studying this lesson you will be able to

- create records in the database
- edit records
- browse the database
- search the database with different techniques

Structure

1. Create a New Record
2. Editing Records
2.1 Overview of the Edit Function
2.2 Using the Keys

2.3 Adding Fields
2.4 Deleting Fields
2.5 Validation
2.6 Moving to another Field or Record

3. Editing a range of records
4. Deleting Records – Logically and Physically
5. Default Values
6. Browsing the Database
7. Updating Inverted File
8. Searching
8.1 Guided Search
8.2 Expert Search
8.3 Display search results
8.4 Browse Function
8.5 Display format
8.6 Marking Records
8.7 Dictionary display

9. Advanced Searching
9.1 Truncation
9.2 Logical operators
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9.3 Any Files
9.4 Proximity operators
9.5 Brackets
9.6 Field Identifier
9.7 Free-text searching
9.8 Saving searches

10. REFERENCES

1. CREATE A NEW RECORD

Switch on the computer and execute WINSIS, a window will appear. Choose
Database ⇒ Open and select the database you wish to open by double-clicking on its name
which you have given while creating the structure (e.g. BOOKS). To create new
record, click on the blank page icon. Empty fields will appear on the screen and the MFN box
will contain ???. Whatever you type goes into the top box and will be added to the contents of
that field when you press {Enter} or finish by clicking on the text of another field. When you
have completed a record and saved it, it will be allocated the next available MFN. The detailed
procedure to enter records into database is explained to you in the following sections as rules
for editing a record apply equally to entering data in new records.

2. EDITING RECORDS

2.1 OVERVIEW OF THE EDIT FUNCTION

Choose Database ⇒ Open and select the database you wish to open by double-
clicking on its name (e.g. BOOKS). The database will then open displaying the first record
in the database. Then choose Edit ⇒ Data entry and the data entry window will appear as in
Figure 1. The record displayed when the database is opened will be displayed in the data
entry window.

The display is divided into parts. The MFN is displayed towards the top left of the
screen. If you are in a database which already contains some records, select or type the
number and press {Enter}. The record with that number or the last record in the database if
the number is greater will be displayed. A data entry box is at the top in which is displayed
the text of the first field. Below is a list of the fields which exist in the record.

The first field will be highlighted. You may also see empty fields depending on the

setting of Show empty fields in data entry option on the Configure ⇒ System Settings⇒
Display dialog box. If empty fields are not visible, you can click on the magnifying glass icon
in the bottom right corner and those fields will be represented by empty boxes on the screen. If
the first field displayed on the screen is empty, the data entry box will be empty. Any text
typed into the box will be displayed against that field in the display below on pressing the
{Enter} key. The field below will then be highlighted and its data appear in the data entry box.
Alternatively you can click in a different field. The top box will display the highlighted field
and the cursor will be placed at the start of that box waiting for a key to be pressed.
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If you are not displaying empty fields you may add a field by clicking on the combo
box labeled Add field. Click on the field you wish to add to select it, or else start typing its
name. At the bottom of the window you will see a box which indicates the size of the field
being edited (e.g. 25 bytes) and a box which contains the help message for the field that was
supplied when the worksheet was created.

2.2 USING THE KEYS

You can use the {Delete} and {Insert} keys in the usual way. {Insert} will act as a
toggle between insert and overtype. {Home} will take you the start of the field and {End} to
the end of the field.

Figure 1 Data entry

You may cut and paste data in the usual Windows way. You can highlight a section by
dragging the mouse from the start to end of the section with the left mouse button
pressed.{Ctrl x} will cut that section and copy it to the clipboard, {Ctrl c} will copy it to the
clipboard. {Ctrl v} will insert the text at the point where the cursor is. Additionally CDS/ISIS
for Windows uses the function key {F2}. This will delete the field you are editing and
remove the field completely from the display. Pressing {Esc} key will revert to how the field
was before you began to edit the record.
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2.3 ADDING FIELDS

If you wish to add a new occurrence of a field which is already present in the record,
you may do so if the field is repeatable, by clicking on the button to the left of the field name.
A blank field will appear into which you may enter data as you wish.

If you need to enter several values in the same field, use this repeatable field option.
Alternatively, you can separate the repeats with % signs. If the field has not been defined as
repeatable in the Field Definition Table, you cannot add multiple occurrences in data entry.

When there are different worksheets, correct worksheet, note that any field which
contains data will be hidden if it is not present in the selected worksheet.

2.4 DELETING A FIELD

Click on the field and press {F2}.

2.5 VALIDATION

CDS/ISIS for Windows has a number of different validation procedures. When a
data base is created, in the Field definition table (FDT), each field is designated
repeatable or non-repeatable, type of data (alphabetic, numeric or alphanumeric) and
subfield codes if present in that field. CDS/ISIS strictly adheres to parameters defined in the
FDT. When the database was created the designer could indicate that certain fields were
mandatory. If these are not entered the record cannot be saved.

2.6 MOVING TO ANOTHER FIELD OR RECORD

When you have finished editing the field click on another field you wish to edit or
save the record and move to another. When you have finished editing all the fields you
wish, click on the icon of a floppy disk and the record will be saved. To move to another
record, edit the number in the MFN window and press {Enter}. If you have not saved the
previous record, you will get the message: Record was changed. Save? Click on the Yes
button and the record will be saved.

3. EDITING A RANGE OF RECORDS

You can edit a record or a range of records whether you have found the record(s) by
browsing a database or by doing a search. From the main menu bar, choose Edit ⇒ Data
entry and the data entry window will appear with the record you have on your main database
display screen. You can move onward in the database by clicking on the right-facing triangle
or backward by clicking on the left-pointing triangle. If you want to edit records 15-20, with
the database open but with Data Entry closed, type 15 in the box marked MFN. Choose
from the menu bar Edit ⇒ Data Entry and the record in the data entry window will be
record number 15. Make changes to that record, click on the floppy disk to save it. Then click
on the right-pointing triangle to move to the next record (or on the left-pointing to move
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backwards).

4. DELETING RECORDS – LOGICALLY AND PHYSICALLY

To delete a record from the database: retrieve the record as for editing. Then when you
are sure that the correct record is in the data entry window, select Options ⇒ Delete record.
It will then not appear during searching. However, the data remain in the record and you may
later undelete the record. Select from the data entry window: Options ⇒ Undelete record. If
you want to get rid of the record altogether, the only way is to Export the whole database and
then Import it again.

5. DEFAULT VALUES

Sometimes you need to create several records with same data in one or more fields,
e.g. you are cataloguing several books in a series with the same series title and imprint. To
save having to type these data in each time, it is possible to set some default values which
will be filled in already in the data entry window.

If you have a record which you would like to use as a model, select the record and
display it in the data entry worksheet. Then select Options ⇒ Define Default values
[Model] Modify the record and save it. That will now be the model. Any new record will
be based on the model. When you no longer wish to use the model, select Options ⇒ Clear
Default values [Model]

6. BROWSING THE DATABASE

You can see the records what they look like in your display format, i.e. the output
format rather than in the worksheet which is the input format. To do this, close Data entry.
Click on the right hand triangle button and you will see the record you have entered last.
The format in which the records are displayed will be the display format written into the
database definition. You can change the format when you see it in use.

Click on the Format drop-down menu and try each format. You will see the format
*ALL*. Click on that and the display will list all the fields in the record as entered. Other
formats will give different displays of the same record as per the description of the format.

7. UPDATING THE INVERTED FILE

To update the inverted file, choose Database ⇒ I/F Update. The Inverted file
maintenance screen is displayed. Select OK. The MFN of each record is listed while it is
being inverted. At the end of the process, click on the Completed button.

Whenever new records are added or the existing records are edited you have to update the
inverted file. Otherwise the changes you made in the database will not reflect in search.

However you have provision to set automatic updating of inverted file by choosing Configure
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⇒ System Settings ⇒ Options and clicking on Automatic .Inv. File Update.

8. SEARCHING

CDS/ISIS provides two methods of search. They are Expert search and Guided search.
To search the database, choose Search on the menu bar. You can then choose either Expert
Search or Guided Search. Guided Search gives you a search form with separate text boxes
in which you can enter search terms. Expert Search gives you a form with one large text area
in which you enter your search expression. The same basic principles of searching apply in
either case.

8.1 GUIDED SEARCH

The form for a Guided Search is shown in Figure 2 below.

Figure 2 Guided search form

You can enter up to four search elements. For each one, you can specify whether to
search in All Fields (i.e. all inverted fields, as specified in the Field Selection Table for the
database) or you can select a particular field from a drop-down list box.

You can also choose to combine a previous search (if you have done one) with your
new search elements. Finally, if you enter more than one search element, you can choose the
logical operator with which to combine the terms: AND, OR or NOT from a drop-down list
box. When you open the form, the operators are set by default to AND.

To search for, e.g. PLANT PHYSIOLOGY, type it in one of the search elements boxes.
Click the Execute button. The Search Number box will then show 1, the Number of Hits box
will show the number of records containing that term, and the Search Expression box will
show the term you entered.
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After doing a search you can display the record(s) you have found by clicking the
Display button.

8.2 EXPERT SEARCH

The form for an Expert Search is shown in Figure 3.

Figure 3 Expert search form

To search for e.g. PRIMARY EDUCATION, type it in the Search Expression box.
You can enter your search in upper- or lower-case letters or a mixture. Then click the
Execute button or press {Enter}.

The Search History box will show a message like:

#4 (BOOKS) T=2: primary education

This means that for search number 4 on the database BOOKS, there were two records
retrieved and the search was for PRIMARY EDUCATION. To display these records, double-
click on the relevant line in the Search History box. CDS/ISIS provided provision for
automatic display of search results by configuring the settings.

8.3 DISPLAYING SEARCH RESULTS

CDS/ISIS Windows version or WINISIS provides provision to configure
and select one of the following three display options.

(a) Default Search Display: With this setting, the Display button is not available in
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Expert Search and you need to double-click on the relevant entry in the Search History
display.

(b) Alternate Search Result Tool Bar: This is similar to the Default Search Display, but
at the top of each record a bar is displayed giving information on the search number, the
hit being displayed and total number of hits, and the option to Stop.

(c) Display Search Results in a Table: Clicking the Display button shows for each hit
its record number (MFN) and the first field (if present) defined for that database. To
see a fuller version of a record, click on it and it will be displayed in the right-hand
window.

The search term(s) will be highlighted where they occur in the records. The example in
Figure 4 shows one record retrieved by searching for PLANT in the CDS database. You can

turn highlighting off or on using the checkbox. You can also chose the colours used in

highlighting.

Figure .4 Highlighting of retrieved terms

8.4. BROWSE FUNCTION

Another way of looking at the results of a search is to choose Browse from the menu
bar and then Search Results. You will be presented with a list of the searches you have
done (Search History) and you can select the one you want.

8.5 DISPLAY FORMAT

The format in which the records are displayed will be the display format written into
the database definition. The default format, which is used if you do not specify otherwise, is
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the one with the same name as the database. It is possible to have more than one format for a
database. You can change to another format by choosing from the Format drop-down menu.

You will see a special format listed, which is not part of the database definition,
called *ALL*. This displays the records as they are stored on the system with each field
preceded by its numeric tag. It is useful for checking records and investigating problems. An
example of a record in the *ALL* format is shown in Figure 5.

Figure 5 Record displayed in the ALL format

8.6 MARKING RECORDS

When you are looking through the results of a search, you may decide that some
records are relevant to your need but others are not. You can mark the relevant ones by
clicking the Mark check box: a V appears in the box. Then in the Browse menu you can
choose Marked Record to browse through the marked records only and in the Print Setup
dialog box you can click the Marked Records Only check box.

8.7 DICTIONARY DISPLAY

The method of searching described above works by the computer looking for the term
in the inverted file of the database being searched. If it finds the term there, it gets the number
of hits: if not, it reports zero hits. Your search will only succeed if you enter the search term
exactly the way it is in the inverted file. You can then find the term as entered in the
inverted file by clicking the Dictionary button on the Expert Search form or one of the
Book icons on the Guided Search form. The display will start from the beginning of the file
(in the order of figures 0 - 9 then letters A - Z). You will then get a display of the form shown
in Figure 6.
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Figure 6 Dictionary display

If you now want to search for the records containing one or more of the terms
displayed, you can drag that term from the dictionary to the search expression box. Select the
term by clicking once on it. Hold down the left mouse button and move the mouse pointer
across to anywhere in the search expression box. Then release the mouse button. On the
Expert Search form, if you drag across a term when there are already terms in the Search
Expression box, the new term will be combined with the + (OR) operator. On the Guided
Search form, you need to drag each term to a separate box: the dragged term replaces any
term already there. The Searchable Field is not set automatically if you have selected a field
in the dictionary display.

9. Advanced Searching

9.1 TRUNCATION

The truncation facility allows you to look for a number of words or terms starting with
the same letters. For example, you might want to look for any item to do with agriculture: it
would be useful to search the terms AGRICULTURAL, AGRICULTURE,
AGRICULTURALIST, etc. This can be done using the truncation symbol which is a dollar
sign in CDS/ISIS. You would therefore enter the search as

AGRICULTUR$

9.2 LOGICAL OPERATORS

It is frequently necessary to combine two or more terms in a search, for example to find
items about ECONOMICS of TRANSPORT, or a book by GRAHAM on MATHEMATICS.
This can be done by using logical operators, of which there are three.

0. AND: This operator would be used in the examples just given. In the first case we want
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to find those items each of which has the index term ECONOMICS and TRANSPORT.
On the Guided Search form you would enter ECONOMICS in the first Search box,
leave the Operator next to it as AND and enter TRANSPORT in the second Search
Elements box. This is shown in Figure 7.

Figure 7 Guided search using the AND operator
On the Expert Search form you would enter ECONOMICS, click the AND button, then

enter TRANSPORT. This is shown in Figure 8. For simplicity, we will write the search in
this section as:

ECONOMICS AND TRANSPORT

You actually enter it in one of the two ways described. In the display of the Search
Expression the AND operator will appear as an asterisk, *.

Figure 8 Expert search using the AND operator

In the second example, the record should contain the author GRAHAM and the subject
term MATHEMATICS, so you should enter:



Acharya Nagarjuna University 15.12 Centre for Distance Education

GRAHAM AND MATHEMATICS

In general terms, we could say that the AND operator narrows the search. Looking for
ECONOMICS AND TRANSPORT is more specific than looking just for ECONOMICS.

1. OR: This operator is useful for linking together several synonyms or related terms each
relevant to the concept you are looking for. If you were trying to find everything about
education in your database you might enter the search as:

EDUCATION OR SCHOOLS OR UNIVERSITIES OR TEACHING

This means that each item retrieved must contain the term EDUCATION or
SCHOOLS or UNIVERSITIES or TEACHING.

The effect of the OR operator is to broaden the search: you expect to find more items
if you look for EDUCATION or SCHOOLS or UNIVERSITIES or TEACHING than if
you look just for EDUCATION. In the display of the Search Expression the OR operator
appears as a plus sign, +.

2. NOT: Sometimes you might want to exclude records with a certain term from your
search. For instance, you might want to find all items in your database about
STRUCTURAL ADJUSTMENT but which do not come from your own institute. In
this case you would use the NOT operator, e.g.

STRUCTURAL ADJUSTMENT NOT INSTITUTE OF DEVELOPMENT
STUDIES

In the display of the Search Expression, the NOT operator appears as a circumflex, ^.

9.3 ANY FILES

You may find that there is a group of search terms which you often use together linked
by OR. For example, if your information centre is responsible for East Africa, you might
often need to search for

SOMALIA OR ETHIOPIA OR KENYA OR UGANDA OR TANZANIA

To save having to spell out the countries each time, you could set up an ANY file. Then
in Expert Search you would only need to click the ANY button and select ANY EAST
AFRICA from the list, or in Guided Search you would just type ANY EAST AFRICA.

The ANY file has to be created outside CDS/ISIS using a text editor or word
processor. It needs to be held in the same folder as the database to which it refers, and to
have the name of the database with the extension .any. For example, if you have a database
called BOOKS, the corresponding ANY file should be named books.any and this file
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should be in the same folder as books.mst.

The format of the ANY file is as shown below:

AN EAS AFRICA SOMALIA
ETHIOPIAAN EAS AFRICA

AN EAS AFRICA KENYA
AN EAS AFRICA UGANDA
AN
Y

EAS
T

AFRICA TANZANIA

The individual terms (SOMALIA, ETHIOPIA, etc.) must be one on each line, and
they must start at position 31 on that line.

9.4 PROXIMITY OPERATORS

Suppose that you have inverted the title field with indexing technique 4, i.e. as
keywords. If you then want to search for titles containing 'New York', you might search for:

NEW AND YORK

This would find titles containing both the word NEW and YORK, but the words might
not be adjacent. For example, there might be a title 'New buildings in York'. In fact the
words might not even have come from the same field: there might be an author 'New' and a
place of publication 'York'. To avoid such a situation you could specify that the words must
occur next to each other in the field by using the adjacency operator, which is a full stop:

NEW . YORK

9.5 BRACKETS

The logic in search statements can sometimes get confused. You might want to look for
any items about 'lions or tigers in Kenya or Uganda'. It would be tempting to enter the search
as

LIONS OR TIGERS AND KENYA OR UGANDA

The results will not be as you expected since the AND operator is processed before the
OR operator by the computer. The best way to avoid this kind of confusion is probably to do
the search in small stages:

1. LIONS OR TIGERS
2. KENYA OR UGANDA
3. #1 AND #2

However, you can use brackets to show what is to be combined first:
(LIONS OR TIGERS) AND (KENYA OR UGANDA)
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9.6 FIELD IDENTIFIER

If you wish, you can specify that a search term should only be retrieved if it occurs in a
particular field. On the Guided Search form, you can specify one of the Searchable Fields for
each Search Element by clicking on the arrow to the left of the Element box. ("Searchable
fields" are those included in the Field Selection Table.) This opens a drop-down list of
searchable fields and you can select the one you want. Figure 9 shows a search for NEW as
an author. Note that if you drag a term from the Dictionary, the field that the term occurs in is
not automatically entered in the Searchable Fields box.

On the Expert Search form, you can specify the field using a slash and brackets. For
example, if the author field is 100: NEW/ (100)

Figure 9 Choosing the field in Guided Search

If you drag a term from the Dictionary after selecting a searchable field, it is
automatically copied with its field identifier.

9.7 FREE-TEXT SEARCHING

This facility is available in Expert Search only. The normal method of searching in
CDS/ISIS is through inverted file. So the database can be searchable through the fields which
you have selected in Field Select Table (FST). However, there is another method of searching
which does not depend on the inverted file. Rather, it depends on scanning through the records
in the whole database (or a subset of the database) one-by-one looking for a word or term that
you specify. This is a much slower process. The advantage is that you can look for any term
anywhere in the record, whether the field is indexed or not and whether the word is a stop word
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or not. This kind of searching is often known as serial searching, because the records are
searched serially. CDS/ISIS calls it free-text searching. It is specified by using a question mark
at the beginning of the search and using the same formatting language as provided by CDS/ISIS.
The colon (:) is used to mean 'contains'. Thus we could enter:

? v260 : 'McGraw-Hill’
This would look for those records where field 260 contains the word (or literal)

'McGraw-Hill'. To search the whole text of the record, use v0, e.g.
? v0 : 'Shakespeare'

Figure 10 Free-text searching – progress message

After you enter a free-text search, you will see a display of the kind shown in Figure
10. You will see the MFN advancing as the search proceeds through the database and if any
records match your search statement they will be added to the figure for 'Hits'. The '%'
number shows what percentage of the records scanned so far match your search statement.
When the search is complete, you can click the Completed button and display the records
found just as with direct searching.

9.8 SAVING SEARCHES

If you have a search that you may need to repeat in the future, you can use the Save
search facility. Carry out the search using the Guided or Expert Search form. If you used
Guided Search, close the search form. Then choose Search ⇒ Save Search. The search
history is displayed: click on the search you want to save. Then choose a folder and filename
for the saved search. To rerun the saved search in the future, choose Search ⇒ Recall Saved
Search. Select the filename and click OK. The search will run and the results will be
displayed. The search will appear in Search History and can be combined with other terms if
required.

10. REFERENCES:

1. Mini-Micro CDS/ISIS 2.3 Reference Manual & CDS/ISIS Pascal Manual /
Division of software development and applications. UNESCO. – New Delhi : NISSAT, DSIR,
1989
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Lesson 16

THE FORMATTING LANGUAGE, SORTING AND
PRINTING OF RECORDS

16.0 Objective

The objective of this lesson is to explain the formatting language of the CDS/ISIS which is
useful to display and print the records. The formatting language also helps in creating inverted file
which is useful in searching the database. This lesson also describes the sorting and printing
methods given in CDS/ISIS package

After studying this lesson you will be able to

- learn formatting language of CDS/ISIS
- learn sorting of records
- printing of records

Structure

1.INTRODUCTION
2.FIELD, SUBFIELD AND OCCURRENCE SELECTORS
3.MODES
4.LAYOUT
5.LITERALS
6.REPEATABLE GROUPS
7.S P E C I A L FEATURES
8.PRINTING

8.1 PRINTING USING THE CLIPBOARD
8.2 PRINTING AND SORTING FACILITIES – PRELIMINARIES
8.3 GENERAL
8.4 PRESENTATION

8.5 MARGINS

8.6 LAYOUT
9. SORTING

9.1 SAVING YOUR PRINT SPECIFICATION
10. REFERENCES

1. Introduction

Once database is created and data entered, you may need to display and print the records
or part of the record. For this CDS/ISIS provided powerful formatting language. A good
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understanding of this formatting language enables you not only to print or display the records
but also to enter terms from the record on to the index file and to select parts of the record for
sorting or exporting to another database. It also helps in writing validation rules and pick-lists
for data entry forms.This lesson is written from the point of view explaining the printing
and displaying operations. However, the same formatting language is used in the other three
cases.

For the purposes of example, the following record will be used:

300 ^aTanenbaum^bV.S.
200 ^aComputer Networks

Upper or lower case letters can be used in the formatting language

e.g.mhu v300or MHU v300or MhU V300etc.
Carriage returns can be used within a display format to make it easier to read, but they

have no effect on the display itself.

2 . FIELD, SUBFIELD AND OCCURRENCE SELECTORS

As we have seen, the contents of a field are selected by using vand the field tag, e.g.
v300. (v stands for 'variable'.). This will select all the subfields present, if the field is divided
into subfields. To select the subfield ‘a’ of field 300, use the circumflex and the subfield tag,
e.g. v300^a. If you want to select several subfields from the same field, you need to repeat
the field number, e.g. v300^a, v300^b

If you want to select a particular occurrence of a repeating field, specify it in square
brackets, e.g. v300[1]will select the first occurrence of field 300.

To select the number of the record in the database (called the Master File Number) use
MFN(6). This will give a number with six digits, e.g. 000045. To make it shorter, specify the
number of digits in brackets, e.g. MFN(3)will produce 045.

3 . MODES

There are three modes available.
proof - data will be displayed exactly as entered in the record, i.e.

^aTanenbaum^bV,S.
^aComputer Networks

heading - angle brackets in the data are ignored. Subfield markers are converted to
punctuation: ^a is converted to a semicolon and space (unless it comes at the beginning
of a field). ^bto ^i are converted to a comma and space all others are converted to a full



Comprehensive & Viva… 16.3 The Formatting Language, Sorting..

stop and space. So, the example will come out as

Tanenbaum, V.S.
Computer Networks

data - It is just like heading mode, but each field will be followed by a full stop and
two spaces. This provides a simple way of separating the occurrences of a repeating
field. The example will thus appear as

Tanenbaum, V.S.
Computer Networks

Each of these modes can be specified as 'upper case' or 'lower case'. If you choose
upper case, all letters will be converted to capitals, e.g. SHAKESPEARE, WILLIAM

If you choose lower case, all letters will be left as they are (not all converted to small
letters) e.g. Shakespeare, William

The mode is specified by m; followed by p for proof, h for heading or d for data; and
followed by u for upper case or l for lower case. Thus you could specify:

mhl v300

The mode specification applies throughout a format until another mode is specified.
Thus in the format mhu v100, v200, v300, mhl v400 fields v100, v200 and v300 will be
converted to upper case and field 400 will be left as it is. There is no necessity to specify a
mode. If you do not specify the mode, the 'default' mode of mpl will be used. If you are
specifying data to go into an inverted file (i.e. you are writing the Field Selection Table) all
letters are converted into upper case anyway.

4. LAYOUT
A common requirement is to indent one or more fields when printing a record,

e.g. SHAKESPERE, William
Hamlet

This can be done by specifying the number of spaces to indent in brackets after the tag,
e.g. v300/v200(5). This will display

SHAKESPERE, William
Hamlet

If the field is long, you may want to indent subsequent lines by the same amount,
or by different amounts, you can specify two numbers in the brackets - one for the first
line and one for all subsequent lines, e.g. v10/v20(5,10)

Indenting applies only if the field is the first item to be printed on that line. To start a
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new line within a display format, use a slash. For example, v300/v200will produce:
SHAKESPERE, William
Hamlet

However, slashes will never produce a blank line, even if you use two or more. To
produce a blank line (e.g. between records in a printout) you should use hash marks. One
hash will go on to the next line, and two will produce one blank line. So the format
v300##v200will result in

SHAKESPERE, William

Hamlet

5. LITERALS
When you write v300within a format, you do not want 'v300' to appear literally in the

printout, but rather the contents of field 300, e.g. ' SHAKESPERE, William'. However, you
may want to specify some text or punctuation that you do want to appear literally, e.g. Author:
in front of the author's name. This text is known as a literal.

Three types of literal can be used in CDS/ISIS:

(i) Unconditional literals. These are specified by putting the text in single
quote marks, e.g.'Author: 'v300/'Title: 'v200.This will produce the display:

Author: SHAKESPERE, William
Title: Hamlet

Because this type of literal is unconditional it will appear even if
there are no data in the field, e.g. no author's name in field 300:

Author:
Title: The Tempest

Note that literals can be used to supply spaces and punctuation. If we wanted a
space, hyphen and space between author and title we could write v300 ' - ' v200
which would give

SHAKESPERE, William - Hamlet
However, the space, hyphen and space will appear even if there is no author or

title.

(ii) Conditional literals. These are displayed only if their associated field is
actually present. They are written between double quote marks. Thus "Author:
"v300/"Title: " v200will produce for the first example:

Author: SHAKESPERE, William
Title: Hamlet
and for the second:
Title: The Tempest
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You may need to use a comma to show whether a conditional literal is
conditional on the field before it or the field after it. For example, in V300 " - "
v200 is the punctuation conditional on field 300 or field 200 being present? A
comma will remove the ambiguity, e.g. v10 " - ",v20shows that it is conditional on
field 300.

(iii) Repeatable literals. If you have a repeated field (e.g. several authors) you
can choose whether the literal should appear with each of them, e.g.

Author: Shakespeare, William
Author: Maxwell, Simon
Author: Joekes, Susan

or just once, e.g.

Author: Shakespeare, William
Maxwell, Simon
Joekes, Susan

A repeatable literal is written between vertical bars.

For example: |Author: |v300

A common requirement with repeating fields is to print some punctuation after
each occurrence except the last one, e.g.

Shakespeare, William; Maxwell, Simon; Joekes, Susan

Here, a semicolon is printed after each name but not after the last name. This can be
achieved using a plus sign, e.g. v300+|; |

6 . REPEATABLE GROUPS
Another common requirement with repeated fields is to display the repeats one on

each line, e.g.

Shakespeare, William
Maxwell, Simon
Joekes, Susan

If you write the format as v300/, the three names will be run together and there will
only be a new line at the end:

Shakespeare, WilliamMaxwell, SimonJoekes, Susan

The same problem occurs if you try to invert a repeated field, or to sort on a repeated
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field: only one index term or sort key is produced. It can be solved by using brackets to
form a repeatable group, e.g. (v300/). V300and the slash (new line) now form a group.
Every time v300 repeats the new line repeats too. So the result will be:

Shakespeare, William
Maxwell, Simon
Joekes, Susan

7. SPECIAL FEATURES
In CDS/ISIS for Windows, provides Font table and Colours table so as to

make it possible to control the appearance of the display or printout quite precisely. You
can specify font size, character style (bold, italic or underline) and format the paragraphs
using rules and codes provided. It is possible in the formatting language to display a picture
as part of the format or as the background to the record display. The picture should be in
the form of a .bmp or .jpg file and be stored in the folder specified for Patterns/Images.
CDS/ISISIS windows version also provided rules to write commands (IF THEN) for dealing
complicated conditions of display and to link different records (REF and L functions) within
and from different databases. In the Windows version of CDS/ISIS it is possible to display
a record containing a hypertext link.

8. P R I N T I N G
There are two main ways in which you can print records from a CDS/ISIS database.

One is to display a record on the screen and copy it onto the Clipboard and then into an
application that allows printing, e.g. Word for Windows. You can copy several records, but
one at a time.

If you have more than a few records to print, you can make use of the sophisticated
printing and sorting facilities of CDS/ISIS for Windows. To do this, choose Database ⇒
Print, or click on the Printer icon on the toolbar. The Print Setup Window is shown in
Figure 1. There are five dialog boxes provided for specifying your printing requirements:
the second to fifth boxes (Presentation, Margins, Layout and Sorting) are accessed by
clicking on their tabs. It is possible to send the output either to your default printer or to a file
in Postscript format for printing on an appropriate printer.
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Figure 1 Print Setup Window

8.1 PRINTING USING THE CLIPBOARD
The Clipboard provides temporary storage for data you want to transfer. You can cut or

copy data from a record displayed on the screen onto the Clipboard and then transfer those
data into another application. Data put onto the Clipboard remain there until you clear the
Clipboard or quit Windows. The Clipboard in CDS/ISIS operates in two modes. You can
switch the Clipboard mode by clicking on one of the two buttons [TXT] and [RTF] on the
Toolbar. The default mode is Text Mode. The second mode is Rich Text Format (RTF) mode.

8.2 PRINTING AND SORTING FACILITIES - PRELIMINARIES
If you wish to use the printing and sorting facilities, there are a couple of things worth

thinking about before opening the Print Setup dialog.

1. Although you can write a print format in the General dialog box, it is easy to use the
display format that you set up in the database definition, which will have the same name as
the database. An example is shown in Figure 2.

----------------------------------------------------------------------------------------------------

Record format

Field 300 : author
Field 200 : title
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(a) Display format
v300^av300^b/v200

Arora, R.P. Plant
Diseases
Chalam, G.V.
A history of the Telugu speaking peoples
Clarendon, Earl of
History of the Germany

(b) Display format v10/v20###

Arora, R.P. Plant
Diseases

Chalam, G.V.
A history of the Telugu speaking peoples

Clarendon, Earl of
History of the Germany

--------------------------------------------------------------------------------------------------

Figure 2 Formatting for line spaces between records

2. You need to have decided which records from the database you want to print.

You can open the Print Setup window by clicking the Printer button on the toolbar or
by choosing Database ⇒ Print. There are then dialog boxes which can be opened by means
of their tabs.

8.3 GENERAL

The first dialog box to complete is called "General". This allows you to say what and
where to print and to define the print format. It is shown in Figure 8.1. You need to select the
records to print either as the results of a search or by Master File Numbers (MFNs). This is
done by clicking on one of the option buttons Current Browse Set or MFN Range. Current
Browse Set means the set of records retrieved in your last search. In this case, you can also
click on the check box Marked records only if you have marked some records. If you
choose MFN Range, you should enter your selection of MFNs in the text box. Some possible
formats for this are:

17 Print record number 17
-5 Print records up to number 5
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60- Print from record 60 onwards
19-30 Print records 19-30
-5,17,19-30,60-Print this combination of ranges

You could print the whole database by choosing an appropriate range of MFNs. Next
you can specify where the output from the printing should go by means of the Output to
combo box. It should be showing the printer configured as your default printer. The button
with the Printer icon next to this combo box allows you to change your printer settings if
necessary. Alternatively you can send the results to a file in Windows-ASCII, or Postscript
format. This has the advantage that you can check the output file on the screen before sending
it to paper. You could then use a word processor to paginate the text and do other editing if
necessary.

The print format can either be one which you have defined and named already or one
which you now write in the large text area. When you are using a predefined format, the
Predefined Format checkbox is crossed. There are also some command buttons down the
right-hand side of the dialog box. Recall allows you to call up a previously saved print
worksheet. Save allows you to save your worksheet so that you can produce similar prints in
the future without having to repeat all your work. Preview lets you see what the first page
will look like before printing.

8.4 PRESENTATION

This dialog box allows you to add titles, headers and footers to your print. It is illustrated
in Figure 3. At the top of the dialog box there is a combo box allowing you to edit these
objects:

First title
Second title Third
title Header
Footer
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Figure 3 Presentation dialog box

"First", "second" and "third titles" are three pieces of text which you can have printed
on your printout. Each one can come on a separate page at the beginning (as a "cover"), at the
top of the first page of records, or at the top of every page of records. The header comes at
the top of every page and the footer comes at the bottom of every page. For each "title" you
would like on your printout, you select it from the first box, then click the boxes for "Use as
a cover" and "Keep title on all pages" if you wish. The remaining boxes apply also to headers
and footers. The text for the object you type into the large area. You can pick alignment of
the text to the left, to the right, or have it centred by clicking on the appropriate button. You
can choose to have the text in italic, bold, underlined or combinations of these. The font and
font size can
be selected from the two boxes on the right.

As an example, the following three titles might be set up:

First title: INSTITUTE OF DEVELOPMENT STUDIES

[ ] Use as a cover [X] Keep title on all
pages

Second title: Accessions list

[X] Use as a cover [ ] Keep title on all
pages
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Third title: July 2001

[ ] Use as a cover
[ ] Keep title on all

The first page of the printout (the cover) will be printed only as:

Accessions list
The second page will have the heading:

INSTITUTE OF DEVELOPMENT STUDIES July 2001

followed by the records being printed,
and the third page will have the heading:

INSTITUTE OF DEVELOPMENT STUDIES

8.5 MARGINS
Here you define what area of the page you want to print on. The dialog box is

illustrated in Figure 4.

Figure 4 Margins dialog box

You can define the size of the margin at the top of the page, the bottom of the page, the
left hand side (Inside) and the right hand side (Outside). If you are intending to bind your
printout down the left hand side, you can specify extra space to be added to the inside
margin (Gutter).

The Measurement Unit can be selected from a combo box as Millimetres, Centimetres,
Inches or Twips. The Paper Size can be set to A4, Letter, Legal or User Defined. In the last
case you then set the height and width of the paper in the boxes next to the diagram.There are
three further boxes in the "Special" frame. Data Indention is most useful for indenting
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records with respect to headings when you are producing sorted listings.

EOC (i.e. End Of Column) tolerance. If a record will not fit the space available at
the bottom of a page, CDS/ISIS will print part of it on that page and the rest of the record
on the next page (or column). The End of Column Tolerance means how many lines space
must be left at the bottom of the page for CDS/ISIS to start printing a record. If you set it to
3, a record might be split as shown below.

World Conservation Strategy. International Union
for the Conservation of Nature and Natural Resources, in
co-operation with the United Nations Environment

---------------------------------------------------------

Programme and the World Wildlife Fund. IUCN: Gland,
Switzerland, 1980.

Figure 5 A record split between pages

Finally you can set Record height is fixed and the measurement. This makes it
possible to specify the height of the record when printed. If the text does not fill it some
blank space will be added: if the record is too long it will be truncated.

8.6 LAYOUT
In this dialog box you can specify more about the page layout and the number of

columns. It is illustrated in Figure 6. Firstly there is a frame to do with columns. There is a
spin box for the number of columns across the printed page (set by default to one) and one
for the space between the columns, using the current unit of measurement (set by default
to10). Then there are three radio buttons for choosing no decoration, a line between the
columns, or a border round each column, respectively. Next you can choose whether there
should be a maximum number of records per page or column and if so what that number
should be. This could be useful in printing labels or cards.
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Figure 6 Print setup – Layout dialog box

Below that, the frame allows you to ask for page numbers and say where they should
appear. There is a check box to request that page numbers are printed and a separate one for a
page number on the first page of printout. Then you can choose from a combo box whether
the number comes at the top or bottom of the page, and from the next box whether the
number appears on the left, centre or right of each page. Alternatively, you can ask for the
numbers to be placed on the inside or outside of each pair of pages. You can pick the first
page number to be used by means of a spin box, e.g. if there was a 10 page introduction to
your listing you could start it at page 11. At the top right of the page, there is a spin box for
applying a "zoom" factor. By default it is set to 100% but you can vary it between 50 and
120%. It allows you to fit more or fewer records on a page by varying the font size, but with
no changes to your print format.

Then there is a group of three check boxes. The first two are for Don't use titles and
Don't use sorting. If you are using a format which you have set up and saved on a previous
occasion, but on this occasion you don't want to include the titles or you don't want to have
the records sorted, you can "turn off" these features by means of the check boxes. (If you do
not use sorting, the records will be printed in order of ascending MFN, i.e. the order that they
are on the database.) The third one Just make HIT file provides a way of sorting the
database into a different order.

There are also command buttons on this page to Preview the printout, start Printing,
Cancel, or ask for Help.

9. SORTING
Sorting dialog box provided by WINISIS is illustrated in Figure 7.
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Figure 7 Print setup – Sorting dialog box

a. N[umber] of headings. This actually means the number of levels of heading
to be used. The maximum heading levels is four. The number will usually be one
less than the number of sort keys. If the first field in the description is the one you are
sorting on, you will want no headings at all.

b. Stopword file. The name of the stop word file should be entered here.

c. Heading format. You can provide your own format for printing the headings,
using the formatting language or you can let CDS/ISIS construct the heading
format itself.

d. Sort key parameters. Up to four sort keys may be specified. If two records
have the same primary sort key, they will then be sorted by secondary sort key and
so on. For each sort key, you must give three pieces of information:

i. Key length. This defines how many characters are taken from the
specified field to form the sort key.

ii. Heading processing indicator. There are four combinations numbered
0 to 3. Depending upon the purpose proper indicator is to be selected.

0. Headings don't repeat. Records don't repeat.
1. Headings don't repeat. Records repeat.
2. Headings repeat. Records don't repeat.
3. Headings repeat. Records repeat.

iii. A Field Selection Table. This is written in the same way as the Field
Selection Table for inversion. For sorting to take place the box next to “FST”



Comprehensive & Viva… 16.15 The Formatting Language, Sorting..

must be checked. The check box provides a temporary way of “turning off”
one or more FSTs. Instead of writing out the FST, you may use an FST which
you have already prepared in Database Definition Services. You enter here its
name preceded by an at sign, e.g. @SORT.

You can now click the Print button to put your specification to the test.

9.1 SAVING YOUR PRINT SPECIFICATION

You may want to produce similar printouts at regular intervals, e.g. a printed catalogue
every quarter, or a list of new accessions every month. You may therefore find it useful to
enter the values once, test them, and then save your specification. Click the Save button on
the General page to save a specification. You are asked to give it a file name and choose a
folder: the name is given an extension .wpr. Next time you want to print with this
specification, go into Print Setup, click Recall and select the .wpr file.

10. REFERENCESs

1. Mini-Micro CDS/ISIS 2.3 Reference Manual & CDS/ISIS Pascal Manual /
Division of software development and applications. UNESCO. – New Delhi :
NISSAT, DSIR, 1989
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Lesson 17

EXPORTING, IMPORTING, BACKING UP AND
MODIFICATION OF DATABASE

17.0 OBJECTIVE
The main objective of this lesson is to explain how to exchange the database with the help

of Export and Import features available in CDS/ISIS package. This lesson also explains how to
take backup and restore the database. Sometimes you will probably wish to make some
modifications to the original definition. CDS/ISIS allows modification of database any number
of times.

After studying this lesson you will be able to

- Export database
- Import database
- Backup the database
- Restore the database
- Modify the database

Structure
1. Introduction
2. ISO 2709 Structure
3. Export into ISO 2709 Format
4. Import a n ISO 2709 File
5. Backing Up and Restoring a Database
6. Modification Of Database

6.1 Modifying the Field Definition Table

6.2 Modifying the Worksheet or Creating a New one

6.3 Modifying the Field Selection Table
6.4 Modifying or Adding Print Formats

7. Modifying the Data
7.1 Global Add (Range)
7.2 Global Delete (Range)
7.3 Global Replace

7.4 Global Add (Search)
7.5 Global Delete (Search)
7.6 Modification by Exporting and Importing

8. Conclusion
9. References

1. INTRODUCTION
Library is a growing organism as stated by 5th Law of library science by S.R.Ranganathan.

Consequently library catalogue also grows continuously. The library bibliographic database
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(Catalogue) also grows continuously. So as a precautionary measure the database is to be
backed up periodically to save the database. Hence CDS/ISIS provided Backup and Restore
facility to avoid exigencies arises by computer breakdown, hard disc crash etc. Library
catalogue controls the documents of the library. In order to meet the universal availability of
publications one has to achieve regional bibliographic control and universal bibliographic
control. To achieve bibliographic control regional and union bibliographic databases are to be
created by pooling database from different libraries. For example ‘Indcat’ is a union catalogue
database of documents available in Indian universities. There are different library software
packages that are being used for creation of bibliographic database in libraries. Hence Export
and Import features are must for any library software to facilitate exchange of data between
libraries and to pool data at regional, National and International level. The export and Import
feature of the software converts the data into common communication standard structure and
facilitate exchange of data.ISO 2709 is one such common record structure to facilitate exchange
of data.

After you have been using your database for some time, you will probably wish to
make some modifications to the original definition. For example, there may be fields in the
definition that you have never used, or you might realize that you missed out some data
elements. You might want to be able to search on elements which have not been indexed or
you might find that elements are not being indexed in the way you had intended. You may
want an additional worksheet for a particular task. You might want to alter the print
format, or you might want several print formats for different purposes.

2. ISO 2709 STRUCTURE
The export function of CDS/ISIS allows you to copy some or all of the records in a

database into another portable file. The import facility allows you to bring data from elsewhere
into your own database. During exporting or importing you can use a Field Selection Table

(a) to limit the parts of the record you allow to be transferred
(b) to move data from one field to another on transfer.

So another use of these functions is to reformat the database by exporting and then re-
importing the same records. The record structure which is used for exporting and importing is
known as ISO 2709 because it follows the International Organization for Standardization's
standard 2709.

A file of two records in ISO 2709 format is shown in Figure 1.

---------------------------------------------------------------------------------------------------------

00433000000000121000450004400780000005000120007806900790009002400690016902600
230023
8030002100261070001600282070001300298~Methodology of plant eco-physiology:
proceedings of the Montpellier Symposium~Incl. bibl.~Paper on: <plant physiology><plant
transpiration><measurement and instruments>~Techniques for the measurement of
transpiration of individual plants~^aParis^bUnesco^c~1965~^ap.211-
224^billus.~Magalhaes, A.C.~Franco,
C.M.~#003760000000001090004500044007800000050001200078069003700090024010000
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12702600
0700227030002100234070001100255~Methodology of plant eco-physiology: proceedings of
the Montpellier Symposium~Incl. bibl.~Paper on: <plant evapotranspiration>~<The>
Controlled climate in the plant chamber and its influence upon assimilation and
transpiration~^c1965~^ap. 225-232^billus.~Bosian, G.~#

----------------------------------------------------------------------------------------------------------
Figure 1 A file in ISO 2709 format

(Here ~ has been used as field separator and # as record separator)

3 . EXPORT INTO ISO 2709 FORMAT

Open the database from which you are going to export. Use the Open File icon, or
choose Database ⇒ Open, then the database you want to use. The exporting function is
reached by choosing Database ⇒ Export. A dialog box will open asking you for the name to
be given to the ISO file. You can choose whether it should go on to the hard disk, a floppy
disk. It is customary to give the ISO file a name with the extension .iso, e.g. mar01.iso. Then
click the OK button.

A dialog box will appear as in Figure 2. The meaning of the various choices is explained
below. You can accept most (if not all) of the default values offered.

Figure 2 Export dialog box

1 Name of output ISO file. This will be the filename you have just chosen, but you can
alter it here.
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2 Field separator. If this is left blank, the program will use the ISO 2709 standard
field separator.

3 Record separator. If this is left blank, the program will use the ISO 2709 standard
field separator.

4 Export Range of MFNs / Search results/From sorted HIT file. You can limit the
records exported either by giving a range of MFN numbers or by means of a previous
search. You cannot limit by both but you can limit to marked records only. Exporting
from a sorted hit file is used to sort the records in a database into a new order.

5 Range: from MFN ... to MFN ... If you want to limit by MFN, specify the limits here,
e.g. From MFN 1 to MFN 50

6 Reformatting FST. If you do not want to reformat the records for exporting,
leave this blank.

7 Renumber records from MFN. You can make the MFNs of the exported records
start from a different value from what they start from in your database. You can
generally leave this blank.

8 Output Tag containing MFN. Sometimes you will need to transfer the MFN into
one of the tagged fields. You can choose any field number which is not already in use,
e.g. 99, and the program will copy the MFNs into that field in the exported records.

Gizmo conversion file. You can leave it blank.

When you have completed the dialog box, click the OK button. The computer should
then start to export records.

4 . IMPORTING AN ISO 2709 FILE
This section covers transferring records from a file in ISO 2709 format into a

CDS/ISIS database. The database definition must have been set up before importing records,
though the database can either be empty or already have records in it.

First open the database into which you want to import. Then choose Database ⇒
Import. You are asked for the name of the ISO file to import from - choose the correct
disk, folder and filename. Note that only filenames with the extension .iso are displayed
unless you change List files of type... to *.*. Click the OK button.

A dialog box will appear as in Figure 3. Most of the choices are similar to those
in the export dialog box.
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Figure 3 Import dialog box

1 Name of input ISO file. This will be the name of the file you wish to import.

2 First MFN to be assigned. You can normally leave this as the default value, 1. If you
make it greater than the number of records already in your database, the incoming
records will be given MFNs starting from the value specified.

3 Tag containing MFN. You can take the MFN from a numeric field present in the
ISO 2709 record being imported. This will override anything you have answered at
choice 2. The MFN will be removed from the field specified when the record has been
imported.

4 Reformatting FST. If you do not want to reformat the records during importing,
leave this blank.

5 Gizmo conversion file. As in exporting you leave it blank.

6 Input line length. This is the number of characters per line in the ISO file. 80 is the
default in the Windows version. However, if you are importing from another package
which adheres more strictly to ISO2709, there may not be any line breaks and you
should set this value to 0.

7 Subfield separator. Normally this is the circumflex ^ in CDS/ISIS.

8 Options: Load/Merge/Update. Be careful what you choose here as you could
lose an existing database! The choices are:

Merge. This means that the imported records will be added to any existing ones. If the
imported records have MFNs and these clash with existing MFNs they will not be
imported.
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Load. This means that any existing records are lost and you end up with only the
imported records. But you will be asked to confirm. OK / Cancel

Update. This works like Merge, except that if an incoming record has the same MFN as
an existing one it will overwrite the existing record, i.e. update it.

When you have completed the dialog box, click the OK button. The record(s)
should then be imported: the program displays the MFNs as it runs.

5. BACKING UP AND RESTORING A DATABASE
You should take regular backups of your database(s) to avoid loss of work when the

systems are breakdown. Before you make a backup, make sure that the inverted file is
updated. You will have to use the Windows Backup facility or a file compression program
Winzip.

6. MODIFICATION OF DATABASE
Modification of database includes changes in FDT, Worksheet, FST and Display formats

of the database.

6.1 MODIFYING THE FIELD DEFINITION TABLE
The most common type of modification is to add extra fields to the database. This entails

adding to the Field Definition Table (FDT). To do this choose Edit ⇒ Field Definition Table
from the main menu bar. This opens up the Data Base Definition - Field Table window. You
can add, delete or modify the existing fields. Click on OK when you have finished. If you add
a new field, you will also need to add it to a worksheet, a print format, and possibly to the
Field Select Table. If you delete a field from the FDT, the field will not disappear in existing
records but you will not be able to enter any more data into this field. You may therefore want
to remove it from the worksheet(s). If you have already entered data in this field in existing
records, you can change the print format(s) to stop them displaying.

6.2 MODIFYING THE WORKSHEET OR CREATING A NEW ONE

If you have added a field in the Field Definition Table, you must add it to a worksheet.
Select Edit ⇒ Data entry Worksheets and the default worksheet will be displayed. You
should see any extra field you have added displayed in the Fields window. Double Click on
the new field and that field will be added to the data entry fields box and hence to the
worksheet.

6.3 MODIFYING THE FIELD SELECTION TABLE

Select Edit ⇒ Field Selection Tables and the table will be displayed. Add the field
you want to be indexed along with all parameters Click Add. Click OK to save it.
Modifying the FST does not alter the entries for records which have been inverted
already. When you say YES to Update inverted file?, CDS/ISIS only considers records
which have been added or modified since the last update. Therefore, for the new FST to take
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effect on existing records, you will have to choose from the main menu bar Database ⇒ I/F
Update and click the Full Inverted File Generation radio button and OK.

6.4 MODIFYING OR ADDING PRINT FORMATS

This is one of the most common modifications required. Chose from the main menu
Edit ⇒ Print Formats. Select New. If you are modifying the current format then click on
the check box Don't clear current format and the current format. Give the format a new
PFT name and click OK. You will then be able to amend the format and produce a variation
on the earlier one.

7. MODIFYING THE DATA

Modifying data in the normal is explained in the data entry lesson. CDS/ISIS for
Windows has three very powerful utilities for making global changes to the database. That
means making the same change across sets of records. There are three separate functions:
Global add, Global delete and Global replace. It is always better to take the backup of the
database before using these functions. Global add will add a field to every record selected.
Global delete removes a complete field from every record Global replace replaces selected
text in a field with text required. Note that these functions cannot be opened while the Data
Entry Worksheet is open. These functions can be used by selecting Utils While database is
open. Following figures show the global add windows.

7.1 GLOBAL ADD (RANGE)

With the database open, select Utils ⇒ Global Add Range).

Enter the range of MFNs, e.g. 1/50. If you enter nothing it will add the field to every
record. Select the field tag using the spin box.

Add the text to be entered in this field.

Note that a new field will be created, for each field added. This will be created even if
the field is already present and the field is not repeatable. The field will be created even if it is
not in the FDT.

You may want the field to be created only if it is not already present. Click on Add if
not present.

How could you use this? You could add in an author field the text 'Anon.' to every
record which does not have an author field. Let's do it in the first 50 records only.

Here (Figure 4) is the screen displayed ready to run.

When you click on OK, a Progress window comes up, very useful in a very large
database, and you will see on the window the MFN of the record being processed
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Figure 4 Global Add (Range) window

Click on the completed button when it appears and then check some records to ensure it
has worked correctly.

7.2 GLOBAL DELETE (RANGE)

With the database open, select Utils ⇒ Global Delete (Range). Enter the range of
MFNs, e.g. 350/355

If you enter nothing in range, Global Edit will remove all instances through the entire
database of the field you select in the next step.

Select the field tag using the spin box. Press OK.
The field will be deleted from every record selected. Note that if you wish to delete only

certain words in a field, use Global replace (below).

7.3 GLOBAL REPLACE
Global replace allows you to search for a particular string of characters and replace them

by another string. You can limit this to particular fields, subfields or occurrences of a field.
You can get it to select text for change taking into account case or ignoring it. You can tell it
to select whole words only. You can get it to prompt you before it makes any particular
replacement.

You may enter the range of records on which you wish to make the global edit. Click on
the button and enter the range as e.g. 55/90. If you leave the MFN limits button set and do not
enter a range the global edit will not be performed; it will go through all the stages but nothing
will be changed and no error message will appear.
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If you have not made any searches in that database since opening it, Search set and
Marked Records will be greyed out. Otherwise you can select a search set for the global edit
to be done on instead of using a range.

The Marked records selection which can be used if you have just separately marked
records in the last search you made is not reliable.

You must enter the text you wish to replace in the Text to find box. If you enter
nothing you will get a message 'No text to search for'. Enter the text you wish to replace it
with in the next box. If you enter nothing there, you will get the message

You are DELETING some text!
NO NEW TEXT HAS BEEN SPECIFIED! Are you sure?

If you click on the Yes button, the text will be deleted and replaced by nothing. If you
click No the Replace Text Window will appear again with all values empty so you have to
start again. If you click on Cancel, the Global Replace utility closes.

If you click the case sensitive button the replacement will check the case of the original
and if different from that entered in Text to find it will not change it. If you click on Whole
words only it will select character strings only found between two spaces or the beginning or
end of the field. It does not change anything immediately preceded by a subfield identifier.
Thus, the will be changed if it is a complete word but not if it is another word like 'there'. It
will not change if it is at the start of a subfield.

In the Tags box you can specify replacement in one or more fields. Enter each field
separated by commas. If you want it to replace the text only in certain subfields, you can
specify as many subfields as you like: e.g. afgh, but it will change the text in any of the
subfields specified in any of the fields selected. You cannot specify to make a change in
subfield a of field 26 and subfield b in field 30. To do this you should run Global Replace
separately for each.

You can convert punctuation to a subfield identifier. Here is an example. You may
have an author in field 70 and you may wish to replace comma space by ^b in the first 100
records in your database. Let's do it only in second occurrences of the field.

Following figure shows the global replace window.
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Figure 5 Global Replace window

7.4 GLOBAL ADD (SEARCH)

To add a field to every record you have just retrieved with a particular search, with the

database open, select Utils ⇒ Global Add (Search).

Click on search set and select a search you have just made by clicking on the button at
the right of the combo box and clicking on the search

Select the field tag using the spin box. Add the text to be entered in this field.

Note that a new field will be created, for each field added. This will be created even if the
field is already present and the field is not repeatable. The field will be created even if it is not
in the FDT.

You may want the field to be created only if it is not already present. Click on Add
if not present.

When might you use this? Let's assume that every bibliographic record in a database
includes a language code in field 41. Let's say we would like to add a note 'Foreign
Language Material' in field 500 to those records describing non-English-language material.
Select those records with language code not ENG:

? v41 <> 'ENG'

Select the search set in the global edit window. Select field tag 500 and enter in the
text box
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'Foreign Language material'

and the text will be added in field 500. If field 500 is not repeatable and the field already exists,
it will still add the field, unless you click the check box Add if not present.

7.5 GLOBAL DELETE (SEARCH)

With the database open, select Utils ⇒ Global Delete (Search).

Click on Search set and select a search. If you do not select a search you will delete the field
you select in every record.

Select the field tag you wish to delete using the spin box. Choose OK.
The field will be deleted from every record selected. Note that if you wish to delete only

certain words in a field, use Global replace (10.6.3).

7.6 MODIFICATION BY EXPORTING AND IMPORTING

Another way to make changes to all the records in a database is through the export and
import functions on the Database menu. In either process you can use a field select table
(FST), which allows you to make changes to the data. In particular, if you want to move
data automatically from one field to another. This can only be done through exporting and
importing.

8. Conclusion

CDS/ISIS is a text oriented non-numeric database management software developed by
UNESCO in Pascal language. It is designed exclusively to handle library bibliographic data,
whose special features are variable fields and records, repeatable fields, unpredicted fields. The
software has best feature to export data into ISO2709 to facilitate exchange of records between
libraries. The package also provides Pascal interface to develop own programs to automate other
library house-keeping operations.
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